
Chapter 15

Surface Modeling

After completing this chapter you will be able to:
• Create Extruded surface.
• Create Revolved surface.
• Create Swept surface.
• Create Lofted surface.
• Create Planar surface.
• Create Fill surface.
• Create Radiated surface.
• Offset the surfaces.
• Trim the surfaces.
• Untrim the surfaces.
• Extend the surfaces.
• Knit the surfaces.
• Fillet the surfaces.
• Create a Mid-surface.
• Delete Holes.
• Replace the faces.
• Delete the faces.
• Move and Copy the surfaces.
• Thicken the surface body.
• Create thicken surface cut.
• Create a surface cut.

Learning Objectives
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SURFACE MODELING
Surface modeling is a technique of creating a planar or non planar geometry of zero thickness.
This zero thickness geometry is known as surface. The surfaces are generally used to create
models of complex shapes. You can convert surface models in solid models. You can also
extract a surface from a solid model using the tools available for surface modeling. This
chapter explains the surface modeling tools available in SolidWorks. Using these tools, you
can create complex shapes as surfaces and then convert them in solid models, if required.

Most of the real world components are created using solid modeling. But sometimes, you
may need to create some complex features that can only be created by surface manipulation.
This manipulation of surfaces is done using surface modeling. After creating the required
complex surface, you can convert it into a solid model. The reasons why you need to convert
a surface model into solid model is because a surface is a zero thickness geometry, and so it
has no mass and no mass properties. In real world design, many times you need mass and
mass properties of a model. The other reason is that you can generate the section view only if
the model is solid.

In SolidWorks, the surface modeling is done in the Part mode and the tools used for surface
modeling are available in the Surfaces toolbar. This toolbar is not available by default in the
Part mode. Therefore, you need to invoke it by choosing View > Toolbars > Surfaces from
the menu bar. The tools used for surface modeling are also available in the menu bar. Choose
Insert > Surface from the menu bar to invoke the surface options. You will notice that some
of the tools available in the Surfaces toolbar are the same as those discussed in solid modeling.
These tools are extrude, revolve, sweep, and loft.

The above mentioned tools and the other advanced surface modeling tools are discussed
next.

Creating an Extruded Surface

In SolidWorks, the Extruded Surface tool is provided to extrude a closed or an open
sketch to create an extruded surface. An extruded surface is created using the
Surface-Extrude PropertyManager. After creating the sketch in the sketcher

environment, choose the Extruded Surface button from the Surfaces toolbar. The
Surface-Extrude PropertyManager is displayed as shown in Figure 15-1. The preview of the
extruded surface with the default value is also displayed in the drawing area. Using the drag
handle provided in the drawing area, you can dynamically define the extrusion depth. Using
the options available in the End Condition drop-down list, you can define the feature
termination. The feature termination options available in the Direction 1 and Direction 2
rollouts and other options are the same as those discussed in part modeling.

Figure 15-2 shows a closed sketch and Figure 15-3 shows the surface created by extruding the
closed sketch. Figure 15-4 shows an open sketch and Figure 15-5 shows the surface created by
extruding that open sketch.

Toolbar: Surfaces > Extruded Surface
Menu: Insert > Surface > Extrude
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Figure 15-2  A closed sketch Figure 15-3  Surface created by extruding the closed
sketch

Figure 15-4  An open sketch Figure 15-5  Surface created by extruding an open
sketch

Figure 15-1  The Surface-Extrude PropertyManager

c15-solidworks-2003.p65 7/21/2003, 6:49 PM3



15-4                           SolidWorks for Designers
©

 C
A

D
C

IM
 T

ec
hn

ol
og

ie
s,

 U
S

A
. 

Fo
r 

en
gi

ne
er

in
g 

se
rv

ic
es

, 
co

nt
ac

t 
sa

le
s@

ca
dc

im
.c

om

Creating a Revolved Surface

You can also create a surface by revolving a closed or an open sketch along a centerline.
Revolving a sketch along a centerline to create a surface is similar to revolving a
sketch along a centerline to create a solid feature. To create a revolved surface, choose

the Revolved Surface button from the Surfaces toolbar after creating the sketch and the
centerline in the sketching environment. The Surface-Revolve PropertyManager will be
displayed as shown in Figure 15-6. The preview of the revolved surface with the drag handle
is displayed in the drawing area. The feature termination options and other options are
similar to those discussed while revolving a solid feature.

Figure 15-7 shows an open sketch for creating a revolve surface. Figure 15-8 shows the resultant
revolve surface.

Toolbar: Surfaces > Revolved Surface
Menu: Insert > Surface > Revolve

Figure 15-6  The Surface-Revolve PropertyManager

Figure 15-7  Sketch for creating a revolve surface Figure 15-8  Surface created by revolving a
sketch through an angle of 270-degree

c15-solidworks-2003.p65 7/21/2003, 6:49 PM4
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Creating a Swept Surface

You can also create a sweep surface by sweeping a closed or an open profile along a
closed or an open path. To create a swept feature, choose the Swept Surface button
from the Surfaces toolbar. The Surface-Sweep PropertyManager is displayed as shown

in Figure 15-9. You are prompted to select a sweep profile. Select a closed sketch or an open
sketch as the profile of the sweep feature. Next, you are prompted to select the sweep path.
Select a closed or an open sketch as the sweep path. The preview of the sweep feature will be
displayed in the drawing area.

You can also select the guide curves while creating the sweep surface. All the other options
used to create a sweep surface are similar to those discussed while creating the solid sweep
feature. Figure 15-10 shows an open profile and an open sketch and Figure 15-11 shows the
resultant sweep surface. Figure 15-12 shows a closed profile and an open path and Figure 15-13
shows the resultant sweep surface Figure 15-14 shows an open profile and closed path and
Figure 15-15 shows the resultant sweep surface.

Toolbar: Surfaces > Swept Surface
Menu: Insert > Surface > Sweep

Figure 15-9  The Surface-Sweep PropertyManager
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Figure 15-12  Closed profile and open path Figure 15-13  Resultant sweep surface

Figure 15-10  Open profile and open path Figure 15-11  Resultant sweep surface

Figure 15-14  Open profile and closed path Figure 15-15  Resultant sweep surface
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Figure 15-18  Profile, path, and guide curves Figure 15-19  Resultant sweep feature

Figure 15-16  Closed profile and closed path Figure 15-17  Resultant sweep surface

Figure 15-16 shows a closed profile and a closed path and Figure 15-17 shows the resultant
sweep surface.

Figure 15-18 shows the profile, path, and the guide curves and Figure 15-19 shows the resultant
sweep surface.

Creating a Lofted Surface

In SolidWorks, you can also create a surface by lofting two or more sections. To create
a lofted surface, choose the Lofted Surface button from the Surfaces toolbar. The
Surface-Loft PropertyManager is invoked as shown in Figure 15-20 and you are

prompted to select at least 2 profiles. Select the profiles to be lofted. All the options of creating
a lofted surface are similar to those are discussed while creating a solid lofted feature.

Remember that if you need to create the loft surface with open section, then all the sections to

Toolbar: Surfaces > Lofted Surface
Menu: Insert > Surface > Loft
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Figure 15-21  Open sections Figure 15-22  Resultant lofted surface

Figure 15-20  The Surface-Loft PropertyManager

be lofted must be open. Similarly, if you need to create a closed lofted surface, then all the
sections must be closed. The combination of closed and open sections in a loft surface is not
possible. Figure 15-21 shows two open sections to be lofted and Figure 15-22 shows the resultant
lofted surface.

Figure 15-23 shows two closed sections to be lofted and Figure 15-24 shows the resultant
lofted surface. Figure 15-25 shows two sections and the centerline and Figure 15-26 shows the
resultant lofted surface.

c15-solidworks-2003.p65 7/21/2003, 6:49 PM8



Surface Modeling       15-9

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. 
Fo

r 
en

gi
ne

er
in

g 
se

rv
ic

es
, 

co
nt

ac
t 

sa
le

s@
ca

dc
im

.c
om

Figure 15-23  Closed sections Figure 15-24  Resultant lofted surface

Figure 15-25  Sections and centerline Figure 15-26  Resultant lofted surface

Figure 15-27 shows two sections and the guide curves and Figure 15-28 shows the resultant
lofted surface.

Creating a Planar Surface

A planar surface is generally used to fill the gaps between the surfaces using a planar
patch. To create a planar surface, you need to choose the Planar Surface button from
the Surfaces toolbar or choose Insert > Surface > Planar from the menu bar. The

Planar Surface PropertyManager is displayed as shown in Figure 15-29 and you are prompted
to select a sketch, edge, or curve.

Tip. You do not need to add Pierce constraint if you are lofting the sections using
the centerline.

Toolbar: Surfaces > Planar Surface
Menu: Insert > Surface > Planar

c15-solidworks-2003.p65 7/21/2003, 6:49 PM9
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After invoking the Planar Surface PropertyManager, you need to select the bounding entities.
The bounding entities can be sketch, edges, or curves. Select the bounding entities, the name
of the bounding entity is displayed in the Bounding Entities rollout. After selecting the
bounding entities, choose the OK button from the Planar Surface PropertyManager. A planar
surface will be created using the selected entities.

Creating a Fill Surface

The Filled Surface tool is used to create a surface patch along N number of sides.
The sides to be selected for creating a fill surface can be the edges of the existing
model, 2D or 3D sketch entities, or 2D or 3D curves. The difference between planar

surface and fill surface is that you cannot create planar surface using 3D curves or edges. For
example, the 3D edge created in Figure 15-30 cannot be used to create planar surface. But
you can fill this gap by creating a fill surface on the 3D edge.

To create a fill surface, choose the Filled Surface button from the Surfaces toolbar. The Fill

Figure 15-29  The Planar Surface PropertyManager

Toolbar: Surfaces > Filled Surface
Menu: Insert > Surface > Fill

Figure 15-27  Sections and guide curves Figure 15-28  Resultant lofted surface

c15-solidworks-2003.p65 7/21/2003, 6:49 PM10
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Figure 15-31  The Fill Surface PropertyManager

Surface PropertyManager is displayed as shown in Figure 15-31 and you are prompted to
select the bounding entities and set the options. Select entities which will define the boundary.

Figure 15-30  Entities selected for creating a fill surface

c15-solidworks-2003.p65 7/21/2003, 6:49 PM11
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Figure 15-32  Preview of the fill surface along
with mesh

Figure 15-33  Resultant fill surface

The selected entities are displayed in green and the callouts attached to them are also displayed.
After selecting the last entity that will close the current selection chain, the preview of the
surface is displayed in the drawing area and the mesh is also displayed. Now, choose the OK
button from the Fill Surface PropertyManager. Figure 15-32 shows the preview of the fill
surface along with the mesh and Figure 15-33 shows the resultant fill surface.

Note
The surface model used in the above example is created by trimming the surface. You will learn
about trimmed surfaces later in this chapter.

The other options available in the Fill Surface PropertyManager are discussed next.

Edge settings
The options available in the Edge settings area are used to define various parameters to
specify the references with respect to the selected edges, type of curvature, and so on. These
options are discussed next.

Alternate Face
The Alternate Face button available in the Edge settings area is used to specify the face
reference to be included while creating a fill surface for controlling the curvature of the
fill surface. This option is only used when you are creating a fill surface on a solid body.

Curvature Control
The Curvature Control drop-down list is used to define the type of curvature you need to
apply on the fill surface that you are creating. There are two types of curvatures that you
can apply, these two types of curvatures are discussed next.

Contact
The Contact option is selected by default and is used to create a patch using the fill
surface option within the selected patch boundary.

c15-solidworks-2003.p65 7/21/2003, 6:49 PM12
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Tangent
The Tangent option is used to create a patch using the fill surface option within the
selected patch boundary but it also maintains the tangency of the patch created with
the selected edges. When you use this option for creating a patch, the Reverse Surface
button is also displayed. Using this button, you can reverse the direction of the surface
created.

Figure 15-34 shows the circular edge selected as patch boundary. Figure 15-35 shows
the fill surface created using the Contact option selected from the Curvature Control
drop-down list. Figure 15-36 shows the fill surface created using the Tangent option
selected from the Curvature Control drop-down list.

Figure 15-34  Edge selected as patch boundary

Figure 15-35  Fill surface created using the
Contact option

Figure 15-36  Fill surface created using the
Tangent option

c15-solidworks-2003.p65 7/21/2003, 6:49 PM13
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Apply to all edges
This option is used to apply the curvature settings discussed earlier to all the edges. If
this check box is not selected, the current curvature setting is only applied to the edge of
the boundary selected in the Patch boundary display area.

Optimize surface
The Optimize surface option is used to create the simplest patch of surface along the
selected patch boundary. The Optimize surface check box is selected by default. When
you create a surface patch using the Optimize surface check box selected, the time taken
to create the surface is less and the model rebuilds faster. When you clear this check box,
the Resolution Control rollout is displayed as shown in Figure 15-37. The slider available
in this rollout is used to specify the resolution of the fill surface. The higher the resolution,
better will be the quality of the surface and the more time it will take to rebuild the model.
Lower the resolution, the quality of the surface will not be good. However in this case, the
rebuilding of the model will take lesser time.

Show Preview
The Show Preview check box is selected by default and is used to display the preview of
the fill surface created using the selected patch boundary.

Preview Mesh
The Preview Mesh check box is selected by default and is used to display the mesh
surface in the preview of the fill surface. This option is only available if the Show Preview
check box is selected earlier.

Constraint Curves
The Constraint Curves rollout is used to define the constraint curves while creating the fill
surface. To create a fill surface using the constraining curves, invoke the Fill Surface
PropertyManager and then select the patch boundary. Now, click once in the Constraint
Curves area of the Constraint Curves rollout to invoke the selection mode and then select
the constraint curves. The constraint curve to be selected can be a sketched entity, edge, or a
curve. The select constraint curve is displayed in red and the callout is displayed attached to
it. The name of the selected entity is displayed in the Constraint Curve display area. The
preview of the fill surface modifies as you select the constraint curves. After specifying all the
constraint curves, choose the OK button from the Fill Surface PropertyManager.
Figure 15-38 shows the sketches selected for patching the boundary and the constraint
curves. Figure 14-39 shows the resultant fill surface.

Figure 15-37  The Resolution Control rollout

c15-solidworks-2003.p65 7/21/2003, 6:49 PM14
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Creating a Radiated Surface

In SolidWorks, you can also create a surface by radiating a surface along an edge or
edges or a split line. The radiated surface is always created parallel to the plane or
face selected as radiate direction reference. This type of surface is generally used in

mold design as the parting surface for extracting the core and cavity. For creating a radiated
surface, choose the Radiate Surface button from the Surfaces toolbar. The Radiate Surface
PropertyManager is displayed as shown in Figure 15-40.

Toolbar: Surfaces > Radiate Surface
Menu: Insert > Surface > Radiate

Figure 15-40  The Radiate Surface PropertyManager

Figure 15-38  Sketches to be selected for patching
the boundary and the constraint curves

Figure 15-39  Resultant fill surface

c15-solidworks-2003.p65 7/21/2003, 6:49 PM15
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You will observe that the selection is active in the Radiate Direction Reference display area.
Therefore, first you need to select a plane or a planar face parallel to which the surface will be
radiated. The selected reference will be highlighted in green and an arrow symbol normal to
the selected face will be displayed. Now, the selection mode in the Edges to Radiate display
area is invoked and you need to select the edges along which the surface will be radiated.
Select the edges. The name of the selected edges is displayed in the Edges to Radiate display
area and the arrows showing the direction in which the surface will be radiated is also displayed
attached to the selected edges. Now, set the value of the distance of the surface to radiate in
the Radiate Distance spinner. After setting the radiate distance, choose the OK button from
the Radiate Surface PropertyManager.

The Propagate to tangent faces check box is used to radiate the surfaces along all the edges
that are tangent to the selected edge.

Figure 15-41 shows the radiate direction reference and the edge to be selected. Figure 15-42
shows the resultant radiated surface with the Propagate to tangent faces check box selected.

Offsetting the Surfaces

The Offset Surface tool is used to offset the selected surface or surfaces to a given
distance. For offsetting a surface, choose the Offset Surface button from the Surfaces
toolbar. The Offset Surface PropertyManager is displayed as shown in Figure 15-43

and you are prompted to select a face or a surface to offset.

Now, select the face or surface that you need to offset. The selected face or surface is highlighted
in green and its name is displayed in the Surface or Faces to Offset display area. The preview
of the offset surface with the default value is also displayed in the drawing area. Set the value
of the offset distance using the Offset Distance spinner. You can also flip the direction of the
surface creation using the Flip Offset Direction button available on the left of the Offset

Toolbar: Surfaces > Offset Surface
Menu: Insert > Surface > Offset

Figure 15-41  Reference and edge to be selected Figure 15-42  Resultant radiated surface with the
Propagate to tangent faces check box selected

c15-solidworks-2003.p65 7/21/2003, 6:49 PM16
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Figure 15-43  The Offset Surface PropertyManager

Figure 15-44  Surface selected to offset Figure 15-45  Resultant offset surface

Direction spinner. After setting all the parameters, choose the OK button from the Offset
Distance PropertyManager. Figure 15-44 shows the surface selected to offset and Figure 15-45
shows the resultant offset surface.

Trimming the Surfaces

The Trimmed Surface tool is used to trim the surface using a trim tool. A trim tool
can be a surface, sketched entity, or an edge. To trim a surface, choose the Trimmed
Surface button from the Surfaces toolbar. The Trim Surface PropertyManager is

displayed as shown in Figure 15-46 and you are prompted for selecting a trimming surface or
sketch followed by the pieces to keep.

Tip. If you need to extract a surface from the solid or a surface body without
specifying the offset distance, then invoke the Offset Surface PropertyManager
and select the surfaces that you need to extract. Set the value of the Offset Distance
spinner to 0 and choose the OK button from the Offset Surface PropertyManager.

Toolbar: Surfaces > Trimmed Surface
Menu: Insert > Surface > Trim

c15-solidworks-2003.p65 7/21/2003, 6:49 PM17
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Figure 15-46  The Trim Surface PropertyManager

The Trim tool radio button is selected by default. The trimming of surfaces using this option
is discussed next.

When you invoke this tool, you will notice that the cursor is replaced by the trim tool cursor.
Select the trimming surface using this cursor. You can select a surface, sketch, or an edge. The
selected entity is highlighted in green and the name of the trimming surface is displayed in
the Trimming Surfaces display area. The selection mode in the Pieces to keep display area is
active and you are prompted to select the pieces to keep. Also, the cursor is replaced by the
surface body cursor. Move the cursor on the surface that is being trimmed, the pieces of the
surface on which you place the cursor are displayed in blue. Select the piece or pieces of the
surface to keep. The selected pieces will be displayed in yellow and their names will be displayed
in the Pieces to keep display area. Choose the OK button from the Trim Surface
PropertyManager.

Figure 15-47 shows the trimming surface and the piece to keep after trimming. Figure 15-48
shows the resultant trimmed surface. Figure 15-49 shows the sketch selected as a trimming
surface and Figure 15-50 shows the resultant trimmed surface.

The other method of trimming a surface is known as Mutual trim method. In this method,
you need to select two surfaces as trimming surfaces. To trim the surfaces using this method,
invoke the Trim PropertyManager and then choose the Mutual trim radio button from the
Trim Type rollout. You are prompted to select the surfaces to trim, followed by the pieces to
keep. Select the trimming surfaces and then select the pieces to keep, refer to Figure 15-51
and choose the OK button from the Trim PropertyManager. Figure 15-52 shows the resultant
trimmed surface.

c15-solidworks-2003.p65 7/21/2003, 6:49 PM18
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Figure 15-47  Trimming surface and piece to
keep after trimming the surface

Figure 15-48  Resultant trimmed surface

Figure 15-51  Surfaces to trim and the pieces to
keep

Figure 15-52  Resultant trimmed surface

Figure 15-49  Sketch selected as trimming surface Figure 15-50  Resultant trimmed surface

c15-solidworks-2003.p65 7/21/2003, 6:49 PM19
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Figure 15-53  The Untrim Surface PropertyManager

Untrimming the Surface

The Untrim Surface tool is used to create a surface patch by extending the existing
surfaces. Using this option, the trimmed portion of a surface is filled with a surface
patch. To untrim a surface, choose Insert > Surface > Untrim from the menu bar.

You can also use the Untrim Surface button from the Surfaces toolbar, but you first need to
customize this button. As you invoke this tool, the Untrim PropertyManager is
invoked as shown in Figure 15-53 and you are prompted to select surface bodies or edges of
surface for the Untrim operation.

There are two methods of untrimming the surfaces. In the first method, you will select the
face that you need to untrim and in the second method you will select the edges of the
trimmed portion of the surface. Both these methods are discussed next.

Untrimming by Selecting the Faces
In this method you will untrim the surface by selecting the face or faces of the surface to
untrim. Invoke the Untrim PropertyManager and select the face of the surface that you need
to untrim. The preview of the untrimmed surface with default settings is displayed in the
drawing area. Additional options are also displayed in the Options rollout as shown in
Figure 15-54. These options are discussed next.

Face untrim type
The Face untrim type area is used to specify the type of edges along which you need to
untrim the surface. The options available in this area are discussed next.

All edges
The All edges radio button is selected by default. Therefore, all the internal and

Toolbar: Surfaces > Untrim Surface (Customize to Add)
Menu: Insert > Surface > Untrim
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Figure 15-54  The Options rollout

Figure 15-55  Surfaces selected to untrim Figure 15-56  Resultant untrimmed surface
with the All edges radio button selected

external edges of the selected surface are extended to be untrimmed. Figure 15-55
shows the surface to be selected and Figure 15-56 shows the untrimmed surface using
the All edges radio button selected.

Internal edges
The Internal edges radio button is used if you need to patch only the internal edges
of the selected surface using the Untrim Surface tool. Figure 15-57 shows the
untrimmed surface created with the Internal edges radio button selected.

External edges
The External edges radio button is used if you need to patch only the external edges
of the selected surface using the Untrim Surface tool. Figure 15-58 shows the
untrimmed surface created with the External edges radio button selected.

Merge with original
The Merge with original check box is selected to merge the surface created using this
tool with the original surface. This check box is selected by default. If you clear this check
box, the resultant untrimmed surface will be a separate surface body.

You can also specify the percentage of distance to which you need to extend the surface
depending on the edges type selected from the Face untrim type area of the Options
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rollout. The Distance spinner is used to define the percentage distance of extension of
surface. The preview of the surface extension is displayed in the drawing area.

Untrimming by Selecting the Edges
You can also patch a trimmed surface using the Untrim Surface tool by selecting the edges of
the trimmed portion of the surface. Invoke the Untrim Surface PropertyManager and select
the edge of the surface along which you need to patch the trimmed surface. Now, select the
edge, additional options in the Options rollout are displayed as shown in Figure 15-59. The
options available in this rollout are discussed next.

Edge untrim type
The Edge untrim type area is used to specify the options to patch the trimmed surface
using the selected edges. The options available in this rollout are discussed next.

Extend edges
The Extend edges radio button is selected by default and it extends the edge to
create a corner to untrim the trimmed surface.

Connect endpoints
The Connect endpoints radio button is used to patch the trimmed surface by joining
the endpoints of the selected edge.

Figure 15-59  The Options rollout displayed when the Edge is
selected to be patched using the Untrim Surface tool

Figure 15-58  Resultant untrimmed surface
with the External edges radio button selected

Figure 15-57  Resultant untrimmed surface
with the Internal edges radio button selected
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Figure 15-60  Edge selected for untrimming the surface

Figure 15-61  Untrimmed surface created
with Extend edges radio button selected

Figure 15-62  Untrimmed surface created with
Connect endpoints radio button selected

Figure 15-60 shows the edge to be selected for untrimming a surface. Figure 15-61 shows
an untrimmed surface created using the Extend edges check box selected. Figure 15-62
shows the untrimmed surface created using the Connect endpoints check box selected.

Extending the Surfaces

The Extended Surface tool is used to extend the surface along the selected edge or
the selected face. To extend the surface, choose the Extended Surface button from
the Surfaces toolbar. The Extend Surface PropertyManager is displayed as shown in

Figure 15-63 and you are prompted to select a face or edge(s) and set the properties. There
are two options of extending a surface, both of which are discussed next.

Toolbar: Surfaces > Extended Surface
Menu: Insert > Surface > Extend
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Figure 15-63  The Extend Surface PropertyManager

Extending using Same surface Option
When you extend a surface using the Same surface option, the surface is extended by
maintaining the curvature. To extend the surface using the Same surface option, invoke the
Extend Surface PropertyManager. You will observe that the Same surface radio button
is automatically selected in the Extension Type rollout. Now, you need to select the edge or
the face that you need to extend. Note that when you select the face to extend the surface, the
surface will extend equally in all the directions. Using the drag handle, extend the surface
dynamically or set the extending distance in the Distance spinner. You can also use the other
feature termination options available in the End Condition rollout.

Figure 15-64 shows the edge selected to extend the surface. Figure 15-65 shows the preview of
the surface being extended by selecting the edge with the Same surface radio button selected.
Figure 15-66 shows the face selected to extend the surface. Figure 15-67 shows the preview of
the surface being extended by selecting the face with the Same Surface radio button selected.

Note
If any edge of the selected surface is merged with another surface, the surface will not be extended
along that edge.

Extending the Surface in the Linear Direction to An Existing Surface
To extend the surface in the linear direction to an existing surface by maintaining the tangency,
invoke the Extend Surface PropertyManager and select the Linear radio button from the
Extension Type rollout. Now, select the face or the edge along which you need to extend the
surface and specify the feature termination using the End Condition rollout.
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Figure 15-64  Edge selected to extend the surface Figure 15-65  Preview of the extended surface
with the Same surface radio button selected

Figure 15-66  Face selected to extend the surface Figure 15-67  Preview of the extended surface
with the Same surface radio button selected

Figure 15-68 shows the edge selected to extend the surface and Figure 15-69 shows the preview
of the surface being extended with the Linear radio button selected. Figure 15-70 shows the
face selected to extend the surface and Figure 15-71 shows the preview of the surface being
extended with the Linear radio button selected.
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Figure 15-70  Face selected to extend the surface Figure 15-71  Preview of the extended surface
with the Linear radio button selected

Knitting the Surfaces

Using the Knit Surface tool you can knit the surfaces together to create a single
surface. You can also knit a surface with the faces of a solid body. The surfaces that
you need to knit together must have contact with each other. You cannot knit the

disjoint surfaces or faces. The knit surface option is widely used while extracting core and
cavity while designing a mold. To knit the surfaces, choose the Knit Surface button from the
Surfaces toolbar, the Knit Surface PropertyManager is invoked as shown in Figure 15-72.

You are prompted to select the surfaces to knit. Select the surfaces that you need to knit, the
names of the surfaces are displayed in the Surfaces and Faces to Knit display area. After
selecting all the surfaces and faces choose the OK button from the Knit Surface
PropertyManager.

Toolbar: Surfaces > Knit Surface
Menu: Insert > Surface > Knit

Figure 15-68  Edge selected to extend the surface Figure 15-69  Preview of the extended surface
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Figure 15-72  The Knit Surface PropertyManager

Filleting the Surfaces

Filleting the surfaces is the same as discussed earlier while filleting the solid models.
All the options are the same except some exceptions. These exceptions are discussed
next.

1. You cannot create a variable radius on the fillet edges.

2. While applying the face fillet to the surface, you need to define the direction in which you
need to add the fillet.

3. You cannot use the Keep features option while filleting a surface.

4. You cannot select the surface using the FeatureManager Design Tree to fillet all the
edges in a surface.

Note
You can only fillet the edge of the surface which is created using the intersection of the two
surfaces. You need to make sure that if the edge is created using two surfaces then you must knit
them before filleting them. You will learn more about knitting the surfaces later in this chapter.

Creating a Mid-Surface

The Mid-Surface tool is used to create a surface between the two offset faces of a solid
model. You can define the placement position of the surface in terms of percentage
from the face selected first. The faces to be selected to create a mid surface should be

offset from each other, such as two parallel faces or two concentric curved faces. To create a
mid surface, choose the Mid-Surface button from the Surfaces toolbar. The MidSurface1
PropertyManager is displayed as shown in Figure 15-73.

Toolbar: Features > Fillet
Menu: Insert > Surface > Fillet/Round

Toolbar: Surfaces > Mid-Surface
Menu: Insert > Surface > Mid Surface
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Figure 15-73  The MidSurface1 PropertyManager

You are prompted to select face pairs manually or use Find Face Pairs to automatically recognize
face pairs. Select the face between which you need to create the surface. The first selected face
will be highlighted in green and the second selected face will be highlighted in red and the
names of the selected faces will be displayed in the Face pairs display area. You can also set
the position of the mid surface. By default, the mid surface is placed in the middle of the
selected faces. You can also define the percentage distance of the placement of the mid surface
using the Position spinner. The position of the mid surface is defined from the first
selected surface. After setting all the parameters, choose the OK button from the Mid-Surface1
PropertyManager.

Figure 15-74 shows the offset faces being selected and Figure 15-75 shows the mid surface
created in the middle of the selected faces.

The Find Face Pairs button is used to find the faces that are adjacent to the selected face. The
options available in the Recognition threshold area are used to filter the faces depending on
the wall thickness of the face searched using the Find Face Pairs option. Using the Threshold
Operator drop-down list, you can set the mathematical operator such as >, <, =, and so on.
Using the Threshold Thickness spinner, you can specify the threshold thickness.
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Figure 15-74  Offset faces selected Figure 15-75  Resultant mid surface created

Deleting the Holes in the Surfaces
Using this option, you can delete the closed contours that cut the surface. The closed contours
can be in any shape. For deleting a contour, select any one edge of the contour from the
drawing area and invoke the shortcut menu. Choose the Delete option from the shortcut
menu, the Choose Option dialog box is displayed as shown in Figure 15-76.

The Delete Hole(s) radio button is selected by default. Using this option, the empty area of
the selected contour is patched and it also maintains the tangency and curvature with the
surrounding surfaces. You will notice that the icon of the DeleteHole is displayed in the
FeatureManager Design Tree. If you select the Delete Feature radio button, the feature
associated with that contour is deleted. After selecting this option, when you choose the OK
button from the Choose Option dialog box, the Confirm Delete dialog box is displayed and
you are informed about the name of the feature to be deleted and the names of the dependent
item that will also be deleted.

Figure 15-77 shows the edge of the closed contour to be selected. Figure 15-78 shows the hole
deleted using the delete feature option.

Figure 15-76  The Choose Option dialog box
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Replacing the Faces

In SolidWorks, you can also replace the selected faces of a solid body with one or
more surfaces. When you replace the selected faces with another surface or surfaces,
the resultant solid body will retain the shape of the replacement surface by adding or

subtracting the material from the solid body. To use this option, choose the Replace Face
button from the Surfaces toolbar, the Replace Face1 PropertyManager is displayed as shown
in Figure 15-79.

Select the face that you need to replace, the name of the selected face is displayed in the
Target faces for replacement area. Now, click once in the Replacement surface(s) display
area to invoke the selection environment in this area. Now, select the replacement surface,
the name of the replacement surface is displayed in the Replacement surface(s) display area.
Choose the OK button from the Replace Face1 PropertyManager.

Toolbar: Surfaces > Replace Face
Menu: Insert > Face > Replace

Figure 15-79  The Replace Face1 PropertyManager

Figure 15-77  Edge to be selected to delete the hole Figure 15-78  Resultant surface
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Figure 15-80  Target face and the replacement surface

Figure 15-80 shows the target face that is to be replaced and the replacement surface.
Figure 15-81 shows the resultant replaced face. Figure 15-82 shows the solid body after hiding
the surface body. For hiding the surface body, select the surface body and invoke the shortcut
menu. Choose the Hide Surface Body option from the shortcut menu.

Deleting the Faces

The Delete Face tool is used to delete the faces of the selected surface or solid body.
When you delete the face of a solid body, it is converted into a surface body. If you
patch the deleted face, then the solid body is not converted into a surface body. To

Toolbar: Surfaces > Delete Face
Menu: Insert > Face > Delete

Figure 15-81  Resultant replaced face Figure 15-82  Model after hiding the surface
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Figure 15-83  The Delete Face PropertyManager

delete a face, choose the Delete Face button from the Surfaces toolbar. The Delete Face
PropertyManager is displayed as shown in Figure 15-83.

Now, you need to select the face or faces to be deleted. The name of the selected face is
displayed in the Faces to delete display area. Since the Delete and Patch radio button is
selected by default in the Options rollout, the preview of the patch to be created after deleting
the faces is displayed. If the preview of the patch is not displayed, it is confirmed that deleting
and patching the selected face is not possible. In this case, you need to select the Delete radio
button from the Options rollout so that the face is only deleted and not patched. After setting
all the parameters, choose the OK button from the Delete Face PropertyManager.

Figure 15-84 shows the face selected to be deleted. Figure 15-85 shows the face deleted with
the Delete and Patch radio button selected. Figure 15-86 shows the face deleted with the
Delete radio button selected and it forms a surface body.

Moving and Coping the Surfaces
You can move and copy the surface bodies using the Move/Copy Bodies tool. Moving and
coping the surface bodies using the Move/Copy Bodies tool is similar to that discussed in
moving and coping the solid bodies.

Note
You can also delete the surface bodies using the Delete Body PropertyManager. The procedure
of deleting the surface bodies is similar to that discussed for deleting the solid bodies.

Tip. You can also delete a face by selecting a face and then invoking the shortcut
menu. Choose the Delete Face option from the shortcut menu. The Delete Face
PropertyManager is displayed.
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Figure 15-84  Target face and the replacement surface

Mirroring the Surface Bodies
You can also mirror the surface bodies using the Mirror tool. The procedure of mirroring the
surface bodies is the same as that discussed for mirroring the solid bodies.

Adding Thickness to the Surface Bodies

In SolidWorks, you can also add thickness to the surface bodies. There are two methods of
adding thickness to the surface bodies. In the first method, you will add wall thickness to the
surface body. In the second method, you will solidify the closed stitched surface body to create
a solid body. These two methods of adding thickness to the surface bodies are discussed next.

Figure 15-85  Face deleted with the Delete and
Patch radio button selected

Figure 15-86  Face deleted with the Delete radio
button selected and it forms a surface body

Menu: Insert > Boss/Base > Thicken
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Figure 15-87  The Thicken PropertyManager

Figure 15-88  Surface to thicken Figure 15-89  Model after thickening the surface

Tip. If the surface model that you need to thicken consists of multiple joined surface
bodies, then you first need to knit the surfaces together and then add thickness to
them.

Adding Thickness to the Surface Body
To add thickness to a surface body choose Insert > Boss/Base > Thicken from the menu bar.
The Thicken PropertyManager is invoked as shown in Figure 15-87. You are prompted to
select surface to thicken. Select the surface that you need to thicken. The preview of the
thickened body with default values is displayed in the drawing area. Using the buttons available
in the Thickness area, you can specify the side on which you need to thicken the surface.
Using the Thickness spinner, you can specify the wall thickness. After setting all the parameters,
choose the OK button from the Thicken PropertyManager.

Figure 15-88 shows the surface body and Figure 15-89 shows the model after adding thickness
to the surface body.
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Solidifying a Closed Surface Body
To solidify a closed surface body, the surface body should be exempted from any type of gap
and all the surfaces should be stitched together using the Knit tool. To solidify the surface
body, invoke the Thicken PropertyManager and select the closed surface body. The Create
solid from enclosed volume check box is displayed. Select this check box, the option available
in the Thickness area and the Thickness spinner are no more available. Choose the OK
button from the Thicken PropertyManager. The solid volume from the closed surface is
created.

Creating a Thicken Surface Cut

In SolidWorks, you can create a thicken surface cut. To create a thicken surface cut, choose
Insert > Cut > Thicken from the menu bar. The Cut-Thicken PropertyManager is displayed
as shown in Figure 15-90.

You are prompted to select surface to thicken. Select the surface that you need to use as the
cutting tool and then specify the parameters for defining the side in which you need to add
the thickness and the thickness of cut. The preview is displayed in the drawing area. Now,
choose the OK button from the Cut-Thicken PropertyManager. If the thicken cut results in
creation of multiple bodies, the Bodies to Keep dialog box as displayed. Using this dialog
box, you can define the bodies that you need to keep.

Figure 15-91 shows the surface selected for creating thicken cut. Figure 15-92 shows the
resultant thicken cut.

Creating a Surface Cut

In SolidWorks, you can also cut a solid body using a surface. To create this type of surface cut,
choose Insert > Cut > With Surface from the menu bar. The SurfaceCut PropertyManager
is displayed as shown in Figure 15-93.

Figure 15-90  The Cut-Thicken PropertyManager

Menu: Insert > Cut > Thicken

Menu: Insert > Cut > With Surface
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You are prompted to select cutting surface. Select the cutting surface, the name of the selected
surface is displayed in the Selected surface for cut display area. An arrow is also displayed
that indicates the direction of material removal. Using the Flip Cut button, you can flip the
direction of material removal. Now, choose the OK button from the SurfaceCut
PropertyManager. Figure 15-94 shows the surface selected to create a surface cut. Figure 15-95
shows the resultant surface cut after hiding the surface body.

Figure 15-93  The SurfaceCut PropertyManager

Figure 15-94  Surface selected to create the
surface cute

Figure 15-95  Resultant surface cut after hiding
the surface body

Figure 15-91  Surface to be selected Figure 15-92  Resultant thicken surface cut
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Tip. If the surface cut results in the creation of multiple bodies, then the Bodies to
Keep dialog box is displayed after exiting the SurfaceCut PropertyManager.

If you create a thicken surface cut or a surface cut on multiple solid bodies, then the
Feature Scope rollout is displayed and you can specify the bodies on which you
need to add this feature.

TUTORIALS

Tutorial 1
In this tutorial, you will create the model shown in Figure 15-96. Create this model using the
surface modeling tools available in SolidWorks and then add the wall thickness to the surface
model. The views and dimensions of the model are shown in Figure 15-97.

         (Expected time: 1hr)

The steps to be followed to complete this tutorial are discussed next.

a. Create the base surface of the model by revolving the sketch using the Mid Plane option
to 180-degree, refer to Figures 15-98 and 15-99.

b. Create the second feature, which is an extruded surface feature located at the sides of the
base feature, refer to Figures 15-100 and 15-101.

c. Using the trim tool, trim the extruded surface, refer to Figures 15-102 and 15-103.
d. Add the fillet to the trimmed base surface, refer to Figures 15-104 and 15-105.
e. Create a plane at an offset distance of 40 from the Top plane.
f. Create a lofted surface by lofting the section created on the newly created plane and the

curve projected on the base surface, refer to Figures 15-106 through 15-110.
g. Create a planar surface on the top of the lofted feature and trim the base feature using

Figure 15-96  Model for Tutorial 1
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Figure 15-97  Views and dimensions for the model of Tutorial 1

the lofted feature, Figures 15-111 and 15-112.
h. Trim and knit all the surfaces together, refer to Figure 15-113.
i. Add the fillets to the surface model, refer to Figure 15-114.
j. Add the thickness to the knitted surface, Figure 15-115.

Creating the Base Surface
For creating this model, first you need to create the base surface. The base surface will be
created by revolving a sketch created on the Front plane.

1. Start SolidWorks and create a new SolidWorks document in the Part mode.

2. Invoke the sketcher environment using the Front plane as the sketching plane and create
the sketch of the base surface as shown in Figure 15-98.

3. Choose the Revolve Surface tool from the Surfaces toolbar. The Surface-Revolve
PropertyManager is invoked.
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Figure 15-98  Sketch of the base surface Figure 15-99  Base revolved surface

4. Select the Mid-Plane option from the Revolve Type drop-down list and set the value of
the Angle spinner to 180.

5. Choose the OK button from the Surface-Revolve PropertyManager. Figure 15-99 shows
the base feature after revolving the sketch created on the Front plane.

Creating the Second Surface Feature
The second surface feature will be an extruded surface. This surface will be created by
extruding a sketch created on the Top plane.

1. Using the Top plane, invoke the sketching environment.

2. Create the sketch of the second surface feature as shown in Figure 15-100. You may have
to apply Horizontal or Vertical relations between the points of the ellipse.

3. Choose the Extruded Surface button from the Surfaces toolbar. The Surface-Extrude
PropertyManager is displayed.

4. Set the value of the Depth spinner to 40 and choose the OK button from the
Surface-Extrude PropertyManager.

Surface created after extruding the sketch is displayed in Figure 15-101.

Trimming the Base Surface using the Extruded Surface
Next, you need to trim the unwanted portion of this surface model. You will trim the base
surface using the extruded surface.

1. Choose the Trimmed Surface button from the Surfaces toolbar to invoke the
Trim Surface PropertyManager.

2. Select the Mutual trim radio button from the Trim Type rollout.
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3. Select the surfaces shown in Figure 15-102 as the trimming surfaces.

4. Now, click once in the Pieces to Keep display area to invoke the selection mode. Select
the pieces to keep as shown in Figure 15-102.

5. Choose the OK button from the Trim Surface PropertyManager. The model after trimming
the base surface is displayed in Figure 15-103.

Filleting the Edges of the Trimmed Surface
Next, you need to fillet the edges created at the intersection of the base surface
and the extruded surface after trimming the surfaces.

1. Choose the Fillet button from the Features toolbar.

Figure 15-102  Surfaces and pieces to keep to be selected

Figure 15-100  Sketch of the second surface feature Figure 15-101  Extruded surface
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Figure 15-103  Model after trimming the surfaces

Figure 15-104  Edges selected to fillet Figure 15-105  Resultant fillet feature

2. Select the edges to fillet as shown in Figure 15-104.

3. Set the value of the Radius spinner to 5 and choose the OK button from the Fillet
PropertyManager. Figure 15-105 shows the model after adding the fillet.

Creating a Lofted Surface
Next, you need to create a lofted surface. The lofted surface will be created using a sketch
drawn on a plane at an offset distance from the Top plane and a curve projected on the
base surface. Before proceeding further you first need to create a plane at an offset distance
from the Top plane.

1. Create a plane at an offset distance of 40 from the Top plane.
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Figure 15-106  First sketch for loft surface Figure 15-107  Sketch to create projected curve

2. Invoke the sketching environment using the newly created plane as the sketching plane.

3. Create the sketch as shown in Figure 15-106 and exit the sketching environment.

Next, you need to create a projected curve. First, the sketch of the curve will be created on
the newly created plane and then you need to project this curve on the base surface.

4. Invoke the sketching environment with the newly created plane as the sketching plane
and create the sketch as shown in Figure 15-107 and exit the sketching environment.

5. Choose Insert > Curve > Projected from the menu bar to invoke the Projected Curve
PropertyManager.

6. Select the Sketch onto Face(s) option from the Projection Type drop-down list.

7. Select the second sketch created on the newly created plane and then click once in the
Projection Faces display area to invoke the selection mode.

8. Select the base surface from middle and select the Reverse Projection check box. Choose
the OK button from the Projected Curve PropertyManager.

Figure 15-108 shows the model after creating the sketch and the projected curve.

9. Choose the Lofted Surface button from the Surfaces toolbar. The Surface-Loft
PropertyManager is displayed.

10. Select the loft section as shown in Figure 15-109 and choose the OK button from the
Surface-Loft PropertyManager.

Figure 15-110 shows the model after creating the lofted surface.
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Figure 15-108  Model after creating the sketch and the projected curve

Figure 15-109  Section selected for lofted surface Figure 15-110  Resultant lofted surface

Creating the Planar Surface
Next, you need to create a planar surface using the top edges of the lofted surface.

1. Choose the Planar Surface button from the Surfaces toolbar to invoke the
Planar Surface toolbar.

2. Select the edges as shown in Figure 15-111 to create the planar surface.

The name of the selected edges is displayed in the Bounding Entities display area.

3. Choose the OK button from the Planar Surface PropertyManager. Figure 15-112 shows
the resultant planar surface.
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Figure 15-111  Edges selected to create the planar
surface

Figure 15-112  Resultant planar surface

Trimming the Base Surface using the Lofted Surface
Next, you need to trim the base surface using the lofted surface. You need the trimming
tool to trim the base surface.

1. Choose the Trimmed Surface button from the Surfaces toolbar to invoke the
Trim Surface PropertyManager.

2. Select the lofted surface as the trim tool and select the base surface as pieces to keep.

3. Choose the OK button from the Trim Surface PropertyManager.

Figure 15-113 shows the model after trimming the base surface using the lofted surface.

Figure 15-113  Model after trimming the base surface using the lofted surface
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Knitting all the Surfaces
Next, you need to knit the base surface, lofted surface, and the planar surface using the
Knit Surface tool. This is done because, for creating fillets on the edges created at the
intersection of the two surfaces, the two surfaces should be knitted first. If you need to
add the wall thickness to the surface model created using multiple surfaces, all the surfaces
should be knitted first.

1. Choose the Knit Surface button from the Surfaces toolbar to invoke the Knit Surface
PropertyManager.

2. Select the base surface, lofted surface, and the planar surface. The name of the selected
surfaces is displayed in the Surfaces and Faces to Knit display area.

3. Choose the OK button from the Surface Knit PropertyManager.

Next you need to add the required fillets. The final surface model after adding fillets is
shown in Figure 15-114.

Adding Thickness to the Surface Model
Next, you need to add the thickness to the surface model.

1. Choose Insert > Boss/Base > Thicken from the menu bar to invoke the Thicken
PropertyManager.

2. Select the surface model and set the value of the Thickness spinner to 2.

3. Choose the OK button from the Thicken PropertyManager.

Figure 15-114  Final surface model
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Figure 15-115 shows the final model after thickening the surface. Figure 15-116 shows
the FeatureManager Design Tree of the model.

Figure 15-115  Final model

Figure 15-116  FeatureManager Design Tree
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Saving the Model
1. Choose the Save button from the Standard toolbar and save the drawing with the name

given below and close the file.

\My Documents\SolidWorks\c15\c15-tut01.SLDPRT.

Tutorial 2
In this tutorial you will create the cover of the hair dryer shown in Figure 15-117. You will
create this model using surfaces and then you will thicken it. The views and dimensions of the
hair drye are displayed in Figure 15-118.      (Expected time: 1.5 hr)

The steps to be followed to complete this tutorial are discussed next.

a. First, you need to create the base surface. The base surface is created by lofting the open
sections along the guide curves, refer to Figures 15-119 and 15-120.

b. Create a planar surface to close the right face of the base surface, refer to Figures 15-121
and 15-122.

c. Next, you will create the basic structure of the handle of the hair dryer cover by creating
a lofted surface between two open sections, refer to Figures 15-123 through 15-125.

d. Next, you will trim the unwanted portion of the lofted surface used to create the handle,
refer to Figures 15-126 and 15-127.

e. You will create a planar surface to close the front face of the handle, refer to Figure 15-128.
f. Extrude the elliptical sketches to create the grips of the handle and then trim the unwanted

surfaces, refer to Figures 15-129 through 15-132.
g. Create dip on the top surface of the hair dryer, refer to Figures 15-133 throught 15-138.
h. Trim the surface to create the air vents, refer to Figure 15-139.

Figure 15-117  Cover of hair dryer

c15-solidworks-2003.p65 7/21/2003, 6:50 PM47



15-48                           SolidWorks for Designers
©

 C
A

D
C

IM
 T

ec
hn

ol
og

ie
s,

 U
S

A
. 

Fo
r 

en
gi

ne
er

in
g 

se
rv

ic
es

, 
co

nt
ac

t 
sa

le
s@

ca
dc

im
.c

om

i. Knit all the surfaces together and add the required fillets to the model, refer to
Figure 15-140.

j. Thicken the surface, refer to Figure 15-141.

Creating the Base Surface
To create the hair dryer, you first need to create the base surface of the model. The base
surface will be created by lofting the semicircular open sections along the guide curves.
The section will be created on different planes created at offset distances. Therefore, you
first need to create the three planes at offset distances from the Right plane.

1. Create a new SolidWorks document in the Part mode.

2. Create three planes at an offset distance from the Right plane, refer to Figure 15-119.

3. Next you need to create the sections and the guide curves to create a lofted surface as
shown in Figure 15-119.

4. Using the Lofted Surface tool create the lofted surface as shown in Figure 15-120.

Figure 15-118  Views and dimensions for the model of Tutorial 2
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Figure 15-119  Sections and guide curves to create a lofted surface

5. Next, you will create a planar surface to close the right face of the base surface.

6. Invoke the sketching environment by selecting the Plane3 as the sketching plane.

7. Create a closed sketch to create the planar surface as shown in Figure 15-121.

8. Invoke the Planar Surface PropertyManager and choose the OK button from this
PropertyManager to create the planar surface as shown in Figure 15-122.

Figure 15-120  Resultant lofted surface
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Creating the Base Surface for the Handle
Next, you need to create the base surface for the handle. The base surface for the handle
is created by lofting two open sections. The first section for the lofted surface will be
created on a plane at an offset distance from the Front plane and the second section will
be created on the Front plane. Therefore, you first need to create a plane at an offset
distance from the Front plane.

1. Create a plane at an offset distance of 100 from the Front plane.

2. Invoke the sketching environment using the newly created plane as the sketching plane.

3. Create an open sketch as shown in Figure 15-123 and exit the sketching environment.

4. Now, invoke the sketching environment using the Front plane as the sketching plane.

5. Create an open sketch as shown in Figure 15-124 and exit the sketching environment.

6. Using the Lofted Surface tool create the lofted surface as shown in Figure 15-125.

Trimming the Unwanted Lofted Surface of Handle
After creating the lofted surface for the handle, if you rotate the model you will observe
that a portion of the lofted surface needs to be trimmed. The method of trimming the
unwanted portion of the lofted surface is discussed next.

1. Invoke the Trim Surface PropertyManager and choose the Mutual trim radio button
from the Trim Type rollout.

Figure 15-121  Sketch for creating the planar
surface

Figure 15-122  Resultant planar surface
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Figure 15-123  Sketch of the first section for
creating the lofted surface of the handle

Figure 15-124  Sketch of the second section for
creating the lofted surface of the handle

Figure 15-125  Resultant lofted surface

2. Select the surfaces as trimming surfaces and the pieces to keep as shown in Figure 15-126
and choose the OK button from the Trim Surface PropertyManager.

Figure 15-127 shows the resultant trimmed surface.

Creating a Planar Surface to Close the Front Face of the Handle
Next, you need to create a planar surface to close the front face of the handle.

1. Invoke the sketching environment with the plane created at an offset distance from the
Front plane as the sketch plane.

2. Create a closed sketch to create a planar surface.
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3. Invoke the Planar Surface PropertyManager to create the planar surface.

Model after creating the planar surface is shown in Figure 15-128.

Creating the Grips on the Handle
Next, you need to create the grips on the handle that facilitates the user to hold the hair
dryer. The grip will be created by extruding the elliptical surface and then trimming
the unwanted portion of the surfaces.

1. Invoke the sketching environment using the Top plane as the sketching plane.

2. Create the sketch for extruding the surface to create the grips as shown in Figure 15-129.

Figure 15-128  Model after creating the planar surface

Figure 15-126  Trimming surfaces and the pieces
to keep

Figure 15-127  Resultant trimmed surface

c15-solidworks-2003.p65 7/21/2003, 6:50 PM52



Surface Modeling       15-53

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. 
Fo

r 
en

gi
ne

er
in

g 
se

rv
ic

es
, 

co
nt

ac
t 

sa
le

s@
ca

dc
im

.c
om

Figure 15-129  Sketch created for extruding the
surface

Figure 15-130  Resultant extruded surface

Figure 15-131  Trimming surfaces and the pieces
to keep

Figure 15-132  Model after trimming the surfaces

3. Invoke the Surface-Extrude PropertyManager and extrude the sketch to the depth of
25mm. The extruded surface is displayed in Figure 15-130.

Next, you need to trim the portions of the extruded surface and the handle to obtain the
desired shape of the grips.

4. Invoke the Trim Surface PropertyManager and choose the Mutual trim radio button
from the Trim Type rollout.

5. Select the trimming surfaces and the pieces to keep as shown in Figure 15-131.

6. Choose the OK button from the Trim Surface PropertyManager. Figure 15-132 shows
the resultant trimmed surface.
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Figure 15-133  Sketch to be projected Figure 15-134  Resultant projected curve

Creating the Dip on the Upper Surface of the Base Surface
Next, you need to create the dip on the base surface. To create this, you need several
tools. These include offsetting the planes, creating lofted surface, trimming and creating
planar surface.

1. Create a plane at an offset distance of 35 from the Top plane.

2. Invoke the sketching environment using the newly created plane as the sketching plane.

3. Create the sketch as shown in Figure 15-133 and exit the sketching environment.

4. Choose Insert > Curve > Projected from the menu bar and project the newly created
sketch on the base surface. The model, after projecting the surface, is displayed in
Figure 15-134.

5. Create a plane at an offset distance of 6 from the newly created plane at an offset
distance in the downward direction.

6. Now, invoke the sketching environment using the newly created plane as the sketching
plane and create the sketch as shown in Figure 15-135. Exit the sketching environment.

7. Invoke the Lofted Surface tool and create the lofted surface using the sketch and the
projected curve created earlier.

8. The lofted surface after hiding the base surface is displayed in Figure 15-136. To hide the
surface bodies, expand the Surface Bodies folder and select the surface. Now, right-click
to invoke the shortcut menu. Choose the Hide Surface Body option from the shortcut
menu.

9. Using the Trim Surface tool, trim the base surface using the newly created lofted surface.
The model, after trimming the surface, is displayed in Figure 15-137. Next, using the
Planar Surface tool, create a planar surface as shown in Figure 15-138.
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Figure 15-137  Model after trimming the surface Figure 15-138  Planar surface

Creating the Air Vents
Next, you need to create the air vents on the newly created planar surface. The air vents
are created by drawing the sketch on the planar surface and then using the trimming tool
to trim the surface.

1. Select the newly created planar surface as the sketching plane and invoke the sketching
environment.

2. Create the sketch of the air vents, refer to Figure 15-118.

3. Using the Trim Surface tool, trim the planar surface in order to create the air vents.

The surface model after creating the air vents is displayed in Figure 15-139.

Knitting All the Surfaces
After creating all the surfaces, you need to knit all the surfaces together so that you can
add fillets to the surfaces and also thicken the model.

Figure 15-135  Sketch for lofting Figure 15-136  Lofted surface
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1. Choose the Knit Surface button from the Surfaces toolbar. The Knit Surface
PropertyManager is invoked and you are prompted to select the surfaces to knit.

2. Invoke the FeatureManager Design Tree flyout and expand the Surface Bodies folder.

3. Select all the surface bodies from this folder.

4. Choose the OK button from the Knit Surface PropertyManager.

5. Add all the required fillets to the surface model. The model after adding the fillets is
displayed in Figure 15-140.

Figure 15-140  Surface model after adding fillets

Figure 15-139  Surface model after trimming the planar surface
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Figure 15-141  Final model

Adding Thickness to the Surface Model
After creating the entire model, you need to add thickness to the surface model.

1. Choose Insert > Boss/Base > Thicken from the menu bar. The Thicken
PropertyManager is invoked and you are prompted to select surface to thicken.

2. Set the value of the Thickness spinner to 2 and select the surface model from the drawing
area. The preview of the thickened model is displayed in the drawing area.

3. Choose the OK button from the Thicken PropertyManager. Save the model.

The final model is displayed in Figure 15-141. The FeatureManager Design Tree of the
model is shown in Figure 15-142.
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SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. In SolidWorks the __________ tool is provided to extrude a closed or an open sketch to
create an extruded surface.

2. The __________ PropertyManager is used to create a revolved surface.

3. The __________ tool is used to create a surface patch by extending the existing surfaces.

4. The __________ tool is used to offset the selected surface or surfaces to a given distance.

5. The __________ PropertyManager is used to create a lofted surface.

Figure 15-142  FeatureManager Design Tree
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6. You cannot patch the faces of the solid model deleted using the Delete Face tool. (T/F)

7. Using the Stitch Surface tool, you can knit the surfaces together to create a single surface.
(T/F)

8. You cannot create a filled surface by selecting a 3D sketch as patch boundary. (T/F)

9. The Curvature Control drop-down list is used to define the type of curvature you need to
apply while creating the fill surface. (T/F)

10. The SurfaceCut PropertyManager is used to create a surface cut. (T/F)

REVIEW QUESTIONS
Answer the following questions:

1. The __________ PropertyManager is used to add thickness to a surface body.

2. To extend the surface in the linear direction to an existing surface, invoke the Extend
Surface PropertyManager and select the __________ radio button from the Extension
Type rollout.

3. The __________ check box is used to solidify a closed surface model.

4. The __________ tool is used to delete the faces of a surface or a solid body.

5. The Mid-Surface tool is used to create a surface between the selected faces.

6. Which PropertyManager is used to created a fillet surface?

(a) Fill Surface (b) Surface Fill

(c) Fillet (c) None of these

7. Which button from the Surfaces toolbar is used to invoke the Replace Face1
PropertyManager?

(a) Face Replace (b) Replace Face

(c) Offset Surface (d) Fillet Surface

8. The face or surfaces selected to offset are highlighted in green. In which display area are
their names displayed?

(a) Surface or Faces to Offset (b) Options

(c) Patch Boundaries (d) Offset
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Figure 15-143  Model for Exercise 1

9. Which rollout is used to define the constraint curves while creating the fill surface?

(a) Define Constraint Curves (b) Constraint Curves

(c) Patch Boundaries (d) None of these

10. In which display area of the Replace Face PropertyManager, the name of the face selected
to be replaced is displayed?

(a) Target faces for replacement (b) Faces for replacement

(c) Faces (d) Faces and Surfaces to Replace

EXERCISES

Exercise 1
In this exercise, you will create the model shown in Figure 15-143. You need to create this
model using surfaces. After creating and knitting all the surfaces you will add the required
thickness to the model. The views and dimensions of the model are shown in Figure 15-144.

         (Expected time: 1hr)
Note
In this model you will have to knit the surfaces first and then fillet the edges.
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Figure 15-144  Views and dimensions for Exercise 1

Exercise 2
In this exercise you will create the model of the binoculars shown in Figure 15-145. You need
to create this model using surfaces. You need to create a closed surface model and then knit
all the surfaces together and then solidify it. The views and dimensions of the model are
shown in Figure 15-146.          (Expected time: 1hr)
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Figure 15-146  Views and dimensions of Exercise 2

Answer to Self-Evaluation Test
1. Extruded Surface, 2. Surface-Revolve, 3. Untrim Surface, 4. Offset Surface, 5. Surface-Loft,
6. F, 7. F, 8. F, 9. T, 10. T  

Figure 15-145  Model for Exercise 2
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