
January 14, 2002 SurfaceWorks for SolidWorks Tutorials   •   5-1

Tutorial 5  Inserting a Freeform Face

Overview
In this tutorial, we’ll insert a
freeform face from
SurfaceWorks into a SolidWorks
part. The new face will be
tangent to the planar
SolidWorks face that surrounds
it, and durably attached to the
SolidWorks edges. The part will
end up being a drop-in tub (Fig.
1). Fig. 1

Entity introductions:

➢ Tangent Boundary Surface

Concept and Function introductions:

➢  cursor shape
➢ Select boundaries bottom, right, top, left to match TBS spreadsheet
➢ Shaping a Tangent Boundary Surface via its control sliders, and via the Control

Values spreadsheet
➢ SurfaceWorks>Add SurfaceWorks Parents
➢ SurfaceWorks>Manage SurfaceWorks Parents

Here are the basic steps we’ll follow:

• Select a planar face from a model in SolidWorks to take with us into
SurfaceWorks.

• From the inner edges of this face, create a Tangent Boundary Surface in
SurfaceWorks with G1 continuity along all its edges.

• Shape the surface before heading back to SolidWorks.

• Cut the part with the new surface, thus making the new face.

• Lengthen the tub, then shell the part.
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• Edit the Tangent Boundary Surface in SurfaceWorks and bring the changes back
into SolidWorks.

Again, since some of you may be rather new to SolidWorks as well as to
SurfaceWorks, we include step-by-step instructions for both the SurfaceWorks and
the SolidWorks parts of the tutorial modeling. (If you are an old hand at SolidWorks,
please bear with the details for newer users. Thanks!)

Base Extrude and Boss Extrude
We will start this tutorial by finishing a sketch started in SolidWorks:

1 In SolidWorks, File>Open TubStart.sldprt from the \Integrated Tutorials
folder.

2 Select 'Sketch2' from the FeatureManager.

3 Choose  or Extruded Boss/Base from the Features toolbar and click above
the surface.

Type = Blind
Dimension = 50 in

4 Select 'Sketch1' from the FeatureManager.

5 Choose  again and again click above the surface.

Type = Blind
Dimension = 26 in

Add SurfaceWorks Parents
The geometry we will take into SurfaceWorks is the narrow upper face of Boss-
Extrude1, which surrounds the Base-Extrude. In SurfaceWorks, we will make a
freeform surface that spans the area inside the inner edges of this narrow face, then
we’ll bring that surface into SolidWorks and cut with it, thus creating the new
freeform face.

1 Right-click on the narrow upper ledge-like face of the Boss-Extrude (it
surrounds the Base-Extrude), then from the shortcut menu (right click) choose
Add SurfaceWorks Parent.  If you have difficulty selecting the face, you may
have to rotate and/or zoom the model.

2 From the menu bar, choose SurfaceWorks>Manage SurfaceWorks Parents.
This dialog shows you a list of all the SolidWorks geometry that has been
assigned as SurfaceWorks parents. Notice that besides the face we selected, 8
edges are listed. When you add a face as a parent, you automatically get all its
edges as parents as well.

3 Close the dialog.
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4 Choose SurfaceWorks>Modeler.

Check program settings
Let’s check those program settings and make sure we’re all starting with the same
ones (the initial program defaults). This is what you should have:

On the View menu:

Status Bar should be ON (preceded by a checkmark; to turn an option on,
simply click on the menu item or if it has a box next to it click on the box).

All Toolbars should be ON.  To check this, click on Toolbars.  The resulting list
should have all of its boxes checked.

On the Tools>Options, General, tab:

Rotation Constraint should be set to Free tumble

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

Create the Surface
You see the imported SolidWorks geometry. The face is represented by a Trimmed
Surface, and its edges by Projected Snakes (a “snake” is a curve constrained to lie on
a surface). We’ll use a Tangent Boundary Surface to make a freeform surface inside
the SolidWorks face. We chose this kind of entity because it allows us to:

• Make a surface tangent to adjacent surface(s) — the key here is that the bounding
curves need to be snakes along the edges of the adjacent surfaces

• Shape the interior of the surface using numerous control points

We want to select all four lines (Projected Snake entities) around the inside of the
model. You could start with any of them and go in either direction around the loop,
but for the tutorial, so we’re all looking at the same model, do it this way:

1 Click on the upper of the long inner edges to select it.

2 Ctrl+click, in order, going clockwise (right, lower, left), to select the other
three inner lines. All four Projected Snakes should now be displayed wider and
also listed in the selection set.

3 On the Insert toolbar, click  (with the all-blue boundary), then choose
Tangent Boundary Surface from the drop-down menu (alternatively, you
could choose Insert>Surface>Tangent Boundary Surface). In the dialog box,
the four lines you selected should be listed as the “Bounding Curves”.

4 Make Number of u control values = 8 and Number of v control values = 6.
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5 We want the surface we are making to be tangent to the surface rimming it, so
click each of the four radio buttons in the G1 column. Since the bounding
curves are snakes on the adjacent surface, the G1 and G2 options are available.

6 Click Apply (not OK; we want the dialog to stay open — we haven’t finished
shaping this surface yet). A “basis” surface with 8 x 6 control “points” appears
inside the bounding curves. Each of the inner 6 x 4 controls displays as a slider
point on a line that is normal to the basis surface — you can use these to shape
the interior of the surface. The outer row of controls has no sliders; these controls
are fixed at zero because we specified G1 continuity for the edges. The slider
controls display only for shaping the surface (they aren’t real points and they
will disappear when you OK the dialog).

Tangent Boundary Surface Control Values

1 The dialog box is still open.  or View>Modify>Pan the graphic image and
drag the dialog to show as much as possible of the entire surface and the entire
dialog.

2 In the dialog, switch to the Control Values tab, to see the model’s spreadsheet
control, which is synchronized with the sliders in the graphic image.

3 Notice:

• In the dialog, the outer row of values is grayed out and, in the graphic image, the
outer row of control points has no slider to slide on — the points are fixed at
zero. This is because we specified G1 continuity along all the Tangent Boundary
Surface’s edges. (If we had specified G2 continuity, two rows of controls would
be grayed out and sliderless; if we had specified G0, none would be grayed out,
and all would have slider lines.)

• The corner values in the spreadsheet and the corner controls in the graphic image
are color coded, so you can keep track of which values correspond to which
sliders. The control nearest the u=0, v=0 corner of the surface is always red. This
value always is at the lower left of the spreadsheet. So in this case, you can see
that to map the surface onto the spreadsheet, we’d need to flip the surface top to
bottom.

Instead, we’ll show you a little trick about selecting Tangent Boundary Surface
edges: if you select them in the order bottom, right, top, left, the surface
automatically will be oriented similarly to the spreadsheet. Let’s do it:

4 Switch back to the General tab and click in the “Bounding Curves” data field.

5 In the graphic window, reselect the curves: click the bottom inner edge, then
Ctrl+click in order, the inner edge on the right, the top, and the left. (When
you change bounding curves, continuity for the first and third edges is set back
to G0 — the curves in these positions are different from before. The curves in the
second and fourth positions happen to be the same ones as before, so they keep
their G1 continuity assignment.)
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6 Set continuity to G1 for all the edges.

7 Click Apply, then return to the Control Values tab. Now it’s easy to see which
cell in the spreadsheet corresponds to which slider in the graphic window.

Shape the Surface
You can shape the interior of a Tangent Boundary Surface in two ways: by sliding the
sliders in the graphic view or by typing in values on the Control Values tab of the
dialog. We’ll demonstrate both methods. We want to shape the surface so that some
of it is above the original plane of the surface, and some of it is below:

1 In the drawing, find the slider nearest the blue color coded point (at upper
left, in this view). Aim the cursor arrow at the point on the slider line — the

 icon will appear. Drag the slider point up a little and see how the surface
responds.

2 Notice in the dialog that the value for the slider you just dragged is no longer
zero.

3 Back in the graphic display, drag the upper-left slider up to approximately 20
(watch the value in the spreadsheet as you drag — you may need to pause
during the drag to force the value to update).

4 Drag the slider next below it (in the same column) to approximately 20.

Since we want the whole first column to be 20 and the rest of the cells to be -20 let's
work with the spreadsheet.

5 In the Control Values spreadsheet, click in the top left editable cell.  This value
should already be around 20 from being dragged.

6 Type 20 and press the down arrow, 20, down arrow etc.

7 Repeat this for the next column using -20 for the cell value.  To speed the
process for the rest of the columns, select the four    -20 cells, copy (Ctrl+C), click
the top editable cell in the next column, and paste (Ctrl+V), etc. (You won’t see
any change in the graphic until you click Apply or OK).

8 Now click Apply (Fig. 2).
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     Fig. 2

9 Click OK and rotate  to see what you have.

Insert the Face
1 File>Exit & Return to SolidWorks, saving changes.

The surface we’ve made is hidden inside the part, but imagine it there — it goes both
above and below the plane of the narrow face we brought in from SolidWorks. That’s
why we made the Base-Extrude taller than Boss-Extrude1.

2 Before we use the imported surface, go again to SurfaceWorks, Manage
SurfaceWorks Parents. The Import column now shows that Surface-Imported1
is the import based on four of the edges (2, 3, 4, 5) listed in the Export column.

3 Expanding any of the Surface-Imported1 listings shows that the imported
surface comes from the SurfaceWorks entity ‘surface1’.

4 Expanding any of the features in the Export column shows the name of the
SurfaceWorks entity that the SolidWorks entity was translated into.

5 Close the Manage SurfaceWorks Parents dialog.

Now, we’ll cut the part with the surface.

6 In the FeatureManager, select Surface-Imported1.

7 Insert>Cut>With Surface:

The outlined arrow in the graphic image should be pointing toward the top of the
part. If it isn’t, click the “Flip the side to cut away” box.

8 OK (Fig. 3).
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    Fig. 3

Lengthen the Tub
Ah, but what if we now decide that we want the tub to be longer? Well, we’ll just
make it longer:

1 Click  to expand Boss-Extrude1.

2 Double-click Sketch1.

3 In the graphic display, double-click the 96 dimension, then change it to 120 in
the dialog; click on the green check mark.

4 Rebuild (  or Edit>Rebuild) the part (Fig. 4).

    Fig. 4
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Shell the Part
Now, let’s shell this part. We’ll make it a drop-in tub:

1 Select the five big faces of Boss-Extrude1, i.e. the “sides” and “bottom” of the
model (yes, you’ll need to rotate to get the ones that aren’t visible now). Be sure

you get the face icon  before you Ctrl+click — you have to point where the
imported surface does not interfere with the face selection. Toggle the Rotate

button  on and off on the toolbar in order to switch back and forth to the
Select tool without losing any faces from the Selection Set.

2 Shell  the part:

Thickness = 1 in.
Make sure 5 faces are listed (Face <1>, Face <2>, etc.; if there aren’t five, go
back and reselect them.)
OK (Fig. 5).

Ready to cut a drain hole and install in your new bathroom?

    Fig. 5

Final Modification in SurfaceWorks
Before leaving this model, let’s go back to SurfaceWorks and change the shape of the
Tangent Boundary Surface — maybe you’d like to lounge in the tub with your feet
up?

1 Choose SurfaceWorks>Modeler.

2 Double-click the Tangent Boundary Surface to edit it.

3 Go to the Control Values tab and change all the values in the next-to-last
column of control values to -10; OK.

4 File, Exit & Return to SolidWorks, saving changes.
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5 Rotate  to see what you have (Fig. 6).

    Fig. 6

6 That’s all for Tutorial 2, so File, Exit SolidWorks.
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