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PowerMILL is the world's leading specialist NC CAM software for 
manufacturing complex shapes typically found in the toolmaking, 
automotive, and aerospace industries. 

Key features: 

 Wide range of milling strategies which include high-efficiency 
roughing, high-speed finishing, and 5-axis machining techniques. 

 Fast calculation times for toolpath creation and postprocessing. 

 Powerful editing tools to ensure optimum performance on the 
machine tool. 

This Getting Started guide provides step-by-step instructions that 
highlight some of the features of this versatile software. 

 It is assumed that you know how to operate your machine 
tool, select suitable tools, and cutting conditions. If you are 
unsure about any aspect of operating your machine tool, consult 
an expert or seek advice from your machine tool supplier. 

 The machining parameters used in examples in this guide 
have been selected to illustrate the effects of different 
commands and options in PowerMILL. The values given are not 
necessarily suitable for cutting on a CNC machine. If you wish to 
machine any parts based on the examples given, carefully review 
and adjust the parameters to ensure safe cutting conditions. 

 

Introduction 
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Setting up your working directories 
To make project management easier, it is recommended that you 
define a home folder and default directory paths before starting any 
work with PowerMILL: 

 Setting up a Home folder in Windows 7 for user-defined macros 
(see page 2). 

 Specifying PowerMILL default directory paths (see page 3). 

 PowerMILL temporary file area (see page 4). 
 

Setting up a Home folder in Windows 7 for user-defined 
macros 

PowerMILL checks for the value defined in the Windows 
environment variable Home for directions to the user-defined 
macros folder. Decide where you want the Home environment 
variable to point to, for example, E:\PowerMILL_Projects, and set up 
a Windows environment variable: 

1 Open Windows Control Panel and click System > Advanced system 
settings. This displays the System Properties dialog. 

2 Click the Advanced tab. 

3 Click Environment Variables. 

4 To add a new variable name and value, click New to display the 
New User Variable dialog. 

a In the Variable Name field, enter Home. 
b In the Variable Value field, enter the path where you want your 

home folder to be. For example, E:\PowerMILL_Projects. 
5 Click OK in all open dialogs to save changes and close them. 

6 Create a folder called pmill inside the Home directory. For 
example, E:\PowerMILL_Projects\pmill. 

When user-defined macros are created or called, PowerMILL 
automatically locates the user-created macros in this folder. 
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Specifying PowerMILL Default Directory paths 
To specify the Default Directory path in PowerMILL: 

1 From the Menu bar, select Tools > Customise Paths. This displays 
the PowerMILL Paths dialog. 

2 Select Default Directory from the drop-down list. 

 

3 To add a Default Directory path, click , and use the Select Path 
dialog to select the desired location. The path is added to the list. 
You can add multiple paths to the Default Directory list. 

 You can have only one active Default Directory path. 
PowerMILL allows you to add multiple paths to the Default 
Directory list to help you efficiently organise multiple 
projects across different folders. To change the Default 
Directory load order, select the directory path you want to 

change, and use the  and  buttons to promote or 
demote the path. 

4 Click Close. 

Your default working directory is changed to the directory path you 
selected and all your file operations (Open Project, Save Project, 
Import Model, Export Model) are changed to this location. 
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Specifying PowerMILL temporary file area 
By default, PowerMILL projects use the default Windows temp folder 
defined in your Windows System Properties as the temporary area. 

To define a custom PowerMILL temporary file area: 

1 Right-click My Computer, and then click Properties. This displays 
the System Properties dialog. 

2 Click the Advanced tab. 

3 Click Environment variables. 

4 Click New to add a new variable name and value. 

a In the Variable Name field, enter 
DELCAM_POWERMILL_USER_TEMPDIR. 

b In the Variable Value field, enter the path where you want your 
PowerMILL temporary folder to be. For example, 
E:\PowerMILL_Projects\TemporaryFiles. 

5 Click OK in all open dialogs to save changes and close them. 

6 Create the temporary folder in Windows to the path where you 
specified the variable. For example, 
E:\PowerMILL_Projects\TemporaryFiles. 

 If there are any problems with the variable you have 
specified, PowerMILL reverts to the default Windows 
temporary file area. 
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To start PowerMILL: 
 Select Start > All Programs > Delcam > PowerMILL > PowerMILL2012 

R2 

or 

 Double-click the PowerMILL shortcut on your desktop: 

 
This displays the Startup (see page 6) window. 

To exit PowerMILL: 
 Select File > Exit from the menu. 

 Click the Close button  in the top right-hand corner of the 
PowerMILL window. 

If you haven't saved your project, the following message is 
displayed: 

 
Click Yes to save the project before exiting from PowerMILL. 

 

Start and close 
PowerMILL 
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Startup window 
The following window is displayed on starting PowerMILL: 

 
The screen is divided into the following main areas: 

 - Menu bar provides access to a number of menus. Selecting a 
menu, such as File, opens a list of associated commands and sub-
menus. Sub-menus are indicated by a small arrow to the right of 
the text. For example, selecting File > Recent Projects  displays a list 
of recently used projects. 

 - Main toolbar provides quick access to the most commonly used 
commands in PowerMILL. 

 - Explorer provides control over all PowerMILL entities. 

 - Graphics window is the working area of the screen. 

 - View toolbar provides quick access to standard views and 
shading options in PowerMILL. 
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 - Status and Information toolbar enables you to create and activate 
workplanes, display various preset fields and display user defined 
fields. If you hover the cursor over a button, help is displayed rather 
than the information toolbar. The help can be, for example, a brief 
description of the item beneath the cursor, or information about the 
calculation that is in progress. 

 - Tool toolbar facilitates the rapid creation of tools in PowerMILL. 

 The other toolbars are not factory defaults, and may not be 
shown at startup. To display any of these, select them using 
the View > Toolbar option; for example, choose View > Toolbar 
> Toolpath to display the Toolpath toolbar. 
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 If you want to change background colours, select Tools > 
Customise Colours and choose View Background. You can 
change the Top and/or Bottom colours and Reset them or 
Restore Defaults if you change your mind afterwards. 

 

 PowerMILL remembers your toolbar and colour selections 
from one session to the next. For example, if you have the 
Toolpath toolbar displayed when you exit a session, it appears 
the next time you start PowerMILL. 
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Explorer 
The explorer  pane on the left of the graphics window controls 
the display and status of all PowerMILL entities, including NC 
programs, toolpaths, tools, and so on. 

The following is an example of the explorer showing various entities 
and associated controls: 

 
 Click  to expand or  to collapse the tree to view or hide 

subentries. 

 Light bulb icons , ,  work as a three-way switch for drawn 
entities, such as toolpaths and tools: 

  is the default setting when an entity is first created, 
indicating that it is currently active. 

 Clicking  changes the icon to  to indicate that the entity is 
drawn. 
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 Clicking  changes the icon to  to indicate that the entity is 
now hidden, or undrawn. These two icons,  and , work 
together as a toggle. If an undrawn entity is made active 
again after being inactive, the icon reverts to the initial . 

 An entity is always drawn when it is first activated or re-
activated. When active, it is also displayed in bold and 
preceded by a ">" in the explorer. 

 In this example, > 6 Ball is the active undrawn tool, and > 
CornerFinishing_Auto is the active drawn toolpath. 

 

Renaming an entity 
PowerMILL entities are given numeric default names on creation. 
So, for example, the first toolpath you create is called "1", the 
second "2", and so on. 

You can rename an entity to give it a more meaningful name. To 
rename an entity, right-click an entity and select Rename from the 
context menu. 

 

 To quickly rename an entity, select the entity in the explorer, 
and then single-click it. The name is now highlighted, and has 
a box around it: . Enter the new name, for example 
RestRough, and press Enter . 

 



 

PowerMILL 2012 R2 Getting Started Start and close PowerMILL • 11  

Unit System 
By default, PowerMILL uses metric units. You can change the unit 
system before any project entities have been created. 

 This guide uses metric (mm) units. 

To change the default units before you start work, for example, 
from Metric to Imperial: 
1 From the Tools menu, select Options. This displays the Options 

dialog. 

2 Select Unit System and click  to expand the tree to view 
available options. 

3 Select the Unit System sub-item. This displays the Unit System 
page. 

4 Select Imperial (inches). 

 
5 Click Accept to save changes. 

 Changing the unit system automatically resets all the default 
values on the dialogs to match the selected unit system. 
PowerMILL does not convert the values between the unit 
systems; instead, it chooses an appropriate set of default 
values (metric or imperial). 

 



 

12 • Start and close PowerMILL PowerMILL 2012 R2 Getting Started  

Accessing Help 
PowerMILL offers the following forms of help: 

 Tooltips (see page 12) 

 Status bar help (see page 12) 

 Context-sensitive online help (see page 12) 

 Manuals (see page 13) 
 

Tooltips 
Tooltips are displayed by hovering the cursor over the required 
buttons. 

Each tooltip gives a brief description of the function of the 
associated button, for example: 

 
 

Status bar help 
When you hover the cursor over a button, help is displayed in the 
Status bar at the bottom of the screen. So, when you place your 

cursor over the Rapid Move Heights  button, you see the following 
help in the Status bar at the bottom of the screen as well as the 
tooltip: 

 
 

Context-sensitive online help 
Pressing the F1 key displays help for the area of the screen that has 
current focus, such as a display pane (explorer, graphics window), a 
dialog, or a dialog tab. Where there is no focus, the contents page 
for the main Help is displayed, so that you can navigate from there. 

To display the help topic relating to an element on the main 
PowerMILL screen (a toolbar button, an explorer entity), hold down 
the Shift key and press F1. When the cursor changes to , click the 

item of interest to open the help topic: . 

 If you want to cancel context-sensitive mode, press Esc. 
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To display context-sensitive help for an element within a PowerMILL 
dialog (such as a field or a button), click  and when the cursor 
changes to , click the item to open the associated help topic: 

 
 

Manuals 
The PowerMILL manuals offer additional help. 

The documents are: 

 What's New and Getting Started manuals. 

 Online reference help. 
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This example shows you how to generate and output the basic 
toolpaths used to machine a forging die mold. 

1 Start PowerMILL (see page 5). 

2 Load the model (see page 15). 

3 Save the project (see page 19). 

4 View the model and block (see page 20). 

5 Create an NC program (see page 24). 

6 Create, simulate, and output each toolpath: 

 Roughing (see page 29) - to rapidly remove the majority of 
the excess material using the Offset all style in the Model Area 
Clearance strategy. 

 Rest roughing (see page 43) - to clear additional material 
using a smaller tool (the Model Area Clearance strategy is used 
again; this time only material not removed by the previous 
toolpath is machined). 

 Finishing toolpath (see page 52) - to generate steep and 
shallow moves within a specified boundary. 

 Corner Finishing (see page 69) - to clean up material that 
previous toolpaths were unable to finish, particularly in 
corners between non-tangential surfaces. 

  

Cavity mold example 
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Loading the model 
The model you will work on is a cavity mold in the Examples folder. 

To load the model: 
1 Select File > Examples. 

 
The Open Examples dialog is displayed, automatically opening the 
drive and folder where the tutorial files are installed: 

 
2 In the Files of type field, select Delcam Geometry (*.dgk) from the 

drop-down list. 

3 Select the cavity mold called die.dgk, and then click Open. 

PowerMILL loads the file. 
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4 Click the Resize to Fit  button on the View toolbar to fit the file 
within the display. 

 

5 To change the display to an isometric view, select the ISO 1  
button on the same toolbar. The model looks like this: 

 

 More information on view manipulation is provided later 
(see page 20). 
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6 The die is currently shown with only the wireframe selected. To 

add shading, click the Plain Shade  button on the View toolbar. 

 

7 Remove the wireframe by clicking the Wireframe  button near 
the bottom of the View toolbar. 

 Click the Wireframe  or Plain Shade  buttons to toggle 
between Wireframe, Plain Shade, Wireframe and Shaded, and 
No Model views. 

For this exercise, keep the model shaded. 
 

Defining the block around the die 
The block defines the stock size. The part is then machined from the 
block. In this case, the block is a rectangular cuboid. 

To define the block: 

1 Click the Block  button on the Main toolbar. 

2 In the Block dialog, check that: 

a Defined by is set to Box. 

b Coordinate System is set to Active Workplane. 
c In the Estimate Limits area, Expansion is set to 0 and Type to 

Model. 
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d Draw is selected. 

 
3 Click Calculate to define a cuboid enclosing the die. Click Accept 

to close the dialog. 

 

 To toggle the display of the block on and off, click the Block 

 button on the View toolbar. 
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Saving the project for the first time 
PowerMILL saves all the entities, together with a copy of the model, 
as a single project. 

To save a project: 

1 Click the Save button  on the Main toolbar. Since you have not 
previously saved the project, the Save Project As dialog is 
displayed. 

 
2 Move to the directory that you created for your projects (see 

page 2), and enter a name for your project in the File name field, 
for example forging_die_mold. 

3 Click Save. 

The PowerMILL window header now reflects the name of the 
project. 

 
An associated file structure is created: 

 

 Do not manually edit these files - you will corrupt your data. 
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 From now on, click Save  on the Main toolbar to update the 
saved version of the project. 

 

Viewing the model and block 
To look at a specific area of the model and block you can either 
select one of the predefined views (see page 20) on the View 
toolbar, or use a mouse. 

It is recommended that you use a three-button mouse. By holding 
down the middle button and moving the mouse pointer in the 
graphics area, you can control the view of the model. When you are 
moving the mouse (with the middle button pressed) the trackball is 
visible on the screen: 

 
Start with the cursor in the middle of the window and press the 
middle mouse button, then drag the cursor up the screen. The 
image moves as you move the mouse. 

 

Predefined views 
The View toolbar is loaded by default when PowerMILL is started 
and is often the best starting point for dynamically manipulating 
model views. There are several fixed viewing directions available 
from the View toolbar. 

 If the View toolbar is not currently displayed, select View > 
Toolbar > Viewing from the menu. 

 

View Along options allow you to orientate the view so 
that it is along the X, Y, or Z axis. Hover on any of these 
buttons to display a 2D view toolbar which has additional 
view options along the primary axes. 
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 Use the ISO View option to change the view angle to any 
of the isometric views. Hover on the button to display 
other isometric view options. 
Isometric views are often the best starting point for 
dynamically manipulating the view using the mouse. 

 Previous View option takes you back to the previous view 
of the entities. 

 Refresh option redraws all the currently displayed 
components, repairing any damage to the current view. 
This can be useful if the view loses definition as items 
are created, modified, or deleted on the screen. 

 Resize to Fit (see page 22) adjusts the view to fit the 
screen. Depending on the current view, PowerMILL 
zooms in or out to adjust the view. Hover on the button 
to view the Zoom In (see page 22) and Zoom Out (see 
page 22) buttons. 

 Use the Zoom to Box (see page 22) option to zoom in on 
a specific area of the model. Click and drag the mouse to 
create a box over a part of the model to zoom in. 
PowerMILL adjusts the view to zoom in on the selected 
boxed area. 

 Use the Block option to show or hide the block. 

 Use the Plain Shade option to show or hide the shaded 
representation of the model. 
Hover on the Plain Shade button to show the other 
shading options available on the Shading toolbar. 

 Use the Wireframe option to show or hide the wireframe 
representation of the model. 

 Use the Box Selection mode to select entities with the 
mouse. Click and drag the mouse to create a box over 
the entities you want to select. 
To deselect entities from a group of selected entities, 
hold down the Ctrl key and click the entities you want to 
deselect. 

 Use the Drag Selection button to select multiple entities 

with the mouse. Hover on the Box Selection  button to 

display the Drag Selection  button. Click the Drag 
Selection  button and click and select the relevant 
entities. 
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 Use the Last Selection option to revert to the previous 
selection made with the Box Selection or Drag Selection 
options. 

Zoom 
You can resize the model using the viewing options available on the 
View toolbar: 

The Zoom options  and  control the zoom factor of 
the image on the screen. 

This is a pull-out toolbar. Hovering on the currently selected Zoom 

button (in this case,  Resize to Fit ) displays the Zoom toolbar. 

 Resize to Fit - zooms the image so that it just fits in the window. 

It converts this: 

 
into this: 

 
This zooms in or out as required. So, it also zooms a microscopic 
image on the screen to one that just fits inside the window. 
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 If you can't see your graphics, click the Resize to Fit  button 
on the View toolbar to fit the graphics to the middle of the 
screen. 

 Zoom In - doubles the size of the image. Click this button 
repeatedly until the required zoom factor is reached. The image is 
zoomed about the centre of the graphics window. 

 Zoom Out - halves the size of the image. Click this button 
repeatedly until the required zoom factor is reached. The image is 
zoomed about the centre of the graphics window. 

 Zoom to Box - zooms in to a specific area of the image. Click and 
then use the left mouse button to drag a zoom box on the image. 
The view is then zoomed to fit the boxed area. 

It converts this: 

 

 - Zoom box 

into this: 
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 You can also resize an image by holding down the Ctrl key 
and the middle (or right) mouse button, and then dragging 
the mouse up to Zoom In or down to Zoom Out. 

 

Panning 
You can Pan the image by holding down the Shift key and the 
middle (or right) mouse button, and then dragging the mouse in the 
direction in which you want to move the image. 

 

NC program 
An NC program contains the commands and output settings that 
specify how the machine controller will machine the part. 

It is advisable to create an NC program, and set the preferences for 
it before generating any toolpaths. However, it's just as easy to add 
generated toolpaths to the NC programs later (see page 79). 

 

Overview Template 
1 In explorer, right-click NC Programs and select Preferences. 

 
This displays the NC Preferences dialog. 
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2 On the Output tab of the NC Preferences dialog, select Use Project 
- On to write the NC program file into the PowerMILL project 
folder. 

 Select Use Project - Off to write the NC program file to a 
different folder. You need to specify it in the Output Folder 
field. 

3 Enter the output file name to be used by default in the Output 
File field. 

 The variable %[ncprogram] gives the output file the same 
name as the NC program. You can add your file name to 
this variable. 

 

4 Click  next to the Machine Option File field to open the Select 
Machine Option Filename dialog. 
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5 Browse to the folder where the option files are stored, and select 
the required machine option file (in this case heid.opt) and click 
Open. 

 
This closes the Select Machine Option Filename dialog and returns 
you to the NC Preferences dialog. 

6 Click Accept to save your changes and close the dialog. 
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Creating an NC program 
1 From the NC Programs context menu, select Create NC Program. 

This displays the NC Program dialog. 

2 In the Name field, enter the name you want to call the NC 
program. For example Cavity_Mold. 

 

3 In the NC Program dialog, click the Options  button. The 
Options dialog is displayed. 

4 On the Output tab: 

a If selected, deselect the Write File for Each Toolpath option. 
This causes Output File to be displayed instead of Root Name 
at the top of the NC Program dialog. 

b Select Option File as heid. 
c Enter Output File Extension as opt. 
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d Click Accept to update and close the Options dialog. 

 

 If you want separate output files for each toolpath, select 
Write File for Each Toolpath option. This changes the Output 
File field to Root Name in the NC Program dialog and 
displays the default path and file name in the Output File 
field at the bottom of the dialog. 

The default path in the Output File field is based on the settings 
in the NC Preferences dialog. If you want to change this path, 

click the open folder  button, browse to the appropriate folder, 
and enter the new file name (the file extension is determined by 
the settings you made in step 4b). If you used the %[ncprogram] 
variable in the NC Preferences dialog, hover on the displayed 
path to see how the file name will be resolved by PowerMILL. 

5 Click Accept in the NC Program dialog to accept your selections 
and close the dialog. 
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6 To see the entity that you have just created, click  to expand 
the NC Programs node. The entity is automatically active 
(signified by bold text preceded by the > symbol). 

 

 Any toolpaths you create are automatically added to the 
currently active NC program. 

 

Creating a roughing toolpath 
A Model Area Clearance strategy with the roughing Style set as Offset 
all is used to rapidly remove the majority of excess material on the 
model. This clears the area with contours that are generated by 
repeatedly offsetting the initial contour until no further offsetting is 
possible, and then steps down to the next level and repeats the 
offsetting until the bottom of the part is reached. 

To create a roughing toolpath: 
1 On the Main toolbar, from the Create Toolpath list, select Model 

Area Clearance. 
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This displays the Model Area Clearance dialog. 

 
Use the various tabs to enter parameters required for the 
toolpath. 

2 Give the toolpath an appropriate Name, for example Roughing. 

3 Define the roughing tool geometry (see page 31). 

4 Define the tolerances (see page 36). 

5 Specify rapid move heights (see page 36). 

6 Specify tool start points. (see page 37) 

7 Generate the roughing toolpath (see page 38). 

8 Display the roughing toolpath (see page 38). 

9 Simulate the roughing toolpath (see page 41). 
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Defining the roughing tool geometry 
The next stage involves selecting a tool and defining its geometry. 
This example uses a 16 mm (5/8 inch) tip-radiused tool. 

1 In the Model Area Clearance strategy dialog, click  to select 
the Tool page. 

2 On the Tool page: 

a Click the  arrow next to the Create Tool  button in the 
Tool area. 

b From the tool list, select  to create a Tip Radiused Tool. 

3 On the Tool page, click  to display the Tip Radiused Tool 
dialog. 

 
4 In the Tip Radiused Tool dialog, enter: 

a Name - D16T1 

b Length - 30 mm 

c Tip Radius - 1 mm 

d Diameter - 16 mm 
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e Tool Number - 1 

 

5 Select the Shank tab, click  to add a shank component. Enter: 

a Upper Diameter - 16 mm 

b Length - 70 mm 
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 The Lower Diameter automatically defaults to the Upper 
Diameter. This can be accepted for the current tool. 

 
6 Click Close. 

The tool is automatically aligned with the Z axis: 

 
You can view and edit the created tool: 
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 In explorer, expand  to see the tool that you have 
created. Expand the tool node to see the specific tool's details. 

 
 In the Tool tab on the Model Area Clearance dialog: 

 
 On the Tool toolbar: 

 
 

Tool length overview 
The diagram below shows a cutting tool made up of a tip (yellow) 
and shank (green) mounted in a shrink-fit holder (red). The tool is 
mounted in the spindle of a machine (grey). 
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 The colours shown here correspond to those used in the 
PowerMILL Tool dialogs. 

 

 - Spindle 

 - Holder length 

 - Gauge face 

 - Overhang 

 - Cutting length 

 - Gauge length 

The Cutting Length represents the part of the cutter that removes 
material. This is set up in PowerMILL as the Tip Length. 

The Overhang is the amount by which the cutter protrudes from the 
tool holder. This, typically, includes part of the Shank Length. The 
Overhang is fixed when the cutter is mounted in the holder. 

 To obtain maximum tool life, the Overhang is typically kept to 
the minimum necessary to prevent the holder from hitting the 
part or unmachined stock. 

The Holder Length is the total length of all parts of the holder 
assembly that protrude from the spindle when the holder is 
mounted in the machine. 

The Gauge Length is the total length of the cutter and holder 
assembly when it is mounted in the machine. It is measured from 
the tip of the tool to the Gauge Face, which is the ground face of the 
spindle. 
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Defining the tolerances 
On the Model area clearance page of the strategy: 

1 In Tolerances, enter 0.2 mm. 

2 Enter a Radial thickness  of 0.5 mm. 

3 Enter an Axial thickness  of 0.1 mm. 

4 In Stepover, enter 7.0 mm. 

5 In Stepdown, enter 4.0 mm. 

6 In the stepdown list, select Automatic. 

 The Z Heights are created automatically when the toolpath 
is calculated, and any existing Z Heights values are deleted. 

 The accuracy of the machined part produced by PowerMILL is 
limited by the accuracy of the model read into the program. 
The original model must have been produced to an adequate 
tolerance. 

 

Specifying rapid move heights 
The heights at which the tool can move safely without hitting the 
part or clamps are called rapid move heights. 

Use the Rapid move heights page on a strategy dialog to define the 
Safe Z and Start Z tool heights. 

 To change rapid move heights after a toolpath is calculated, 

click the Rapid Move Heights  button on the Main toolbar to 
display the Rapid Move Heights dialog. 

To specify rapid move heights 
1 Select the Rapid Move Heights page  on the Model 

Area Clearance strategy dialog. 

2 On the Rapid Move Heights page: 

a Check that Safe Area is set to Plane. 
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b Click Calculate. 

 
The use of absolute and incremental Z heights is controlled by 
the type of Rapid Movement selected. 

 

Specifying tool start point 
1 Select the Start point page  on the Model Area Clearance 

strategy dialog. 

2 On the Start Point page, in the Use list, select Block Centre Safe. 
This resets the tool X and Y values to the centre of the block 
model, with the Z coordinate at Safe Z. 
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Generating the roughing toolpath 
On the Model Area Clearance strategy dialog: 

1 Select and expand the Leads and links page: 

a Select the Lead in sub page. 

b From the 1st choice list, select Ramp. 

2 Select the High speed page: 

a Select the Profile smoothing option. Leave the default Corner 
Radius as 0.05. 

b Select Raceline smoothing, and adjust it to a small value, such 
as 5%. 

3 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

4 After the toolpath is generated, Close the strategy dialog. 
 

Displaying the roughing toolpath 
To improve visualisation of the toolpath, you can: 

 Click the Plain Shade  and Wireframe  buttons to draw and 
undraw the model or wireframe. 

 

 To zoom in to the model, hold down the Ctrl key and the 
middle (or right) mouse button, and drag the mouse 
upwards. 
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 Click the Block  button on the View toolbar to undraw the 
block. 

 Click  to expand the Toolpaths node in the explorer. The new 
toolpath is shown in bold and preceded by the > symbol to 
indicate it's active. 

 
 Click the light bulb  next to the toolpath to toggle toolpath 

display on  or off . 
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 Click  next to the toolpath to expand and view the parameters 
and their specific details used to create the toolpath. 

 

 The Safety Status icon  at the top of the toolpath tree shows 
the toolpath is gouge-checked, but not checked for holder 
details. To see more information, expand the Toolpath Safety 
Parameters node in the toolpath tree. 

 

Saving project changes 
When you have unsaved changes (in this case, the toolpath 
information) in your project, an asterisk (*) is displayed in the title 
bar. 

 

Click Save  on the Main toolbar to save the project changes and 
overwrite the previous file. The toolpath information is added to 
your project, and the asterisk disappears from the project header: 
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Simulating the roughing toolpath 
To view a simulation of the toolpath: 

1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

 

 If the Simulation toolbar is not already displayed, select 
View > Toolbar > Simulation. 

3 Select the current toolpath in the first of the two drop-down lists. 
The tool is selected automatically, and the Play buttons are 
highlighted: 

 

4 The buttons on the ViewMill toolbar  control 
the display of the simulation. Select the Rainbow Shaded Image 
option  to visualise the material removed by different 
toolpaths, for example roughing and rest roughing. 
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5 To start the simulation, click the Play  button. Allow the 
simulation to run through to the end. 
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Creating the rest roughing toolpath 
The rest roughing toolpath uses a smaller tool to eliminate the large 
terraces and to rough areas of the model that the large roughing 
tool couldn't reach, such as pockets and corners. 

To create a rest roughing toolpath: 
1 Display the Settings for the previous toolpath. 

 

2 Click the Create a new toolpath based on this one  button. 

3 A copy of the toolpath is created with a suffix of _1. Enter 
RestRoughing in the Toolpath name field to rename it. 

4 Select the Rest Machining option. This switches the strategy to 
Model rest area clearance strategy and enables the Rest page. 

 
5 Define the rest roughing tool geometry (see page 44). 

6 Change the Stepover and Stepdown values (see page 46). 

7 Complete the Model rest area clearance strategy dialog, and 
generate the rest roughing toolpath (see page 47). 
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8 Display the rest roughing toolpath (see page 47). 

9 Simulate the rest roughing toolpath (see page 48). 
 

Defining the rest roughing tool geometry 
You can base the rest roughing tool on the existing roughing tool, 
although it needs a smaller diameter and larger tip radius. 

This example uses a 10 mm (3/8 inch) tip radiused tool. 

1 On the Tool page of the Model Rest Area Clearance dialog of the 

RestRoughing toolpath click the Edit  button. 

 

2 In the Tip Radiused Tool dialog, click  to create a new tool 
entity based on the existing roughing tool. It is given the default 
name of D16T1_1. 

3 Rename the tool to D10T2. 

4 In the other fields, enter: 

a Length - 10 mm 

b Tip Radius - 3 mm 

c Diameter - 10 mm 
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d Tool Number - 2 

 
5 Select the Shank tab and change the values to: 

a Upper Diameter - 10 

b Length - 40 
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The Lower Diameter automatically defaults to the Upper 
Diameter. This can be accepted for the current tool. 

 
6 Click Close. 

 To see the rest roughing tool more clearly, click the light 
bulb icons for the roughing toolpath and tool, (toggle them 
to ). This undraws (but doesn't delete) the entities on the 
screen. 

 
 

Changing the Stepover and Stepdown values 
On the Model rest area clearance page: 

1 Enter a Stepover of 3.0 mm. 

2 Enter a Stepdown of 1.5 mm. 
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Generating the rest roughing toolpath 
On the Model Rest Area Clearance dialog: 

1 Select the Rest page, and: 

a From Rest Machining type list, select Toolpath. 

b From the Toolpath list, select Roughing (the name of your 
roughing toolpath). 

c In the Detect Material Thicker Than field, enter 0.2 mm. The 
calculation ignores rest material thinner than 0.2 mm. This 
helps to avoid thin regions being rest roughed where the 
benefit of a second cut is negligible. 

d In the Expand Area By field, enter 0.2 mm. The rest areas are 
expanded by 0.2 mm measured along the surface. This can be 
used in conjunction with Detect Material Thicker Than to reduce 
the areas to be machined to the essentials (such as, corners), 
and then to offset these areas slightly to ensure that all 
details (for example, on the corners) are machined. 

2 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

3 After the toolpath is generated, Close the strategy dialog. 
 

Displaying the rest roughing toolpath 
Use the Plain Shade , Wireframe , and Block  buttons to 
undraw the model and the block, and then zoom in to view the 
toolpath: 
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Click  to expand the Toolpaths node in the explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

 

 The Safety Status icon  at the top of the toolpath tree shows 
the toolpath is gouge-checked, but not checked for holder 
details. To see more information, expand the Toolpath Safety 
Parameters node in the toolpath tree. 

To save project changes, click  on the Main toolbar. 
 

Simulating the rest roughing toolpath 
To view a simulation of the rest roughing toolpath: 

1 On the Simulation toolbar, select the current toolpath in the first 
of the two drop-down lists. The tool is selected automatically and 
the Play buttons are highlighted: 

 

2 To start the simulation, click the Play  button. Allow the 
simulation to run through to the end. 
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 If you have not started a different session since creating 
the roughing toolpath, the rest roughing toolpath is shown 
in a different colour, overlaid on the roughing simulation 
(see page 41). 

3 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMILL window is displayed. 
 

Closing the roughing session 
Now you have generated the roughing toolpath. Save the project 
and close PowerMILL until you are ready to create the finishing 
strategies. 

To save project changes, click  on the Main toolbar. 

To exit PowerMILL, either select File > Exit from the menu, or click 
the Close button  in the top right-hand corner of the PowerMILL 
window. 
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Re-opening the project 
1 Restart PowerMILL; this automatically loads your toolbar and 

colour selections from the previous session. 

2 Select File > Recent Projects from the menu, and then select the 
project containing the forging die example: 

 
3 When the project is reloaded, adjust the model size and 

orientation as required. 
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Checking which entities are active 
Before you create the finishing toolpaths, you can ensure they are 
automatically added to an NC program: 

1 Check if the NC program in the explorer is shown in bold and 
preceded by the > symbol to indicate it's active. If it's not active, 
right-click the NC program name, and select the Activate option. 

2 Expand the Toolpaths node, and undraw each of the roughing 
toolpaths by clicking the light bulb icon until it shows . Now you 
can easily see the new finishing toolpaths as you create them. 
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Creating a finishing toolpath 
1 Click  on the Main toolbar to display the Strategy Selector 

dialog. 

2 On the Finishing tab, select the Steep and Shallow Finishing 
strategy and click OK. 

 
3 In the Steep and Shallow Finishing dialog: 

a In the Toolpath Name field, enter SteepAndShallow. 

b Select Climb from the Cut direction field. 
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c Change the Stepover value to 0.5. 

 
 

Defining the finishing tool geometry 
The tool currently selected for the Steep and Shallow Finishing 
strategy dialog is the same tool that was used for the rest roughing 
toolpath. This tool is not appropriate for the current toolpath 
strategy, and must be changed. This example uses an 8 mm (5/16 
inch) ball nosed tool. 

1 In the Steep and Shallow Finishing strategy dialog, click to 
select the Tool page. 

2 On the Tool page, from the tool list, select  to create a Ball 
Nosed Tool. 

3 On the Tool page, click  to display the Ball Nosed Tool dialog. 

4 In the Ball Nosed Tool dialog, enter: 

a Name - 8 Ball_LS_TH 

b Length - 20 mm 
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c Diameter - 8 mm 

d Tool Number - 3 

 

5 Select the Shank tab, click  to add a shank component. Enter: 

a Upper Diameter - 12 

b Lower Diameter - 8 
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c Length - 25 

 

6 Click the  button to add a second shank component. Enter: 

a Upper Diameter - 12 

b Lower Diameter - 12 
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c Length - 30 

 

7 Select the Holder tab, and click the  button to add a holder 
component. Enter: 

a Name - 8 mm Ball Holder 
b Upper Diameter - 20 

c Lower Diameter - 20 

d Length - 20 
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e Overhang - 55 

 

8 Click the  button to add the upper part of the holder. Enter: 

a Upper Diameter - 60 

b Lower Diameter - 60 

c Length - 10 
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d Overhang - 55 

 
9 Click Close to update the Tool page with the new tool. 

 The new tool is shown in the explorer, and on the Tool 
toolbar, and it's also drawn in the graphics window, where 
it is automatically aligned with the Z axis. 
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The toolpath is not yet complete as it needs to reference a 
boundary, but you can close the dialog without generating the 
toolpath. 

10 Click OK to close the toolpath dialog. 
 

Creating the boundary for the selected surface 
As it is only the cavity that needs to be finished by this toolpath, 
you can create a boundary for the cavity. 

1 Undraw the 8 Ball_LS_TH tool by toggling the light bulb icon to  
in the explorer. 

 

2 Click the Block  button to undraw the block, and use the 

Wireframe  button to undraw the wireframe. 

3 Use the mouse to select only the cavity surfaces. 

 

 You can use the Drag Selection Mode  on the View toolbar 
to select multiple surfaces. 
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4 In the Boundaries context menu, select Create Boundary > 
Selected Surface. 

 
5 In the Selected Surface Boundary dialog: 

a In the Name field, enter Cavity. 

b In the Tool list, select 8 Ball_LS_TH. 
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6 Click Apply. 

7 The boundary is calculated. It is shown in white by default: 

 

 Selected Surface Boundaries are recalculated if the selected 
surfaces change. This means that they behave like 
toolpaths in the way they take account of the selection 
state at the time of calculation. 

8 Click Accept to close the boundary dialog. 
 

Completing and generating the finishing toolpath 
You now need to add the created boundary to the Steep and Shallow 
Finishing toolpath together with the appropriate leads and links. 

1 In explorer, expand Toolpaths and select the SteepAndShallow 
toolpath. 

2 Right-click and select Settings from the context menu. 

 
3 On the Steep and Shallow Finishing strategy dialog: 

a Select the Limit page and: 

From the Boundary list, select Cavity. 
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From the Trimming list, select Keep inside. 

 

b Expand the Leads and Links page, select the Lead in  page 
and: 
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In the 1st Choice list, select None. 

 
c Select the Links sub page to define link moves between the 

cutting moves in the toolpath and: 
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In the Short list, select On surface to define the type of link 
moves used to connect adjacent passes. 

 
4 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

5 After the toolpath is generated, Close the strategy dialog. 
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Displaying the finishing toolpath 
When the toolpath is generated, it is displayed on the screen: 

 
Click  to expand the Toolpaths node in the explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

 

To save project changes, click  on the Main toolbar. 
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Simulating the NC program with generated toolpaths 
The new toolpath is automatically added to the active NC program. 
If for some reason, your toolpath is not there, use the mouse to 
drag the toolpath under the NC program manually. 

 

To simulate the NC program: 

1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

3 From the ViewMill Toolbar , select the 
Rainbow Shaded Image option  so you can visualise the 
differences between toolpaths. 
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4 In explorer, right-click the NC program Cavity_Mold, and select 
Simulate from Start from the context menu. 

 
The NC program is automatically selected on the Simulation 
Toolbar, and the Play buttons enabled. 
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5 Click the Play  button, and allow the simulation to run through 
to the end. 

 
6 Zoom into the unmachined areas. You can see that some of the 

corners need cleaning up, particularly between non-tangential 
surfaces. 

 

7 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMILL window is displayed. 
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Creating the Corner Finishing toolpath 
The Corner Finishing toolpath uses a smaller tool to machine the 
remaining corners, particularly between non-tangential surfaces. 

To create the Corner Finishing toolpath: 

1 Click  on the Main toolbar to bring up the Strategy Selector 
dialog. 

2 Select the Corner Finishing strategy on the Finishing tab, and 
click OK. 

 
3 In the Corner Finishing dialog: 

a In the Toolpath name field, enter CornerFinishing_Auto. 
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b Select the Limit page and choose None from the boundary list. 

 
 

Defining the Corner Finishing tool geometry 
You can base the Corner Finishing tool on the tool used for the 
SteepAndShallow strategy, although it needs a smaller diameter. 
This example uses a 6 mm (1/8 inch) ball nosed tool. 

1 Select the Tool page in the Corner Finishing dialog. 

2 From the tool list, select 8 Ball_LS_TH, and click the Edit  
button. 

3 In the Ball Nosed Tool dialog which appears, on the Tip tab, click 

 to create a new tool entity based on the existing tool. 

It is given the default name of 8 Ball_LS_TH_1. 

a Rename the tool to 6 Ball. 
b Enter a Length of 15 mm. 
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c Enter a Diameter of 6 mm. 

d Enter the Tool Number as 4. 
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4 To adjust the shank to match the tip, select the Shank tab, click 
the bottom shank component (it turns pale green), and enter 6 in 
the Lower Diameter field. 

 
5 You can leave the Holder as it is. Click Close to update the 

toolpath dialog with the new tool. 

The new tool is shown in the explorer, and on the Tool toolbar, 
and it's also drawn in the graphics window, where it is 
automatically aligned with the Z axis. 

 

Completing and generating the Corner Finishing 
toolpath 

In the Corner Finishing strategy dialog: 

1 Select the Corner finishing page and: 

a From the Output list, select Both. This creates two separate 
toolpaths for steep and shallow regions. 

b Enter a Threshold Angle of 65. This specifies the angle, 
measured from the horizontal, that determines the split 
between steep and shallow portions of the surface slope. 
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c Enter a Cusp of 0.01. This defines the maximum allowable 
cusp height. The stepover between tool passes is 
automatically calculated from this value and the geometry of 
the tool and part. 

d From the Cut direction list, select Any. This uses both the 
Climb and Conventional methods of milling. 

2 Select the Corner detection page and: 

a Select 8 Ball_LS_TH from the toolpath reference list. The 
Corner Finishing toolpath makes a comparison between the 
current and previous tools, and automatically machines the 
corners that the previous tool was unable to access. 

b Enter an Overlap of 0.5. This indicates how far the toolpath is 
extended beyond the borders of the un-machined region. It is 
also used as the overlap value between the steep and shallow 
portions of the toolpath. 

c Enter a Detection limit of 165. This specifies the angle at which 
PowerMILL finds corners. Only corners less than the specified 
angle are machined. 

3 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

4 After the toolpath is generated, Close the strategy dialog. 
 

Displaying the Corner Finishing toolpath 
When the toolpath is generated, it is displayed on the screen: 
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Click  to expand the Toolpaths node in the explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

If the NC program Cavity_Mold remains active, the toolpath is 
automatically added to it: 

 

To save project changes, click  on the Main toolbar. 
 

Simulating the Corner finishing toolpath 
1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

3 From the ViewMill Toolbar , select the 
Rainbow Shaded Image option  so you can visualise the 
differences between toolpaths. 
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4 In explorer, right-click the NC program Cavity_Mold, and select 
Simulate from Start from the context menu. 

 
The NC program is automatically selected on the Simulation 
toolbar, and the Play buttons enabled. 
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5 Click the Play  button, and allow the simulation to run through 
to the end. 

 
6 Zoom into the machined areas to view the cleaning up of the 

non-tangential surfaces. 

 
This compares with the previous finishing toolpath which left 
some material in the corners. 
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7 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMILL window is displayed. 
 

Writing NC programs 
When the toolpaths are generated, you can add them to an NC 
program to be postprocessed as an output file for a specific NC 
machine controller. Any number of toolpaths can be included, and 
reordered as required depending on the limitations of the particular 
NC machine and the postprocessor. 

By default, all toolpaths in an NC program are saved to a single NC 
program file. The following examples show you how to: 

 Write each toolpath as a separate NC program file (see page 77). 

 Write two NC program files (see page 79) with the toolpaths 
grouped by their functionality. 

 

Writing each toolpath as a separate NC program file 
This procedure shows how to generate separate NC program files 
for each toolpath in an NC program. 

 To have separate NC program files for each of your toolpaths, 
the Write File for Each Toolpath option must be selected on the 
Output tab available from Tools > Options > NC Programs. 
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1 In explorer, right-click the NC program, Cavity_Mold, and select 
Write from the context menu. 

 

 The  symbol against a toolpath indicates a tool change. It 
is always displayed for the first tool in the sequence. It is 
also displayed when a different tool is used. 

2 PowerMILL postprocesses the toolpaths using the specified 
parameters, and displays a confirmation window showing where 
the files are saved. 

 
3 Click to  close the Information window. 
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4 The colour of the NC program Cavity_Mold in the explorer 
changes to a bright green colour, , to show it has 
been calculated correctly. 

5 To save project changes, click  on the Main toolbar. 
 

Writing two NC program files 
This procedure shows how to generate two NC program files, one 
with two roughing toolpaths, and another with the two finishing 
toolpaths. 

1 From the NC Programs context menu, select Create NC Program. 

 
This displays the NC Program dialog. 

2 In the Name field, enter Cavity_Roughing. 

3 In the NC Program dialog, click the Options  button. The 
Options dialog is displayed. 

4 On the Output tab: 

a If selected, deselect the Write File for Each Toolpath option. 
This causes Output File to be displayed instead of Root Name 
at the top of the NC Program dialog. 

b Select Option File as heid. 
c Enter Output File Extension as opt. 
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d Click Accept to update and close the Options dialog. 

 
5 Click the Accept button at the bottom of the NC Program dialog to 

create a new roughing NC program. 

6 Right-click the individual NC program Cavity_Roughing, and 
select Edit > Copy NC Program. 

7 A new entity is added to the NC Programs list with the default 
name of Cavity_Roughing_1. Right-click it and Rename it as 
Cavity_Finishing. 

 

 To identify which NC program is currently active, expand 
the NC Programs node in the explorer; the active program 
is shown in bold and preceded by the > symbol. 
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8 In explorer, move the two roughing toolpaths under 
Cavity_Roughing, and the two finishing toolpaths under 
Cavity_Finishing. 

 
9 Select the Cavity_Roughing and Cavity_Finishing NC programs. 

Right-click, and select Write Selected. 
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10 PowerMILL post-processes the NC programs using the specified 
parameters, and displays a confirmation window showing where 
the programs are saved. 

 

 Two NC programs are written, Cavity_Roughing.tap 
containing both roughing toolpaths, and Cavity_Finishing.tap 
containing both finishing toolpaths. 

11 Click  to close the Information window. 

12 To save project changes, click  on the Main toolbar. 
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3 
3D offset moves • 14 

A 
Along moves • 69 
Area clearance 

Offset • 29, 43 
Tool geometry • 31, 44 

C 
Cavity mold example • 14 
Constant Z moves • 14 
Contour offsetting • 14, 48 
Corner finishing • 69, 74 
Creating tree objects •  See Entities 
Cutting length • 34 

D 
Defining block • 17 
Displaying toolpaths • 38, 47, 65, 73 

E 
Entities 

Renaming • 10 
Verifying active • 51 

F 
Finishing toolpaths 

Interleaved constant Z • 52 
Tool geometry • 53, 70 

Forging die mold •  See Cavity mold 
example 

G 
Gauge length • 34 
Graphics window • 6 

H 
Holder length • 34 

I 
Imperial units • 5, 11 
Isometric vews • 20 

M 
Metric units • 5, 11 
Models 

Opening • 15 
Resizing to fit • 20, 22 
Shading • 20 
Viewing • 20 

N 
NC programs 

Creating • 24 
Setting preferences • 24 
Writing • 77, 79 

O 
Opening 

Models • 15 
Projects • 50 

Index 
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Overhang • 34 

P 
PowerMILL 

Closing • 5 
Context help • 10, 12 
Entities • 9, 10, 11 
Explorer • 9, 51 
Manuals • 13 
Projects 

Opening • 50 
Saving • 19, 40 

Starting • 5 
Startup window • 6 
Status bar • 12 
Toolbars 

Main • 6, 29 
Tooltips • 12 
Units 

About • 5, 11 
Changing to imperial • 11 

R 
Rapid move heights • 12, 36 
Resizing to fit • 20, 22 
Roughing toolpaths 

Rest roughing • 43 
Roughing • 29 
Tool geometry • 31, 44 

S 
Screen layout • 6 
Selected surface boundary • 59 
Shank length • 34, 44 
Stepdown • 36, 46 
Stepover • 36, 46 
Stitch moves • 69 
Surfaces 

Non-tangential, machining • 69 
Selecting • 59 

T 
Temporary file area • 4 
Tip length • 34, 44, 70 

Toggle Simulation window • 41, 48, 66, 
74 

Tolerance • 36 
Tool geometry • 31, 44, 53, 70 
Toolbars 

Main • 6, 29 
Toolpath 

Displaying • 38, 47, 65, 73 
Finishing • 52, 61, 69 
Roughing • 29, 43 
Simulating • 41, 48, 66, 74 
Writing • 77, 79 

Tools 
Ball nosed tool • 53, 70 
Length definitions • 34 
Start point • 37 
Tip radiused • 31, 44 

Tooltips • 12 

V 
ViewMill • 41, 48, 66, 74 
Views 

Isometric • 20 
Locating • 22 
Panning • 24 
Predefined • 20 
Zoom in and out • 22 

W 
Wireframe • 20, 38, 47, 59, 65, 73 
Working directories • 2 

Setting up a Home environment in 
Windows • 2 
Setting up your working directories • 
2, 4 
Specifying PowerMILL Default 
Directory paths • 3 
Specifying PowerMILL temporary file 
area • 4 

 





PowerMILL             R2

Powering your productivity

Delcam Headquarters | Small Heath Business Park | Birmingham | B10 0HJ | UK 
+44 (0)121 766 5544 | marketing@delcam.com | www.delcam.com

To contact your local reseller, visit www.delcam.com/resellers

© Copyright Delcam plc 2012. All other trademarks are the property of their respective owners.

PowerMILL 2012

new features

www.delcam.tv/lz

www.delcam.tv

www.powermill.com

PowerMILL Learning Zone

Delcam TV

PowerMILL Website


	PowerMILL 2012 R2 Getting Started
	Contents
	Introduction
	Setting up your working directories
	Setting up a Home folder in Windows 7 for user-defined macros
	Specifying PowerMILL Default Directory paths
	Specifying PowerMILL temporary file area


	Start and close PowerMILL
	Startup window
	Explorer
	Renaming an entity

	Unit System
	Accessing Help
	Tooltips
	Status bar help
	Context-sensitive online help
	Manuals


	Cavity mold example
	Loading the model
	Defining the block around the die
	Saving the project for the first time
	Viewing the model and block
	Predefined views
	Zoom
	Panning

	NC program
	Overview Template
	Creating an NC program

	Creating a roughing toolpath
	Defining the roughing tool geometry
	Tool length overview

	Defining the tolerances
	Specifying rapid move heights
	Specifying tool start point
	Generating the roughing toolpath
	Displaying the roughing toolpath
	Saving project changes
	Simulating the roughing toolpath

	Creating the rest roughing toolpath
	Defining the rest roughing tool geometry
	Changing the Stepover and Stepdown values
	Generating the rest roughing toolpath
	Displaying the rest roughing toolpath
	Simulating the rest roughing toolpath

	Closing the roughing session
	Re-opening the project
	Checking which entities are active
	Creating a finishing toolpath
	Defining the finishing tool geometry
	Creating the boundary for the selected surface
	Completing and generating the finishing toolpath
	Displaying the finishing toolpath
	Simulating the NC program with generated toolpaths

	Creating the Corner Finishing toolpath
	Defining the Corner Finishing tool geometry
	Completing and generating the Corner Finishing toolpath
	Displaying the Corner Finishing toolpath
	Simulating the Corner finishing toolpath

	Writing NC programs
	Writing each toolpath as a separate NC program file
	Writing two NC program files


	Index

	Contact Delcam


