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 مقدمه 

QGIS کاربر می تواند به   را می توان یک نرم افزار رایگان و متن باز در زمینه سیستم اطلاعات جغرافیایی دانست که

  های  پروژه مکانی  های   داده  تواند می   همچنین  کند، ویرایش یا و مشاهده  را  مکانی اطلاعات   کمک این نرم افزار

 .نماید  تحلیل و تجزیه  دقت به را  موجود 

ی مکانی  این است که کاربر می تواند به کمک آن نقشه ها qgis علاوه بر موارد گفته شده، مهمترین قابلیت نرم افزار 

 .ایجاد کند و آن خروجی متناسب با نیاز خود بگیرد 

 :این نرم افزار از قابلیت ها و جنبه های کاری مختلف برخوردار است که در زیر با مهمترین آنها آشنا می شویم 

برای پردازش گرافیکی روی انواع   Georefrecing ، (  GDAL )قابلیت استفاده از ابزار های پردازشی مانند •

 داده ها 

 ا بر روی انواع داده ه(  …identify   ،search ،selection )   قابلیت کاوش به کمک نرم افزار هایی مانند  •

  ،shapefile ،  kml یا با فرمت های مختلف مانند  vector و  raster قابلیت نمایش انواع داده ها به شکل •
geojson 

 Arcpy   قابلیت نوشتن کد های پایتون با استفاده از ماژول •

 قابلیت استفاده از افزونه های آماده یا نوشتن افزونه های جدید  •

  OSMو یا استفاده از سرور های نقشه ای WebGIS  قابلیت ساخت ساخت •

 نرم افزارshapefile  بخش در ها  نقشه از  خروجی گرفتن   نیز قابلیت ساختن نقشه، مدیریت نقشه و  •

  و ذخیره آن با فرمت دلخواه osm ، ویرایش اطلاعات osm  قابلیت استفاده از نقشه  •

 vector و raster قابلیت پشتیبانی از لایه های •

 line و  polygon  ، point قابلیت تبدیل داده های وکتوری به •

  

https://mapscale.ir/web-gis/
https://mapscale.ir/%d9%86%d8%ad%d9%88%d9%87-%d8%b3%d8%a7%d8%ae%d8%aa-%d8%b4%db%8c%d9%be-%d9%81%d8%a7%db%8c%d9%84-%d9%88-%d9%84%d8%a7%db%8c%d9%87/
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 QGIS افزارنمایش نقشه در نرم 

 QGIS .های پروژه خود اضافه کنید به لایه  (Basemap) ، باید یک نقشه پایهQGIS افزاربرای نمایش نقشه در نرم

ها در اختیار شما  برای کار با داده  (Canvas) دهد و فقط یک بوم خالیای را نمایش نمی فرض، نقشه به صورت پیش 

 .دهدقرار می 

ترین و بهترین راه، استفاده از  های داخلی یا خارجی استفاده کنید. سادهتوانید از پلاگین برای اضافه کردن نقشه پایه، می 

 .است  QuickMapServicesپلاگین  

 QuickMapServices   افزودن نقشه پایه با استفاده از پلاگین 

 نصب پلاگین  .1

 .بروید    Plugins > Manage and Install Plugins، به مسیر QGIS در نوار منوی بالای 

 .را تایپ کنید  "QuickMapServices" عبارت  (Search bar) شود، در قسمت جستجوای که باز می در پنجره 

 .نصب، پنجره را ببندید کلیک کنید. پس از  Install Plugin پلاگین را پیدا کرده و روی دکمه 

 اضافه کردن نقشه  .2

 .شوداضافه می  "Web" پس از نصب پلاگین، در نوار منو یک گزینه جدید با نام  

 OSM" (OpenStreetMap)"کلیک کنید و از زیرمنو، یک منبع نقشه مانند   Web > QuickMapServices روی 

 .را انتخاب کنید  "Google"یا  

 ، نقشه به صورت خودکار به بوم (  Google Satelliteیا   OSM Standardها )مثلاً  با انتخاب هر یک از گزینه 

QGIS  توانید محدوده خود را روی آن مشاهده کنیداضافه شده و می. 

OSM Standard  ( 1404: سرعت لود مناسب بدون نیاز به استفاده از فیلتر شکن ) در حال حاضر  تابستان 

ای، خیابانی و توپوگرافی دسترسی خواهید  های ماهوارهها مانند نقشه ستفاده از این پلاگین، به طیف وسیعی از نقشه با ا

 .داشت
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 QGIS ای بهاضافه کردن نقشه ماهواره

فرض در  به صورت پیش  ESRI یا  Google و لایسنس، منابعی مانند   API گاهی اوقات به دلیل مسائل مربوط به

 .شوندنمایش داده نمی  QuickMapServicesلیست پلاگین  

 ESRI و  Google سازی فعال 

 :ها را به صورت دستی فعال کنید. مراحل زیر را دنبال کنیدها در لیست شما ظاهر شوند، باید آن برای اینکه این گزینه 

 .بروید Web > QuickMapServices > Settings ، به مسیر QGIS در نوار منوی

 .بروید More Services ، به سربرگ Settingsدر پنجره 

 .کلیک کنید "Get contributed pack"روی دکمه 

های اضافی )که توسط کاربران به اشتراک گذاشته شده( را  با این کار، پلاگین به صورت خودکار یک بسته از سرویس 

هایی  ، باید بتوانید سرویس QGIS استارت کردنام این مرحله و ریکند. پس از انج دانلود و به لیست شما اضافه می 

 .مشاهده کنید QuickMapServices را در لیست    ESRI، و منابع Google Satellite ،Google Mapsمانند  
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 QGIS در WGS 84 تبدیل مختصات به

دو عدد به    نی هستند. ا  UTM( به صورت 3731549و   511178) رید که شما ارائه دا جغرافیایی ت یه طور مثال مختصا

 . دهندی نقطه را نشان م   کی(  Northing) ینگار( و شمال Easting) ی نگارشرق  بیترت

 : د یرا دنبال کن  ری مراحل ز د یبا  د،یوارد کن QGISدر   یمختصات را به درست ن یا نکه یا یبرا

 د ی جد   ه ی لا   ک ی   جاد ی اول: ا   گام 

 .بروید Layer > Create Layer > New Shapefile Layer ، از منوی بالا به  QGIS در

 .را انتخاب کنیدبا توجه به نیازتان(  Polygon)یا   Point   گزینه     Geometry typeدر پنجره باز شده، برای  

 مربوط به منطقه جغرافیایی خود را انتخاب کنید.   UTM ، باید سیستم مختصاتCRSبرای 

 

 ( . شود استفاده می    40Nیا  WGS 84 / UTM Zone 39N برای ایران، اغلب از  )  

 گام دوم: وارد کردن مختصات 

 .را فعال کنید Toggle Editing روی آن کلیک راست کرده و   Layersپس از ایجاد لایه، در پنل 

 .کلیک کنید  Add Point Feature در نوار ابزار، روی آیکون 

 .ه دلخواه کلیک راست کنید تا مختصات وارد کنیدروی نقشه در هر نقط

 :شود، مختصات خود را به صورت زیر وارد کنید که باز می   "Vertex Editor"در پنجره 
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X (Easting): 511178 

Y (Northing): 3731549 

 OK ذخیره کنید  را بزنید تا نقطه روی نقشه قرار گیرد. در نهایت، حالت ویرایش را غیرفعال کرده و تغییرات را. 

را   (   در پایین سمت راست )  برای اینکه نقشه شما به درستی روی نقشه پایه نمایش داده شود، سیستم مختصات پروژه

 د. تغییر دهی  WGS 84به 

 

 OSMدقت به این نکته ضروری است که کارهایی که در بالا به ان اشاره شد هم باید برای لایه نقشه )مثلا   •

Standard    انجام شود و هم برای لایه پالی گان ایجاد شده. در غیر این صورت مختصات درست نمایش )

 داده نمی شود.!! 

 مختصات به   Sourceو بعد تب    Propertiesو سپس    (   OSM Standard)مثلا  راست کلیک روی نقشه   •

•  WGS 84 / UTM Zone 39N   .تغییر داده شود 

علاوه بر این  فایل تمپلت در لینک زیر بارگزاری شده است که تمام این تنظبمات روی آن انجام شده است.   •

 یک پالی گان نیز رسم شده که میتوانید مختصات آن را متناسب با پروژه خود تغییر دهید.  

• https://bayanbox.ir/download/5003419869715784775/Q-Vidoja4.qgz 

 

https://bayanbox.ir/download/5003419869715784775/Q-Vidoja4.qgz
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 QGISهای خاص در وجوی نام شهرها یا مکانجست

 یابی وجوی مکان ترین راه استفاده از نوار جست ، سادهQGISهای خاص در  وجوی نام شهرها یا مکان برای جست 

(Locator Bar)   .است 

 .وجود دارد   "Locator Bar"وجوی کوچک به نام  ، یک نوار جستQGIS در قسمت پایین و سمت چپ پنجره اصلی 

 .را فشار دهید  Ctrl + Kوجو، روی این نوار کلیک کنید یا کلیدهای ترکیبی  برای جست 

وجوی شما با استفاده از  گوید که جستشود. این علامت به شما می در ابتدای نوار ظاهر می  (<) تریک علامت بزرگ 

 .شود است( انجام می  OpenStreetMap که بر پایه   Nominatim )مانند   های آنلاینسرویس 

 .در این نوار تایپ کنید(   "Tehran" یا   "تهران "توانید نام شهر مورد نظر خود را )مانند حالا می 

 .شوند وجو نمایش داده می پس از تایپ، نتایج مرتبط به صورت یک لیست در زیر نوار جست

کند و آن را در  افزار به صورت خودکار به آن مکان روی نقشه زوم می خواهید کلیک کنید. نرم ای که می روی نتیجه 

 .دهدمرکز صفحه قرار می 
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وجو به درستی کار کند، باید اتصال اینترنت شما فعال باشد، زیرا اطلاعات از  برای اینکه این جست  :نکته مهم

 مانند )  وجو، یک لایه نقشه پایه ین، بهتر است قبل از جست شوند. همچنهای داده آنلاین بازیابی می پایگاه 

OpenStreetMap  وجو شده را روی نقشه  به پروژه خود اضافه کنید تا بتوانید مکان جست  (  که قبلاً به آن اشاره شد

 .ببینید

 

 :د وجو تغییر کرده باشد. برای بررسی این مورگر روش بالا کار نکرد، ممکن است تنظیمات نوار جست ا

 .بروید Settings > Options به مسیر  

 .را پیدا کنید  Locator در پنجره باز شده، سربرگ  

 .فعال است  Nominatim Geocoder مطمئن شوید که گزینه 
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 QGISافزار ( در نرم Polygonگون )رسم پلی 

ایجاد کرده و سپس با استفاده از ابزارهای  ، ابتدا باید یک لایه جدید QGISافزار ( در نرم Polygonگون )برای رسم پلی 

دهد تا یک محدوده مشخص را به صورت یک  گون خود را ترسیم کنید. این کار به شما امکان می ویرایشی، نقاط پلی 

 شیء وکتور روی نقشه ایجاد کنید. 

 گون گام اول: ایجاد یک لایه جدید پلی 

 بروید.  Layer > Create Layer > New Shapefile Layerافزار، به مسیر در نوار منوی بالای نرم 

 ، مراحل زیر را انجام دهید: "New Shapefile Layer"در پنجره 

File name .یک نام برای فایل خود انتخاب کنید و محل ذخیره آن را مشخص کنید : 

Geometry type از منوی کشویی، گزینه :Polygon  .را انتخاب کنید 

CRS (Coordinate Reference System) توانید از : سیستم مختصات مناسب را انتخاب کنید. معمولاً میWGS 84 

/ UTM Zone  یاWGS 84  .استفاده کنید 

 شود. )سمت چپ( اضافه می  " Layers"کلیک کنید. لایه جدید شما در پنل  OKروی دکمه  

 سازی حالت ویرایش گام دوم: فعال 

 

 ( قرار دهید: editingید خود ترسیم کنید، باید آن را در حالت ویرایش )برای اینکه بتوانید روی لایه جد 
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 را انتخاب کنید.  Toggle Editingاید کلیک راست کنید و گزینه ، روی لایه جدیدی که ساخته " Layers"در پنل 

 شوند. های ویرایشی در نوار ابزار فعال می با این کار، آیکون 

 گون گام سوم: ترسیم پلی 

 کلیک کنید. این آیکون شبیه به یک چندضلعی است.  " Add Polygon Feature"نوار ابزار، روی آیکون در 

 گون خود را روی نقشه ترسیم کنید: ( پلی verticesتوانید با استفاده از ماوس، نقاط )حالا می 

 با هر کلیک چپ، یک نقطه جدید ایجاد کنید. 

 کنید.  کلیک راست  (  گونبرای بستن پلی )پس از رسم آخرین نقطه، 

گون خود یک شناسه یا اطلاعات  توانید برای پلی شود. می باز می  "Feature Attributes"یک پنجره کوچک با عنوان 

 کلیک کنید.  OKدیگر وارد کنید. پس از پر کردن اطلاعات، روی  

 گام چهارم: ذخیره تغییرات 

 گون شما به صورت دائمی در فایل ذخیره شود: پلی  پس از اتمام ترسیم، حتماً تغییرات را ذخیره کنید تا 
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 استفاده کنید.  Layer  > Save Layer Editsکلیک کنید یا از مسیر  Toggle Editingدوباره روی آیکون 

 کلیک کنید.  Saveشود. روی یک پنجره تأیید برای ذخیره تغییرات باز می 

 ایش داده خواهد شد. گون شما روی نقشه نمشود و پلی حالت ویرایش غیرفعال می 

 

 ویرایش نقاط )گوشه های( پالی گان 

 Vertex Tool (currentو زیر منوی  Vertex Tool. سپس روی آیکن  کلیک کنید  Toggle Editingروی آیکون 

layer)    .را انتخاب کنید 

 روی پالیگان ترسیم شده راست کلیک کنید. 

های ترسیم شده  باز می شود که شامل مختصات نقاط گوشه   Vertex Editorدر سمت چپ پایین یک پنجره با نام 

می باشد. با جایگزینی مختصات که از قبل به شما داده شده است با مختصاتی که در این جدول می بینید، میتوانید به  

 دقت مکان مورد نظر را ترسیم کنید. 

 . باشد   0( دقیقا مثل مختصات نقطه    5ان باید مختصات نقطه آخر ) در این مثال نقطه  برای بسته شدن پالی گ  •
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 QGIS گون درمحاسبه مساحت و محیط پلی

توانید از ابزارهای داخلی برنامه استفاده  اید، می ترسیم کرده  QGIS گونی که دربرای محاسبه مساحت و محیط پلی 

 .دارد و بسیار ساده استکنید. این کار نیاز به محاسبه دستی ن

 (Attribute Table)  گام اول: باز کردن جدول اطلاعات

 .گون خود کلیک راست کنید، روی لایه پلی Layersدر پنل 

را انتخاب کنید. با این کار، جدولی شامل اطلاعات تمام اشکالی که در آن لایه   Open Attribute Table گزینه 

 .شودمی اید، باز ترسیم کرده 

 های جدید برای مساحت و محیط گام دوم: ایجاد ستون 

 .)شبیه به یک مداد( کلیک کنید Toggle Editing Mode در جدول اطلاعات، روی دکمه  

 .)شبیه به یک اَباکوس یا ماشین حساب( کلیک کنید Open Field Calculator سپس روی دکمه 

 :برای محاسبه مساحت 

 Create a new field نتخاب کنید را ا. 

 Output field name   را به  "Area"  تغییر دهید. 

 Output field type   را Decimal number (real) قرار دهید. 

 .را تایپ کنید     area$   )پایین پنجره(، عبارت Expression در بخش

 .شود کلیک کنید. یک ستون جدید با مقادیر مساحت به جدول شما اضافه می   OKروی  

 :محاسبه محیط   برای 

 .را باز کنید  Open Field Calculator دوباره  

 Create a new field  را انتخاب کنید. 

 Output field name   را به "Perimeter"  تغییر دهید. 

 Output field type   را Decimal number (real) قرار دهید. 

 .را تایپ کنید perimeter$     ، عبارت Expression در بخش

 .شودکلیک کنید. یک ستون جدید با مقادیر محیط به جدول شما اضافه می  OK روی 

 گام سوم: ذخیره و مشاهده نتایج 

 .کنید  Save کلیک کنید و تغییرات را  Toggle Editing Mode ها، دوباره روی دکمه پس از اضافه شدن ستون 
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 س ) د را مشاهده کنید. واحد این مقادیر بر اساگون خوتوانید مساحت و محیط پلی اکنون در جدول اطلاعات، می 

CRS شود )مثلاً متر مربع یا کیلومتر مربع(لایه شما محاسبه می   )سیستم مختصات. 

  1000000مقدار مساحت را بر این  اگر واحد متر مربع بود و خواستید به کیلومتر مربع تبدیل کنید کافیست  •

 ی شود: یعنی فرمول ها به این صورت م  .تقسیم کنید 

$area / 1000000 

 شود:   1000و برای تبدیل متر به کیلومتر برای پارامتر محیط کافیست مقدار بدست آمده تقسیم بر 

$perimeter / 1000   

توانید مستقیماً نام یا نوع آن را تغییر  اید، نمی مساحت ایجاد کرده محیط و برای ویرایش فیلدی که قبلاً برای  •

راه حل:    .شوندهای آن مانند نام و نوع داده قفل می از ایجاد یک فیلد )ستون(، ویژگی ، پس QGIS دهید. در 

 و حذف فیلد قبلی است!!   ایجاد یک فیلد جدید 
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 QGISجدول اطلاعات در 

کنید، تعلق دارد. برای مشاهده آن، باید یک لایه فعال در  هایی که شما ایجاد می به لایه QGIS جدول اطلاعات در 

 .داشته باشید پروژه 

 نحوه دسترسی به جدول اطلاعات 

خواهید جدول اطلاعاتش را ببینید  ای را که می )معمولاً در سمت چپ پایین صفحه(، لایه  "Layers" در پنل   .1

 .اید( پیدا کنید گونی که قبلاً ساخته)مثلاً لایه پلی 

 .کنید  کلیک راست روی آن لایه   .2

 .را انتخاب کنید Open Attribute Table از منوی باز شده، گزینه   .3

های مربوط به اشکال ترسیم شده را  توانید داده شود و شما می پس از کلیک، جدول اطلاعات در یک پنجره جدید باز می 

  .در آن مشاهده کنید
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  (AutoCAD) اتوکد   ه ب QGIS ها از داده خروجی

خروجی بگیرید، باید لایه خود را به   (AutoCAD) افزار اتوکدبرای نرم  QGIS ای خود را از هبرای اینکه بتوانید داده

ترین و  هستند. ساده   DWGو   DXFهای اصلی اتوکد شامل فرمتی تبدیل کنید که اتوکد آن را پشتیبانی کند. فرمت

 .است DXF ترین روش، استفاده از فرمترایج 

 DXF مراحل خروجی گرفتن به فرمت 

 .گون( کلیک راست کنید ها(، روی لایه مورد نظر خود )همان لایه پلی )لایه  "Layers" در پنل   :انتخاب لایه  .1

 .بروید ...Export > Save Features As از منوی باز شده، به مسیر   :گزینه خروجی .2

 :جام دهید ، تنظیمات زیر را ان"...Save Vector Layer As" در پنجره   :انتخاب فرمت و تنظیمات .3

o  Format:  

o   از منوی کشویی، گزینه "AutoCAD DXF" را انتخاب کنید. 

o File name:  

o  کلیک کرده و یک نام و محل ذخیره برای فایل خود مشخص کنید "..."روی دکمه. 

o CRS:  

o سیستم مختصات (CRS)  را روی"Project CRS"  یا"WGS 84"    بگذارید. این کار تضمین

 .اتوکد به درستی نمایش داده شود  کند که مختصات در می

o Geometry type:    

o  ها خروجی گرفته شوند، این گزینه را روی گون خواهید فقط پلی اگر می"Polygon"  بگذارید. 

 .کندشروع به تبدیل و ذخیره لایه می  QGIS کلیک کنید  "OK"روی دکمه  :  تأیید  .4

توانید آن را به راحتی در  شود که می در محل مورد نظر شما ایجاد می  dxf. پس از تکمیل فرآیند، یک فایل با پسوند  

 .افزار اتوکد باز و ویرایش کنیدنرم
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 QGISدر تغییر واحد پروژه 

 Properties > Generalراست کلیک روی نقشه و انتخاب 

 

 


