
Maxwell® 2D 
Student Version

�

A 2D Electrostatic Problem

November 2002



Notice
The information contained in this document is subject to change without notice.
Ansoft makes no warranty of any kind with regard to this material, including, but not limited to, the 
implied warranties of merchantability and fitness for a particular purpose. Ansoft shall not be liable 
for errors contained herein or for incidental or consequential damages in connection with the �
furnishing, performance, or use of this material.
This document contains proprietary information which is protected by copyright. All rights are 
reserved.

Ansoft Corporation
Four Station Square�
Suite 200�
Pittsburgh, PA 15219�
(412) 261 - 3200

Microsoft® Windows® is a registered trademark of Microsoft Corporation.
UNIX� is a registered trademark of UNIX Systems Laboratories, Inc.
Maxwell� is a registered trademark of Ansoft Corporation.

© Copyright 2002 Ansoft Corporation



Getting Started: A 2D Electrostatic Problem
Printing History
New editions of this manual will incorporate all material updated since the previous edition. The 
manual printing date, which indicates the manual’s current edition, changes when a new edition is 
printed. Minor corrections and updates that are incorporated at reprint do not cause the date to 
change.
Update packages may be issued between editions and contain additional and/or replacement pages 
to be merged into the manual by the user. Pages that are rearranged due to changes on a previous 
page are not considered to be revised. 

Edition Date Software 
Revision

1 June 1994 6.2

2 November 2002 9.0
iii



Getting Started: A 2D Electrostatic Problem
Installation
Before you use Maxwell SV, you must:
1. Set up your system’s graphical windowing system.
2. Install the Maxwell software, using the directions in the Ansoft PC Installation Guide.
If you have not yet done these steps, refer to the Ansoft Installation guides and the documentation 
that came with your computer system, or ask your system administrator for help.

Getting Started
If you are using Maxwell SV for the first time, the following two guides are available for the Stu-
dent Version of Maxwell 2D:
• Getting Started: A 2D Electrostatic Problem
• Getting Started: A 2D Magnetostatic Problem
Additional Getting Started guides are available for the standard version of Maxwell 2D.
These short tutorials guide you through the process of setting up and solving simple problems in 
Maxwell SV, providing you with an overview of how to use the software.

Other References
To start Maxwell SV, you must first access the Maxwell Control Panel.
For information on all Maxwell Control Panel and Maxwell SV commands, refer to the following 
online documentation:
• Maxwell Control Panel online help. This online manual contains a detailed description of all of 

the commands in the Maxwell Control Panel and in the Utilities panel. The Maxwell Control 
Panel allows you to create and open projects, print screens, and translate files. The Utilities 
panel is accessible through the Maxwell Control Panel and enables you to view licensing infor-
mation, adjust colors, open and create 2D models, open and create plots using parametric �
equations, and evaluate mathematical expressions. 

• Maxwell 2D online help. This online manual contains a detailed description of the Maxwell 2D 
and the Parametric Analysis modules. Maxwell SV does not provide parametric capabilities.
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Typeface Conventions
Field Names Bold type is used for on-screen prompts, field names, and messages.

Keyboard Entries Bold type is used for entries that must be entered as specified. 
Example: Enter 0.005 in the Nonlinear Residual field.

Menu Commands Bold type is used to display menu commands selected to perform a 
specific task. Menu levels are separated by a carat.
Example 1: The instruction “Click File>Open” means to select the 
Open command on the File menu within an application.
Example 2: The instruction “Click Define Model>Draw Model” 
means to select the Draw Model command from the Define Model 
button on the Maxwell SV Executive Commands menu.

Variable Names Italic type is used for keyboard entries when a name or variable must 
be typed in place of the words in italics. 
Example: The instruction “copy filename” means to type the word 
copy, to type a space, and then to type the name of a file, such as 
file1.

Emphasis and 
Titles

Italic type is used for emphasis and for the titles of manuals and 
other publications.

Keyboard Keys Bold Arial type is used for labeled keys on the computer keyboard. 
For key combinations, such as shortcut keys, a plus sign is used.
Example 1: The instruction “Press Return” means to press the key 
on the computer that is labeled Return.
Example 2: The instructions “Press Ctrl+D” means to press and hold 
down the Ctrl key and then press the D key.
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Introduction
This guide is a tutorial for setting up an electrostatic problem using version 9.0 of Maxwell 2D Stu-
dent Version (SV), a software package for analyzing electromagnetic fields in cross-sections of 
structures. Maxwell SV uses finite element analysis (FEA) to solve two-dimensional (2D) electro-
magnetic problems. 
To analyze a problem, you need to specify the appropriate geometry, material properties, and exci-
tations for a device or system of devices. The Maxwell software then does the following:
• Automatically creates the required finite element mesh.
• Iteratively calculates the desired electrostatic or magnetostatic field solution and special quan-

tities of interest, including force, torque, inductance, capacitance, and power loss. You can 
select any of the following solution types: Electrostatic, Magnetostatic, Electrostatic, Eddy 
Current, DC Conduction, AC Conduction, Eddy Axial. The student version does not contain 
thermal, transient, or parametric capabilities.

• Provides the ability to analyze, manipulate, and display field solutions.
Many models are actually a collection of three-dimensional (3D) objects. Maxwell SV analyzes a 
2D cross-section of the model, then generates a solution for that cross-section, using FEA to solve 
the problem. Dividing a structure into many smaller regions (finite elements) allows the system to 
compute the field solution separately in each element. The smaller the elements, the more accurate 
the final solution.
Introduction 1-1
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Sample Problem
After starting the software and introducing the Executive Commands window, this guide steps you 
through the setup, solution, and analysis of a simple electrostatic problem. The sample �
problem, shown below, is an electrically insulated structure that includes the following:
• Two microstrip lines, one set to +1 volt, and the other set to -1 volt.
• A substrate.
• A ground plane.
In this guide, you will draw, set up, and solve the sample microstrip problem shown below. 
Detailed dimensions and instructions for drawing this model are given in Chapter 4, “Creating the 
Model.”

Microstrips

Substrate

Ground Plane
1-2 Introduction
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General Procedure
Follows this general procedure when using the simulator to solve 2D problems:
1. Use the Solver command to specify which of the following electric or magnetic field quantities 

to compute:
• Electrostatic 
• Magnetostatic 
• Eddy Current 
• DC Conduction 
• AC Conduction 
• Eddy Axial

2. Use the Drawing command to select one of the following model types:

3. Use the Define Model command to access the following options:

4. Use the Setup Materials command to assign materials to all objects in the geometric model.
5. Use the Setup Boundaries/Sources command to define the boundaries and sources for the 

problem.
6. Use the Setup Executive Parameters command to instruct the simulator to compute the �

following special quantities:
• Matrix (capacitance, inductance, admittance, impedance, or conductance matrix, �

depending on the selected solver)
• Force
• Torque
• Flux Linkage
• Current Flow

7. Use the Setup Solution Options command to specify how the solution is computed.
8. Use the Solve command to solve for the appropriate field quantities. For electrostatic �

problems, the simulator computes �, the electric potential, from which it derives E and D.
9. Use the Post Process command to analyze the solution, as follows:

• Plot the field solution. Common quantities (such as �, E, and D) are directly accessible 

XY Plane Visualizes cartesian models as sweeping perpendicularly to the cross-section.
RZ Plane Visualizes axisymmetric models as revolving around an axis of symmetry in 

the cross-section.

Draw Model Allows you to access the 2D Modeler and draw the objects that make up 
the geometric model.

Group Objects Allows you to group discrete objects that are actually one electrical 
object. For instance, two terminations of a conductor that are drawn as 
separate objects in the cross-section can be grouped to represent one 
conductor.

Couple Model Allows you to define thermal coupling for a project. 
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from menus and can be plotted a number of ways. For instance, you can display a plot of 
equipotential contours or you can graph potential as a function of distance.

• Use the calculators. The post processor allows you to take curls, divergences, integrals, 
and cross and dot products to derive special quantities of interest.

The commands shown on the Executive Commands menu must be chosen in the sequence in 
which they appear. For example, you must first create a geometric model with the Define Model 
command before you specify material characteristics for objects with the Setup Materials com-
mand. A check mark appears on the menu next to the completed steps.

These steps are summarized in the following flowchart:

Assign boundary conditions and sources.

Yes

No

Generate solution.

Select solver and drawing type.

Draw geometric model and 
(optionally) identify grouped objects.

Assign material properties.

Compute other 
quantities during 

solution?

Set up solution criteria and 
(optionally) refine the mesh.

Inspect solutions, view solution 
information, display field plots, and 
manipulate basic field quantities.

Request that force, torque, 
capacitance, inductance, 

admittance, impedance, flux 
linkage, conductance, or 
current flow be computed 

during the solution process.
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Results to Expect
After setting up the microstrip problem and generating a solution, you will:
• Plot and analyze voltage contours to view the voltage distribution around the conductors. 
• Compute capacitance.

Time This guide should take approximately 3 hours to work through.
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Creating the Microstrip Project
This guide assumes that Maxwell SV has already been installed as described in the Ansoft PC 
Installation Guide. 
Your goals in this chapter are as follows:
• Create a project directory in which to save sample problems.
• Create a new project in that directory in which to save the microstrip problem. 

Time This chapter should take approximately 15 minutes to work through.
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Access the Maxwell Control Panel
To access Maxwell SV, you must first open the Maxwell Control Panel, which allows you to create 
and open projects for all Ansoft projects. 
To start the Maxwell Control Panel, do one of the following:
• Use the Start menu to select Programs>Ansoft>Maxwell SV. 
• Double-click the Maxwell SV icon.
The Maxwell Control Panel appears. If not, refer to the Ansoft installation guides for assistance.

See the Maxwell Control Panel online help for a detailed description of the other options in the 
Maxwell Control Panel. 

Access the Project Manager
The Project Manager enables you to create and manage Ansoft products. You can add new project 
directories, create projects in existing directories, and rename and copy projects.
To access the Project Manager, click PROJECTS from the Maxwell Control Panel. The Project 
Manager appears.
2-2 Creating the Microstrip Project
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Create a Project Directory
The first step in using Maxwell SV to solve a problem is to create a project directory and a project 
in which to save all the data associated with the problem.
A project directory contains a specific set of projects created with the Ansoft software. You can use 
project directories to categorize projects any number of ways. For example, you might want to store 
all projects related to a particular facility or application in one project directory. You will now cre-
ate a project directory. 
The Project Manager should still be on the screen. You will add the getting_started_SV directory 
that will contain the Maxwell SV project you create using this Getting Started guide. 

To add a project directories, do the following in the Project Manager:
1. Click Add from the Project Directories list. The Add a new project directory window 

appears, listing the directories and subdirectories. 

2. Type the following in the Alias field:
getting_started_SV

Maxwell SV projects are usually created in directories that have aliases — that is, directories 
that have been identified as project directories using the Add command.

3. Select Make New Directory near the bottom of the window. By default, getting_started_SV 
appears in this field.

4. Click OK.
The getting_started_SV directory is created under the current default project directory. You return 
to the Project Manager, and getting_started_SV now appears in the Project Directories list.

Note If you have already created a project directory while working through one of the other 
Ansoft Getting Started guides, skip to the “Create a Project” section.
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Create a Project
Now you are ready to create a new project named microstrip in the getting_started_SV project 
directory. 

Access the Project Directory
Before you create the new project, access the getting_started_SV project directory.
To access the project directory, click getting_started_SV in the Project Directories list of the 
Project Manager.
The current directory displayed at the top of the Project Manager menu changes to show the path 
name of the directory associated with the getting_started_SV alias. If you have previously created 
a model, it will be listed in the Projects list. Otherwise, the Projects list is empty — no projects 
have been created yet in this project directory.

Create the New Project
To create a new project:
1. In the Project Manager, click New in the Projects list. The Enter project name and select 

project type window appears. 

2. Type microstrip in the Name field. Use the Back Space and Delete keys to correct typos.
3. If Maxwell SV Version 9 does not appear in the Type field, do the following:

a. Click the left mouse button on the software package listed in the Type field. A menu 
appears, listing all Ansoft software packages that have been installed. 

b. Click Maxwell SV Version 9.
4. Optionally, enter your name in the Created By field. The name of the person who logged onto 

the system appears by default. 
5. Clear Open project upon creation. You do not want to automatically open the project at this 

point, so that you may enter project notes first.
6. Click OK.
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The information that you just entered is now displayed in the corresponding fields in the Projects 
list. Because you created the project, Writable is selected, showing that you have access to the 
project.

Save Project Notes
It is a good idea to save notes about your new project so that the next time you use Maxwell SV, 
you can view information about a project without opening it. 
To enter notes for the microstrip problem:
1. Leave Notes selected by default.
2. Click in the area under the Notes option. This places an I-beam cursor in the upper-left corner 

of the Notes area, indicating that you can begin typing text. 

3. Enter your notes about the project, such as the following:
This is the sample electrostatic problem created using 
Maxwell SV and the Electrostatic Getting Started guide.

When you start entering project notes, the Save Notes button (located below the Notes area) 
becomes black, indicating that it is enabled. Before you began typing in the Notes area, Save 
Notes was grayed out, or disabled.

4. When you are done entering the description, click Save Notes to save it. After you do, the 
Save Notes button is disabled again.

Now you are ready to open the new Maxwell SV project and run the software.

Note The Model option displays a picture of the selected model in the Notes area. It is disabled 
now because you are creating a new project. After you create the microstrip problem, its 
geometry will appear in this area by default when the microstrip project is selected. For a 
detailed description of the Model option, refer to the Maxwell Control Panel online help.
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Accessing the Software
In the last chapter, you created the getting_started_SV project directory and created the �
microstrip project within that directory.
This chapter describes:
• How to open the project you just created and run Maxwell SV.
• The Maxwell SV Executive Commands window.
• The general procedure for creating an electrostatic problem in Maxwell SV.
• The sample problem and the procedures you will use to simulate its electric fields.

Time This chapter should take approximately 10 minutes to work through.
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Open the New Project and Run the Simulator
The newly created microstrip project should still be highlighted in the Projects list. (If it is not, 
click the left mouse button on it in the list.) 
To run Maxwell SV, click Open in the project area. The Maxwell SV Executive Commands menu 
appears.
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Executive Commands Window
The Executive Commands window is divided into three sections: the Executive Commands 
menu, display area, and the solution monitoring area.

Executive Commands Menu
The Executive Commands menu acts as a doorway to each step of creating and solving the model 
problem. You select each module through the Executive Commands menu, and the software 
returns you to this menu when you are finished. You also view the solution process through this 
menu.

Display Area
The display area shows either the project’s geometry in a model window or the solution to the �
problem once a solution has been generated. Since you have not yet drawn the model, this area is 
blank. The commands along the bottom of the window allow you to change your view of the 
model:

The buttons along the top of the window are used when you are generating and analyzing a �
solution. These are described in more detail in Chapter 6, “Generating a Solution.”

Solution Monitoring Area
This area displays solution profile and convergence information while the problem is solving, as 
described in Chapter 6, “Generating a Solution.”

Zoom In Zooms in on an area of the window, magnifying the view.
Zoom Out Zooms out of an area, shrinking the view.
Fit All Changes the view to display all items in the window. Items will 

appear as large as possible without extending beyond the window.
Fit Drawing Displays the entire drawing space.
Fill Solids Displays objects as solids rather than outlined objects. Toggles with 

Wire Frame.
Wire Frame Displays objects as wire-frame outlines. Toggles with Fill Solids.
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Creating the Model
In the last chapter, you opened the microstrip project, examined the Executive Commands win-
dow, and reviewed the procedure for creating a 2D model. Now you are ready to use Maxwell SV 
to solve an electrostatic problem. The first step is to create the geometry for the system being �
studied.
This chapter shows you how to create the geometry for the microstrip problem that was described 
in Chapter 1, “Introduction,” and in Chapter 3, “Accessing the Software.” 
Your goals for this chapter are as follows:
• Set up the problem region.
• Create the objects that make up the geometric model.
• Save the geometric model to a disk file.

Time This chapter should take approximately 35 minutes to work through.
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Specify Solver Type
The Maxwell SV Executive Commands window should still be on the screen. Before you start 
drawing your model, you need to specify which field quantities to compute. By default, Electro-
static appears as the Solver type. Because you will be solving an electrostatic problem, leave this 
type as it appears.

Specify Drawing Plane
The microstrip model you will be drawing is actually the XY cross-section of a structure that 
extends into the z-direction. This is known as a cartesian or XY plane model. By default, XY Plane 
appears as the Drawing plane. Because the model you will be creating is in the XY plane, leave 
this type as it appears. 
Now, you are ready to draw the model.

Access the 2D Modeler
To draw the geometric model, use the 2D Modeler, which allows you to create 2D structures. 
To access the 2D Modeler, click Define Model>Draw Model. The 2D Modeler appears.
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Screen Layout
The following sections provide a brief overview of the 2D Modeler. 

Menu Bar
The 2D Modeler’s menu bar appears at the top of the window. Each item in the menu bar has a 
menu of commands associated with it. If a command name has an arrow next to it, that command 
also has a menu of commands associated with it. If a command name has an ellipsis next to it, that 
command has a window or panel associated with it.
To display the menu associated with a command in the menu bar, do one of the following: 
• Click on it. 
• Press and hold down Alt, and then press the key of the underlined letter on the command name. 
For example, to display the Window command’s menu, do one of the following:
• Click it.
• Press Alt, and type a W.
The Window menu appears. Click outside the Window menu to make it disappear.

Project Window
The main 2D Modeler window contains the Drawing Region, the grid-covered area where you 
draw the objects that make up your model. This main window in the 2D Modeler is called the 
project window. A project window contains the geometry for a specific project and displays the 
project’s name in its title bar. By default, one subwindow is contained within the project window.
Optionally, you can open additional projects in the 2D Modeler clicking the File>Open command. 
Opening several projects at once is useful if you want to copy objects between geometries. See the 
Maxwell 2D online help for more details.

Subwindows
Subwindows are the windows in which you create the objects that make up the geometric model. 
By default, this window:
• Has points specified in relation to a local uv coordinate system. The u-axis is horizontal, the v-

axis is vertical, and the origin is marked by a cross in the middle of the screen.
• Uses millimeters (mm) as the default drawing unit.
• Has grid points 2 millimeters apart. The default window size is 100 millimeters by 70 millime-

ters.

Note If a geometry is complex, you may want to open additional subwindows for the same 
project so that you can alter your view of the geometry from one subwindow to the next. 
To do so, use the Window>New command as described in the Maxwell 2D online help. 
For this geometry, however, a single subwindow should be sufficient.
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Status Bar
The status bar, which appears at the bottom of the 2D Modeler screen, displays the following:

Message Bar
A message bar, which appears above the status bar, displays the functions of the left and right 
mouse buttons. When selecting or deselecting objects, the message bar displays the number of 
items that are currently selected. When you change the view in a subwindow, it displays the current 
magnification level.

Toolbar
The toolbar is the vertical stack of icons that appears on the left side of the 2D Modeler screen. 
Icons give you easy access to the most frequently used commands that allow you to draw objects, 
change your view of the problem region, deselect objects, and so on. Click an icon and hold the 
button down to display a brief description of the command in the message bar at the bottom of the 
screen.
For more information on these areas of the 2D Modeler, refer to the Maxwell 2D online help.

The Microstrip Model
Use the following dimensions, which are given in mils, to create the geometric model of the 
microstrip you are modeling:

U and V Displays the coordinates of the mouse’s position on the screen and allows 
you to enter coordinates using the keyboard.

UNITS Drawing units in which the geometry is entered.
SNAPTO Which point — grid point or object vertex — is selected when you 

choose points using the mouse. By default, both grid and object points are 
selected so that the mouse snaps to whichever one is closest.

Note In this example, the default drawing size is appropriate. However, if your model were 
much larger or smaller, you would need to change the model size by clicking the 
Model>Drawing Size command. In general, the width of the drawing area should be three 
to five times longer than the width of the geometric model, and the height of the drawing 
area should be three to five times longer than the height of the geometric model.

4.0

20.0 2.0
0.2

0.2

40.0
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Set Up the Drawing Region
The first step is to specify the drawing units to use in creating the model. 
To set up the drawing region:
1. Click Model>Drawing Units. The Drawing Units window appears.

2. Select mils from the list, and then click the Rescale to new units radio button, if it is not 
already selected.

3. Click OK.
The units are changed from millimeters to mils, and mils now appears next to UNITS in the status 
bar at the bottom of the modeling window.
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Create the Geometry
Now you are ready to draw the objects that make up the geometric model.

Keyboard Entry
In the following section, several of the points lie between grid points. You can position these points 
in one of two ways:
• Change the grid spacing so that the object’s dimensions lie on grid points.
• Use “keyboard entry” — that is, enter the coordinates directly into the U and V fields in the 

status bar.
If you change the grid spacing, the screen may become cluttered with too many tightly-spaced grid 
points and make point selection difficult. Therefore, use keyboard entry to enter several of the 
dimensions of the sample geometry.

Create the Substrate
The substrate consists of a simple rectangle on which the two rectangular microstrips will rest. 

Draw a Rectangle
To create the rectangle to represent the substrate:
1. Click Object>Rectangle. After you do, the pointer changes to crosshairs. 
2. Select the first corner of the substrate, the upper-left corner, as follows:

a. Move the crosshairs to the point on the grid where the u- and v- coordinates are (-20, 0). 
Remember that the coordinates of the cursor’s current location are displayed in the U and 
V fields in the status bar.

b. Click the point to select it.
3. To select the second corner of the substrate, use keyboard entry because -4, the v-coordinate, 

lies between grid points. To specify the lower-right corner:
a. Double-click in the U field in the status bar. 
b. Type 20, using the Backspace and Delete keys to correct typos. 
c. Press Tab to move to the V field in the status bar. The value in the dU field changed. The 

dU and dV fields display the values of the offset from the previous point. 
d. Type –4.

4. To accept the point, press Return or click Enter in the status bar. After you do, the New 

Note To change the grid spacing, click the Window>Grid command. 

To change the size of the problem region, click the Model>Drawing Size command.
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Object window appears.

Assign a Name and Color
By default, the object that you are creating is assigned the name object1 and the color red, and the 
Name field is selected.

To define the name and color for the substrate:
1. Type substrate in the Name field. Do not press Return.
2. Click the solid red square next to Color. A palette of 16 colors appears.
3. Click one of the green boxes in the palette.
4. Click OK.
The object now appears in the drawing region as shown below. It is green and has the name �
substrate: 

Note Be sure to change the name of the object to indicate its function and to assign a different 
color to different objects. This will be important later when you assign boundary 
conditions, voltages, and so forth.
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Create the Left Microstrip
Now that you have drawn the substrate, draw the left microstrip. Because the microstrip is rela-
tively small compared to the substrate, you need to zoom in on the top part of the substrate and then 
use keyboard entry to draw it.

Zoom In on Top of the Substrate
To zoom in on the top of the substrate:
1. Click Window>Change View>Zoom In. The pointer changes to crosshairs. 
2. Click on the point on the grid that is slightly to the left of the upper-left corner of the substrate 

and one grid point above it.
3. Move the crosshairs to the point on the grid that is slightly to the right of the upper-right corner 

of the substrate and one grid point below it. As you move the crosshairs, the system draws a 
box on the screen that encloses the selected area.

4. Click to select the point. The area you selected is enlarged to fill the 2D Modeler window, as 
shown below.
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Draw a Rectangle
Create a rectangle to represent the microstrip.
To create the rectangle:
1. Click Object>Rectangle.
2. Select the first corner of the microstrip, the upper-left corner, by entering the following coordi-

nates using the keyboard:

3. Select the second corner of the microstrip, the lower-right corner, by entering the following 
coordinates as you did in the previous step:

The offset values dU and dV change as you enter the points. The New Object window 
appears. 

Assign a Name and Color
To define the name and color for the left microstrip:
1. Change the object’s Name to left.
2. Leave the object’s Color the default color of red.
3. Click OK.
The substrate and the left microstrip appear as shown below: 

Create the Right Microstrip
Because the left and right microstrip have the same dimensions, create the right microstrip by copy-
ing the left one.

Duplicate the Left Microstrip
To create the right microstrip:
1. Click the left microstrip to select it as the object to be copied. A double outline appears around 

it, indicating that it has been selected.

2. Click Edit>Duplicate>Along Line. You must now select two points: first an “anchor” point, 

U -12 Press Tab.
V 0.2 Press Return.

U -10 
V 0

Note As an alternative to selecting an object by clicking on it, use the Edit>Select commands. 
After an object or objects are selected, they are the objects on which all other Edit 
commands are carried out.
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and then a “target” point, which will be the new location for the anchor point.
3. Click the lower-left corner of the left microstrip as the anchor point. After you do, two new 

fields appear in the status bar: dU and dV. These fields allow you to select the target point by 
specifying its offset from the anchor point rather than its u- and v- coordinates.

4. Enter 22 in the field dU to specify the offset between the anchor and target points. 
5. Press Return or click Enter. The Linear Duplicates window appears. 
6. Leave the default 2 in the Total Number field.
7. Click OK to accept the value and complete the command.
Now both microstrips have been created. By default, the new object — the right microstrip — is the 
selected object.

Assign a Name and Color
The 2D Modeler automatically assigns names to copied objects by appending a number to the end 
of the original object’s name. For instance, the right microstrip is assigned the name left1 because it 
is the first copy of the object left. To assign meaningful names to the object, change the name of 
left1 to right.
To rename the right microstrip:
1. Click Edit>Attributes>Rename. The Rename Selected Objects window appears, listing the 

names of all selected objects. Because left1 is the only selected object, it appears in the field 
beneath the Object list.

2. Change the name left1 that appears below the list box to right. 
3. Click Rename. The new name now appears in the Object list at the top of the window.
4. Click OK.
Since you will be creating other objects, you should deselect the right microstrip.
To deselect the right microstrip:
• Click Edit>Deselect All. If a submenu appears, select either Current Project or All Projects.
The microstrip is deselected. 

Save the Geometry
Maxwell SV does not automatically save your work. Therefore, periodically save the geometry to a 
set of disk files while you are working on it. If you have saved your files and a problem occurs that 
causes an unexpected abort, you will not have to re-create the model.
To save the microstrip model now:
• Click File>Save. The pointer changes to a watch while the geometry is written to files. When 

the pointer reappears, the geometry has been saved in a disk file in the microstrip.pjt direc-
tory. 
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Create the Ground Plane
The last object that you need to create is the ground plane.

Zoom In on the Bottom of the Substrate
Before you zoom in on the bottom of the substrate, you must return to a pre-zoomed view of the 
drawing region as follows:
To zoom out of the drawing: 
1. Click Window>Change View>Fit Drawing. After you do, all objects are displayed in the 

drawing region.
2. Click Window>Change View>Zoom In. You can also click the  toolbar icon. �

3. Select a point slightly to the left and one grid point above the lower-left corner of the substrate.
4. Select a point slightly to the right and one grid point below the lower-right corner of the �

substrate. The selected area is enlarged, along with the rest of the model: 
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Displaying Zoomed Models
You can also use the scroll bars on the right side and bottom of the subwindow to change your view. 
Scroll bars appear only when the entire geometric model is not displayed in the window. 
To change your view, do one of the following:
• Click the arrow buttons at the top and bottom of the scroll bar.
• To scroll through the model:

1. Move the cursor to the off-colored bar, or “thumb scroll,” visible on the scroll bar.
2. Drag the thumb scroll up, down, left, or right in the scroll bar to the portion of the model 

that you want to display.
For instance, to pan down a geometric model, drag the thumb scroll in the vertical scroll bar down. 
If the portion of the geometry in which you are interested does not appear, continue to manipulate 
the thumb scrolls until it does.

Draw a Rectangle
The Object>Rectangle command is generally used to create rectangular objects, such as the 
ground plane, while the Object>Polyline command is used to create lines and other simple closed 
shapes. However, to illustrate its use, Object>Polyline is used in this section to create a rectangle.
To create the ground plane:
1. Click Object>Polyline. To create a rectangle using this command, you will select four points 

representing the four corners of the rectangle.
2. Select the lower-left corner of the substrate (–20, –4) as the first point of the rectangle.
3. Select the lower-right corner of the substrate (20, –4) as the second point in the rectangle. The 

2D Modeler draws a line connecting the points. 
4. Use the U and V fields to enter the following coordinates for the third point on the rectangle:

5. Use the U and V fields to enter the following coordinates for the fourth point on the rectangle:

Again, the offset distances change as you enter the coordinates of the second point. 
6. Select the first point — the lower-left corner of the substrate (–20, –4) — twice, either by �

double-clicking or by entering the values and pressing Enter twice. The New Objects window 
appears.

Assign a Name and Color
To define the name and color for the left microstrip:
1. Change the object’s Name to ground.
2. Change the object’s Color to magenta. 
3. Click OK to complete the command.
The object ground occupies a thin region along the bottom edge of the substrate.

U 20
V -4.2

U -20
V -4.2
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Completed Geometry
The geometric model is now complete. 
Click Window>Change View>Fit All to fit all objects on the screen and make them appear as 
large as possible. Your completed geometry should now resemble the one shown below.

Exit the 2D Modeler
To exit the 2D Modeler:
1. Click File>Exit. A window appears, prompting you to save the changes before exiting.
2. Click Yes. The geometry is saved to a disk file in the microstrip.pjt project directory, and the 

Executive Commands window appears. A check mark appears next to Define Model, indicat-
ing that this step has been completed.

Note Because none of the objects are electrically connected at any point in a 3D rendering of 
the model, you do not need to use the Define>Model>Group Objects command.
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Defining Materials and Boundaries
Now that you have drawn the geometry for the microstrip problem and returned to the Executive 
Commands window, you are ready to set up the problem. 
Your goals for this chapter are as follows:
• Assign material attributes to each object in the geometric model.
• Define any boundary conditions that need to be specified, such as the behavior of the electric 

field at the edge of the problem region, and potentials on the surfaces of the microstrips and 
ground plane.

Time This chapter should take approximately 35 minutes to work through.
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Set Up Materials
To define the material properties for the objects in the geometric model, you must:
• Assign the properties of a perfect conductor to both microstrips and the ground plane.
• Assign FR4-epoxy, a dielectric commonly used in circuit boards, to the substrate.
In general, to assign materials to objects:
1. If necessary, add materials with the properties of the objects in your model to the material data-

base.
2. Assign a material to each object in the geometric model as follows:

a. Select the object(s) for which a specific material applies.
b. Select the appropriate material.
c. Click Assign to assign the selected material to the selected object(s).

In this sample problem, you do not have to add materials to the material database — all materials 
that you will need are already included in the global material database that the simulator makes 
available to every project.

Access the Material Manager
To access the Material Manager:
1.  Click Setup Materials. A warning window appears, explaining that materials with a conduc-

tivity greater than 10000 siemens per meter will be treated as perfect conductors and will be 
excluded from the solution region. Materials with lower conductivities will be included in the 
solution region; the conductivities of such materials will not effect the electrostatic simulation, 
since no current flow is modeled.�

Note You must assign a material to each object in the model.

Note For highly conductive materials such as copper, the potential is the same across an object 
that is assigned the material. Because of this, Maxwell 2D’s electrostatic field solver does 
not generate a solution inside objects assigned these materials. Instead, it treats them as 
though they were perfectly conducting.
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Assign a Material to the Substrate
Now assign a material to the substrate.
To assign a material to the substrate:
1. Click substrate in the Object list, or click on the substrate object in the geometric model. 
2. Click FR4_epoxy in the Material list. If it does not appear in the list, use the scroll bars to 

scroll through the list as described in Chapter 4, “Creating the Model.” Capitalized material 
names are listed first.

3. Click Assign.
FR4_epoxy now appears next to substrate in the Object list.
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Assign a Material to the Microstrips and Ground Plane
Now you can assign materials to the microstrips and ground. which are the conductors. 
To assign materials to the conductors:
1. Click Multiple Select at the top of the window, if it is not already enabled.
2. Do one of the following to select left, right, and ground from the Object list:

• Press and hold down Ctrl, and then click each of the object names.
• Press and hold down Shift, and then drag the pointer over the object names.
To deselect an object, click it.

3. Click perf_conductor in the Material list.
4. Click Assign.
The microstrips and the ground plane have now been assigned the properties of a perfect conductor 
(a good approximation of which is copper). Also, perf_conductor appears next to those objects’ 
names.

Assigning Materials to the Background
The background object is the only object that is assigned a material by default. Include it as part of 
the problem region in which to generate the solution. When a material name — such as vacuum — 
appears next to background in the Objects list, the background object is included as part of the 
solution region. 
Because the model is assumed to be surrounded by a vacuum, accept the default material, vacuum, 
for the background. 

Note The potentials on the surfaces of conductors are specified with the Setup Boundaries/
Sources command that is described later in this chapter.

Note In some cases, such as when all objects and electromagetic fields of interest are contained 
within an enclosure, including the background as part of the problem region wastes 
computing resources. It also prevents you from setting boundary conditions defining an 
external electric or magnetic field for the model.

In these cases, you can manually exclude the background from the solution.
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Exit the Material Manager
Now that you ave assigned materials to the objects, exit the Material Manager and return to the 
Executive Commands window where you will continue setting up the project.
To exit the Material Setup window:
1. Click Exit at the bottom-left of the Material Setup window. A window with the following 

prompt appears:
Save changes before closing?

2. Click Yes.
You are returned to the Executive Commands window. A check mark now appears next to Setup 
Materials, and Setup Boundaries/Sources is enabled.

Set Up Boundaries and Sources
After setting material properties, the next step in creating the microstrip model is to define �
boundary conditions and sources.
Initially, all object surfaces are defined as natural boundaries, which simply means that E is �
continuous across the surface. All outside edges are defined as Neumann boundaries, which means 
that the tangential components of E and the normal components of D are continuous across the �
surface.
To finish setting up the microstrip problem, you need to explicitly define the following:
• The voltages on the two microstrips and the ground plane.
• The behavior of the electric field on all surfaces exposed to the area beyond the problem 

region. Because you included the background as part of the problem region, this exposed sur-
face is that of the background object. 

Maxwell SV is unable to compute a solution for the model unless you specify some source of �
electric field. In this model, the microstrips serve as sources of electric potential. 

Note If you exit the Material Manager before excluding or assigning a material to each object 
in the model, a check mark does not appear next to Setup Materials on the Executive 
Commands menu, and Setup Boundaries/Sources remains disabled.

Note Setup Boundaries/Sources will not have a check mark, and the simulator will not 
attempt to solve the problem unless the potential on at least one object’s surface has been 
explicitly defined using the 2D Boundary/Source Manager.
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Display the 2D Boundary/Source Manager
To display the Boundary Manager:
• Click Setup Boundaries/Sources. The 2D Boundary/Source Manager appears. 

Boundary Manager Screen Layout
The Boundary Manager is divided into several sections, each displaying information about a �
particular property of the model and its boundaries. 

Boundary
Each time you choose one of the Assign>Boundary or Assign>Source commands, an entry is 
added to the Boundary list on the left side of the window. When you first access the 2D Boundary/
Source Manager, the Boundary list is empty.

Display Area
The geometric model is displayed so that you can select the objects or edges to be used as �
boundaries or sources, using the Edit>Select commands.

Boundary/Source Information
The area that appears below the geometric model allows you to assign boundaries and sources to 
objects and surfaces and display the parameters associated with the selected boundary or source.
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Types of Boundary Conditions and Sources
There are two types of boundary conditions and sources that you will use in this problem:

You must assign boundary conditions and sources to the following objects in the microstrip �
geometry:

Before you identify a boundary condition or source, you must first identify the surface to which the 
condition is to be applied. You will select and then assign boundaries and sources for the following 
objects:
• left 
• right 
• ground 
• background 
There are several ways to select objects’ surfaces, but in this sample problem you will select each 
object individually. As a result, the object’s surface will be selected. There are also several ways to 
assign values to surfaces. The sample problem illustrates two ways to do so.

Balloon boundary Can only be applied to the outer boundary, and models the case 
in which the structure is infinitely far away from all other 
electromagnetic sources.

Voltage sources Specifies the voltage on an object in the model. The electric 
scalar potential, �, is set to a constant value, forcing the 
electric field to be perpendicular to the objects’ surfaces.

Left microstrip This surface is to be set to 1 volt.
Right microstrip This surface is to be set to –1 volt.
Ground plane The grounded reference. This surface is to be set to zero volts.
Background The outer boundary of the problem region. This surface is to be 

ballooned to simulate an electrically insulated system.
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Set the Voltage on the Left Microstrip
Because the microstrips appear very small, you must first make the model appear larger before 
assigning the voltages. Then you need to select each microstrip and assign a voltage of 1 volt.
To select the left microstrip and assign the voltage:
1. Zoom in on the two microstrips:

a. Click Window>Change View>Zoom In. The cursor changes to crosshairs. 
b. Select two corners of a rectangle that encloses both microstrips.

2. Click Edit>Select>Object>By Clicking. The menu bar commands are disabled, and the sys-
tem expects you to select an item by clicking on it in the model.

3. Click on the left microstrip. After you do, it is highlighted.
4. Right-click anywhere in the display area to stop selecting objects. The commands in the menu 

bar are enabled again, and the left microstrip is the only highlighted object on the screen. Now 
you are ready to assign a voltage to the surface of the left microstrip.

5. Click Assign>Source>Solid. The name source1 appears in the Boundary list, and NEW 
appears next to it, indicating that it has not yet been assigned to an object or surface.

6. In the properties section below the model diagram, verify that Voltage is selected.
7. Change the Value field to 1 V.
8. Click Assign. A value of one volt has now been specified for the left microstrip, and voltage 

replaces NEW next to source1 in the Boundary list.

Set the Voltage on the Right Microstrip
Now set the voltage on the right microstrip to -1 volt.
To select the left microstrip and assign the voltage:
1. Click Edit>Select>Object>By Clicking.
2. Click on the right microstrip.
3. Right-click anywhere in the display area to stop selecting objects.
4. Click Assign>Source>Solid. The name source2 appears in the Boundary list, and the source 

information appears below the model.
5. Verify that Voltage is selected.
6. Change the Value field to –1 volt.
7. Click Assign. A value of –1 volt has been specified for the right microstrip, and voltage 

replaces NEW next to source2.

Note If the appropriate object is not highlighted, or if more than one object is highlighted, do 
the following:

1. Click Edit>Deselect All. After you do, no objects are highlighted.
2. Click Edit>Select>Object>By Clicking, and select the object.
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Set the Voltage on the Ground Plane
Now set the voltage on the ground plane to 0 volts.
To select the ground and assign a voltage:
1. Click Window>Change View>Fit All to make all objects — including the object representing 

the ground plane — appear as large as possible in the subwindow. 
2. Click Edit>Select>Object>By Name. A prompt with the following message appears:

Enter item name/regular expression
3. Enter ground, and click OK. The ground appears highlighted in the model.
4. Click Assign>Source>Solid. The name source3 appears in the Boundary list, and the source 

information appears below the model.
5. Verify that Voltage is selected.
6. Verify that the Value field is set to 0 volts.
7. Click Assign. Now the voltage has been specified for the ground plane, and voltage replaces 

NEW next to source3.

Assign a Balloon Boundary to the Background
The balloon boundary extends the object to which it is assigned infinitely far away from all other 
sources in all directions. Since the structure of the microstrip problem is an electrically insulated 
system, the background should be ballooned.

To select the background and assign a balloon boundary:
1. Click Window>Change View>Fit Drawing so that the limits of the drawing region are �

displayed. 
2. Click Edit>Select>Object>By Clicking.
3. Click anywhere on the background so that the boundary of the drawing region is highlighted.
4. Right-click to stop selecting. The background is the only object selected in the drawing region. 

Now you are ready to assign a balloon boundary to the background. 

Note For this sample problem, all surfaces of the background are ballooned. Thus, you select 
background to pick its entire surface before ballooning it. If you create only part of an 
electromagnetically symmetrical model, at least one surface — the one representing the 
symmetry plane — would not be ballooned. In such a case, do not select the object’s 
entire surface using the Edit>Select>Object commands. Instead, use the 
Edit>Select>Edge command, described in the Maxwell 2D online help, to select the 
three edges to balloon separately from the edge representing the symmetry plane.
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5. Click Assign>Boundary>Balloon. The balloon1 boundary appears in the Boundary list, and 
the following types of balloon boundaries appear at the bottom of the window:

6. Verify that Charge is selected, and then click Assign to define the balloon boundary. The 
background is ballooned, and balloon replaces NEW next to balloon1 in the Boundary list.

Leave Substrate with a Natural Surface
The substrate is to remain with a natural surface. Therefore, its boundary does not need to be 
explicitly defined.

Exit the Boundary Manager
Once the boundaries and sources have been defined, you can exit the Boundary Manager. 
To exit the Boundary Manager:
1. Click File>Exit. A window appears, displaying the following prompt:

Save changes to “microstrip” before closing?
2. Click Yes.
You are returned to the Executive Commands window. A check mark now appears next to Setup 
Boundaries/Sources, and Setup Solution Options and Solve are now enabled.

Charge Models an electrically insulated system. That is, the charge at infinity 
balances the charge in the problem region, forcing the net charge to be zero. 

Voltage Models an electrically grounded system (voltage at infinity is zero). 
However, the charge at infinity may not exactly balance the charge in the 
problem region.
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Generating a Solution
Now that you have created the geometry and set up the problem, you are ready to specify solution 
parameters and generate a field solution. 
Your goals for this chapter are as follows:
• Set up an automatic capacitance calculation.
• Modify the criteria that affect how Maxwell 2D computes the solution.
• Generate the electrostatic solution. The electrostatic solver calculates electric potential at all 

points in the problem region.
• View information about how the solution converged and what computing resources were used. 

Time This chapter should take approximately 35 minutes to work through.
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Set Up a Matrix Calculation
After solving the problem, you will use a capacitance matrix to calculate the capacitance. The 
matrix calculation is defined using the Setup Executive Parameters command.
To set up the capacitance matrix calculation:
1. Click Setup Executive Parameters>Matrix from the Executive Commands menu. The 

Capacitance Matrix Setup window appears.

2. Assign the two microstrips as signal lines:
a. Click left and right in the Object list.
b. Select the Include in matrix check box.
c. Select Signal Line, and click Assign.

3. Assign the ground as ground:
a. Click ground in the Object list.
b. Select the Include in matrix check box.
c. Select Ground, and click Assign.

4. Click Exit to close the Capacitance Matrix Setup window. A message appears, asking if you 
want to save your changes.

5. Click Yes.
You return to the Executive Commands window. A check mark now appears next to the Setup 
Executive Parameters and Setup Executive Parameters>Matrix commands.
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Access the Setup Solution Menu
Maxwell 2D automatically assigns a set of default solution criteria after you assign boundaries and 
sources. As a result, a check mark automatically appears next to the Setup Solution Options but-
ton on the Executive Commands menu after you use the Setup Boundaries/Sources command.
You can generate a solution using the default criteria. In this problem, however, you will change 
two of the criteria to make the solution converge more quickly.
To access and set up the solution options, click Setup Solution Options. The Solve Setup window 
appears.
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Modify Solution Criteria
When the simulator generates a solution, it explicitly calculates the potential values at each node in 
the finite element mesh and interpolates the values at all other points in the problem region.

Specify the Starting Mesh
For this problem, you will use the coarse mesh that is first generated when you begin the solution 
process. This is referred to as the initial mesh.
Leave the Starting Mesh option set to Initial.
The coarse initial mesh for the microstrip problem is shown below: 

Specify the Solver Residual
The solver residual specifies how close each solution must come to satisfying the equations that are 
used to generate the solution. For this model, the default setting is sufficient. 
Leave the Solver Residual field set to the default. 

Note If you had already generated a solution and wanted to take advantage of the most recently 
refined mesh, you would click Current.

Note Some solution criteria are given in scientific notation shorthand. For instance, 1e-05 is 
equal to 1x10-5, or 0.00001. When entering numeric values, you can use either notation.
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Specify the Solver Choice
You can specify which type of matrix solver to use to solve the problem. In the default Auto posi-
tion, the software makes the choice. The ICCG solver is faster for large matrices, but occasionally 
fails to converge (usually on magnetic problems with high permeabilities and small air-gaps). The 
Direct solver will always converge, but is much slower for large matrices. In the Auto position, the 
software evaluates the matrix before attempting to solve; if it appears to be ill-conditioned, the 
Direct solver is used, otherwise the ICCG solver is used. If the ICCG solver fails to converge 
while the solver choice is in the Auto position, the software will fall back to the Direct solver auto-
matically. 
Leave the Solver Choice option set to Auto. 

Specify the “Solve for” Options
The Solve for options tell the system what types of solutions to generate.

Leave both the Fields and Parameters check boxes selected, to solve for both fields and parame-
ters in this example.

Specify the Adaptive Analysis Settings
Set the adaptive refinement settings. 
To adaptively refine the mesh and solution:
• Leave Adaptive Analysis selected. 

This allows the simulator to solve the problem iteratively, refining the regions of the mesh in 
which the largest error exists. Refining the mesh makes it more dense in the areas of highest 
error, resulting in a more accurate field solution.

• Change Percent refinement per pass to 25. 
This causes 25 percent of the mesh with the highest error energy to be refined during each 
adaptive solution (that is, each solve-refine cycle).

• Leave Number of requested passes and Percent error set to their defaults of 10 and 1. 
After each iteration, the simulator calculates the total energy of the system and the percent of 
this energy that is caused by solution error. It then checks to see if the number of requested 
passes has been completed, or if the percent error and the change in percent error between the 
last two passes match the requested values. If either of the criteria have been met, the solution 
process is complete and no more iterations are done.

Exit Setup Solution
When the solution criteria have been defined, you can exit the Solve Setup window. The solution 
criteria are saved automatically upon exiting. 
To save your changes and exit the Solve Setup window, click OK. You return to the Executive 
Commands menu.

Fields A field solution is generated.

Parameters Any special quantities that you set up using the Setup Executive 
Parameters command are computed.
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Generate the Solution
Now that you have set up the solution parameters, the problem is ready to be solved. In the sample, 
the default number of 10 passes is more than enough to ensure the solution converges. 
To execute the solution, click Solve. The solution process begins, and the following actions occur:

• The system creates the initial finite element mesh for the microstrip structure. A bar 
labeled Making Initial Mesh appears in the Solution Monitoring box at the bottom of 
the screen. It shows the system’s progress as it generates the mesh.

• A button labeled Abort appears next to the progress bar and remains there throughout the 
entire solution process. You can click it to stop the solution process.

• A bar labeled Setting up solution files appears.
After the system makes the initial mesh, the electrostatic field solution process begins.

Monitoring the Solution
The following two monitoring bars alternate in the Solution Monitoring area at the bottom. 

Periodically, the solver also displays messages beneath these progress bars.
To monitor the solution after a few adaptive passes are completed, click the Convergence button.

Solution Criteria
Information about the solution criteria is displayed on the left side of the convergence display, as 
shown in the previous figure.

Solving 
Fields 

Displayed as the simulator computes the field solution. After computing 
a solution, identifies the triangles with the highest energy error.

Refining 
Mesh 

Displayed as the simulator refines the regions of the finite element mesh 
with the highest error energy. Since you specified 25% as the portion 
mesh to refine, the simulator refines triangles with the top 25% error.

Number of passes Displays how many adaptive passes have been completed and still 
remain.

Target Error Displays the percent error value that was entered using the Setup 
Solution Options command — in this case, one percent.

Energy Error Displays the percent error from the last completed solution — in 
this case, 1.61 percent. Allows you to see at a glance whether the 
solution is close to the desired error energy.

Delta Energy Displays the change in the percent error between the last two 
solutions — in this case, 5.94 percent.
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Completed Solutions
Information about each completed solution is displayed on the right side of the screen.

Completing the Solution Process
When the solution is complete, a window with the following message appears:

Solution Process is complete.

Click OK to continue.
You are now ready to view the final convergence for the completed solution.

Pass Displays the number of the completed solutions.
Triangles Displays the number of triangles in the mesh for a solution.
Total Energy (J) Displays the total energy of a solution.
Energy Error (%) Displays the percent error of the completed solutions.

Note After a solution is generated, the system does not allow you to change the geometry, 
material properties, or boundary conditions of the model unless you first delete the 
solution. Therefore, you must generate a new solution if you change the model after 
generating a solution.
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Viewing Final Convergence Data
If you have selected another button from the top of the display area, click the Convergence button 
above the viewing window to view the convergence data for the problem. Convergence data for the 
completed solution appears as shown below: 

Because the Energy Error (0.144) and the Delta Energy (0.402) for the seventh pass were both 
less than the specified stopping criterion of one percent, the solution process stopped before all 10 
requested passes were completed. The relatively small changes in the total energy between the last 
few adaptive passes indicate that the solution has converged to the defined criteria.

Note Generally, the energy error decreases after each adaptive pass as the simulator converges 
on an accurate solution. If a problem does not begin to converge after several adaptive 
passes, the problem is probably ill-defined; for instance, boundary conditions may not 
have been specified correctly. 
If this ever happens, do the following:
1. Interrupt the simulator by clicking the Abort button in the Solution Monitoring 

box.
2. Check the problem definition.
3. Generate a new solution for the problem.
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Plotting Convergence Data
By default, convergence data is displayed in table format. This data can also be displayed �
graphically. 
To plot the total energy associated with each pass:
• Click Convergence Display>Plot Total Energy from the bottom of the display area. The �

following plot appears: 

Displaying the data graphically often makes it easier to see how the solution is converging. For 
instance, in the previous plot, the curve begins to level off after the fourth pass as the total energy 
starts to stabilize.
Optionally, use the other commands under Convergence Display to plot the number of triangles or 
percent error for all adaptive passes.
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Viewing Statistics
Click Profile at the top of the Executive Commands window to see what computing resources 
were used during the solution process.

The time the solution process began is displayed at the top of the window. Beneath it, the following 
information is displayed for each adaptive field solution and mesh refinement step completed:
Command/Info Displays the name of the simulator command that was used.
Real Time Displays the time taken to complete the step.
CPU Time Displays the amount of time taken by the PC’s CPU (central 

processing unit) to complete the step.
Mem Size Displays the amount of memory used.
Num Elements Displays the of number of triangles in the finite element mesh.

Note If more data is available than can fit on a single screen, scroll bars appear. 
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Analyzing the Solution
Now that you have generated an electrostatic solution for the microstrip problem, you can analyze 
it using the post processing features of Maxwell 2D.
Your goals for this chapter are as follows:
• Plot the voltage.
• Print a hardcopy of the plot.
• Calculate the capacitance between the two microstrips in the structure.

Time This chapter should take approximately 35 minutes to work through.
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Access the Post Processor
Use the Post Processor to plot quantities and access the calculator menus. 
To access the Post Processor, click Post Process. The 2D Post Processor appears.

Post Processor Screen Layout
The following sections provide a brief overview of the Post Processor in Maxwell 2D. For more 
details, refer to the Maxwell 2D online help. 
With version 9, the Post Processor is now common to both the Maxwell 2D and the Maxwell 3D 
solvers. Most visualization techniques available in 3D can also be used in 2D.

General Areas
The Post Processor is divided into the following general areas:
Menu Bar Appears at the top of the 2D Post Processor window. Generally, it is 

set up the same way as the 2D Modeler’s menu bar. 
Toolbar Appears at the top of the 2D Post Processor window as a row of 

icons. Includes icons with easy access to frequently used commands.
Viewing Window Contains the geometry, allowing you to view the model and plots. 

Displays 2D Post Processor and project name in title bar. 
Side Window Displays the vertex and snap behavior, and shows the coordinates, 

type of coordinate system, and units of length.
Status Area Displays the version number of the Maxwell 2D Post Processor, and 

any status help on the menu command.
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Menu Bar
The post processor’s menu bar appears at the top of the window. Generally, it is set up the same 
way as the 2D Modeler’s menu bar. 

Status Bar
The status bar, which appears on the right side of the post processor screen, displays the following:

Scientific Notation
The simulator displays most values in scientific notation. For example, the value 234 is displayed 
as:

+2.3400e+02

which is equivalent to 2.34x10 2. When entering values, you can use scientific notation or regular 
notation. For example, you can type the value .00021 as .00021 or 2.1e-4.

Mouse Mode Displays the “snap-to-point” behavior of the mouse when points are 
picked from the screen. For instance, when the following is 
displayed:

Mouse Mode

Object Yes

Grid Yes

Keyboard No

the simulator will snap to the closest grid point or object vertex. See 
the description of the command Global/Defaults in Maxwell 2D 
Field Simulator User’s Reference for more details.

Maximums and 
Minimums

Display the maximum and minimum values of x- and y-coordinates 
associated with objects that are being displayed. Essentially, these 
coordinates define the diagonal corners of the problem region.

Mouse position Displays the coordinates of the cursor.

Units Displays the current unit of length.

Mouse functions Display the effect of clicking the left and right mouse buttons. For 
instance, when the simulator is waiting for you to choose a 
command, the following is displayed:

Mouse Left MENU PICK

Mouse Right

Generally, the left button allows you to perform some function while 
the right button allows you to abort the command.
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Plot the Electric Field
Now you are ready to plot the electric field. Use the Plot>Field command as follows to plot the 
field throughout the problem region.
To plot the voltage:
1. Click Plot>Field. The Create New Plot window appears.

2. Click mag E in the Plot Quantity list. This is magnitude of the electric field. 
3. Click Surface -all- in the On Geometry list. This instructs the software to plot the field over 

the surfaces of all the objects in the model. 
4. Click -all- in the In Area list. This option plots the field over the entire model. You can define 

other areas using the Geometry>Create commands. Once an area is defined, it appears in this 
list. 
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5. Click OK. The Scalar Surface Plot window appears. 

6. Verify that the Show color key and Filled check boxes are selected. This allows you to 
observe both the color key and the shading of the created plot. 
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7. Accept the remaining default settings, and then click OK. The field plot appears.

The plotted field range appears in the plot key at the upper-left corner of the screen. By default, this 
range has ten divisions. Maxwell 2D set this range up automatically based on the E-field solution. 

Formatting and Manipulating Plots
Use the Post Processor Plot menu to edit plot attributes.

Note You can change the number of divisions and the range for this contour plot by double-
clicking on the plot key. For more details, refer to the Maxwell 2D online help. 
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To make a plot easier to read, you can move the legend by clicking the right mouse button on it, 
then dragging it into position. You can also adjust the axes to make the plot more readable.You may 
also need to move plots, hide plots, or manipulate other plot characteristics.

Rotate a Plot
You may want to rotate a plot to view different angles.
To rotate a plot, use the hot keys in the following manner:
1. Press and hold down Ctrl, and then click.
2. Move the pointer to the right to rotate the plot.

Hide or Show a Plot
You may want to hide plots to make the remaining plots more readable.
To set a plot’s visibility:
1. Click Plot>Visibility. The Plot Visibility window appears.
2. In the list, click on the plot you want to hide. The Visible column changes to No, and the plot 

disappears.
3. Click on the plot again to show it. The Visible column changes back to Yes, and the plot �

reappears.
4. Click OK to close the Plot Visibility window.

Open Multiple Plots
You can create or open multiple plots and display them individually or tile your windows so that 
you see all of the plots at once.
To open another plot:
1. Click Plot>Open>2D Plot. The Load 2D plot file window appears.
2. Find and select the plot you want to open.
3. Click OK.
To view multiple plots at once, do one of the following:
• Click Window>Tile. Plot windows are arranged so that all are displayed on the screen at the 

same time. 
• Click Window>Cascade. All plot windows are stacked.

Note After you have rotated the plot, to return to XY view, use the following hot key command:

Ctrl+Double-click in upper center of view

When you do this, you return to the original position, rotated by 90 degrees.
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The 2D Calculator
To calculate capacitance, use the 2D field calculator. The field calculator allows you to manipulate 
the field quantities. All functions of the 2D field calculator are described in the Maxwell 2D online 
help. 
To access the 2D Field Calculator:
1. Click Data>Calculator. The Field Calculator appears. 

The calculator is divided into two parts: the top portion displays the contents of the register stack, 
and the bottom portion displays the functions of the calculator. The calculator already contains the 
results of the previous field plot, which is the magnitude of the E-field plotted on all the object 
faces. 
2. Click Done to close the Field Calculator.
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Examine Results of Capacitance Computation
Before using the capacitance matrix results to calculate the capacitance in the Field Calculator, first 
exit the Post Processor, and then examine the results of the capacitance matrix calculation.
To exit the Post Processor and examine the resultant capacitance matrix:
1. Click File>Exit to exit the Post Processor.
2. In the Executive Commands window, click Solutions>Matrix. The capacitance in the C11 

entry should be approximately 6.2 e-11 or 6.3e-11 F/m.
The electrostatic solver calculates the capacitance matrix by solving the final mesh again, this time 
applying a 1 volt excitation to the test conductor and grounding all other signal conductors included 
in the matrix. In this example, the final mesh is solved twice after the final pass: once for the left 
conductor, and once for the right conductor.
The energy for the two 1 volt solutions is used to compute the capacitance for the test electrode, 
using the following equation:

Since the voltage was set to 1 volt, the capacitance is equal to 2 x the energy: 

In the next section, you will verify this calculation.

Verify Capacitance Calculation
You can verify this calculation by returning to the Boundary/Source Manager, resetting the left con-
ductor to 1 volt, and the right conductor to ground.

Reset the Conductor Values
Reset the left microstrip to 1 volt and the right microstrip to 0 volts.
To reset the conductor values:
1. From the Executive Commands menu, click Setup Boundaries/Sources, and click Modify. 

The Boundary/Source Manager appears.
2. Keep the left microstrip Value set to 1 V.
3. Select the right microstrip, reset the Value to 0 V, and then click Assign.
4. Click File>Exit to exit the Boundary/Source Manager, and save changes when prompted.

Remove Mesh Refinement
Set the project up so that it will not refine the mesh this time. Doing so decreases the number of 
passes needed to solve the project.
To remove mesh refinement:
1. Click Setup Solution Options. The Solve Setup window appears. 
2. Clear the Adaptive Analysis check box.
3. Click OK.

U 1
2
---CV2=

C 2U
V2
-------=
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Run the Solution Again
To run the solution again:
1. Click Solve>Nominal Problem.
2. When the solution is complete, click Solutions>Matrix to view the capacitance calculation 

again. It should still be between 6.2 e-11 and 6.3e-11 F/m.

Calculate Capacitance
The energy for the two 1 volt solutions is used to compute the capacitance for the test electrode, 
using the following equations:

 

Since the voltage was set to 1 volt, the capacitance is equal to 2 x the energy: 

Enter the Post Processor Field Calculator Again
Compute the capacitance manually from the energy, and compare this result to the total energy in 
the convergence table.
To open the Post Processor and the Field Calculator:
1. Click Post Process. The 2D Post Processor window appears.
2. Click Data>Calculator. The 2D Field Calculator appears.

Compute the Energy
The first step in computing capacitance is to load the E-field and the D-field into the register stack. 
To load the E-field and the D-field:
1. If any entries remain on the calculator stack, click Clear to remove them. A message appears, 

asking you to confirm your command. Click Yes. The calculator stack is cleared of any exist-
ing values. 

2. Click Qty/E from the Input column to load the electric field vector E into the top register of 
the calculator first. After E is loaded, the top register appears as follows:

Vec: <Ex,Ey>
3. Click Qty/D to load the electric flux density vector D into the top register of the calculator. 

The top register appears as follows:
Vec: <Dx,Dy> 

The register stack now contains the following:

Note Regardless of the drawing units used in the Maxwell 2D Modeler, the field calculator 
expresses all output quantities in MKS (SI) units.

U 1
2
---CV2=U 1

2
--- E D� vd

vol
�= and

C 2U
V2
-------=
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Calculate the Dot Product
Calculate the dot product of the two vector fields. 
To calculate the dot product:
1. Click Dot from the Vector column of calculator commands. After the dot product has been cal-

culated, the top register of the calculator appears as follows:
Scl: Dot(<Ex,Ey>, <Dx,Dy>)

2. Click Geom>Surface from the Input column. The Select Surface window appears.
3. Select all from the list, and click OK.�

The register stack now contains the following:

Integrate the Values
Integrate the value in the top register of the calculator, and save �
it in the top register of the calculator stack. 
To integrate the values:
1. Click the integrate button from the Scalar column. �

The register stack now contains the following:

2. Click Eval from the Output column. �
The register stack now contains the following:

The value in the top register is integrated and summed for all surfaces. The result of that �
integration — 6.277609e-11 — is displayed in the top register of the stack. That sum repre-
sents: 

3. Enter a constant value of 2 as follows:
a. Click Num>Scalar from the Input column. The Scalar Constant window appears.

E D vd�

vol
�
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b. Enter 2 in the Scalar Value field.
c. Click OK.�

The register stack now contains the following:

4. Click / from the General column to divide the top two quantities in the calculator stack. �
The register now contains the total energy of the system, which is 3.1388e-11 joules per meter.�
The register stack now contains the following:

Compute the Capacitance Value
You are now ready to compute the value of the mutual capacitance between the electrodes. The 
energy was calculated in the previous section to be approximately 3.1388e-11. This value should 
still appear in the top register of the calculator stack. 
To obtain the capacitance, you need to multiply the energy by 2.
To compute the capacitance:
1. Click Num>Scalar from the Input column. The Scalar Constant window appears.
2. Enter 2 in the Scalar Value field. 
3. Click OK. 

4. Click * from the General column to multiply the first two quantities in the calculator stack.�
The register now contains the capacitance, which is approximately 6.2776e-11 farads per 
meter.
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Compare these total energy and capacitance values (3.1388e-11 and 6.2776e-11 ) to the total energy 
and capacitance listed in the convergence table in the Executive Commands window (which are 
3.1365e-11 and 6.2732e-11).

Exit the Calculator
Once the calculations are complete, you can exit the calculator and return to the Post Processor. 
To exit the calculator:
• Click Done from the bottom of the calculator.
You return to the 2D Post Processor.

Exit the Post Processor
To exit Maxwell 2D:
1. Click File>Exit from the post processor. A window with the following prompt appears:

Exit Post Processor?
2. Click Yes. The Executive Commands window appears.

Exit Maxwell 2D
Once you have finished the post processing functions, you are ready to exit the software.
To exit Maxwell 2D:
1. Click Exit from the bottom of the Executive Commands menu. The following prompt 

appears: 
Exit Maxwell 2D?

2. Click Yes. The Executive Commands window closes, and the Project Manager reappears.

Exit the Maxwell Software
To exit the Project Manager, click Exit. The Project Manager closes, and the Control Panel �
reappears.
To exit the Maxwell Control Panel:
1. Click EXIT. A window with the following prompt appears:

Exit Maxwell?
2. Click Yes. You return to Microsoft Windows.
You have completed Getting Started: A 2D Electrostatic Problem, the first Getting Started guide for 
Maxwell 2D SV. You can now continue with the second guide in the SV Getting Started series, Get-
ting Started: A 2D Magnetostatic Problem.

Note To view the total energy, click the Convergence button in the Executive Commands 
window. To view the capacitance matrix, click Solutions>Matrix.
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