
Chapter 13

Surface Modeling

After completing this chapter you will be able to:
•  Create an Extruded Surface.
•  Create a Revolved Surface.
•  Create a Sweep Surface.
•  Create a Blended Surface.
•  Create a Swept Blend Surface.
•  Create a Helical Sweep Surface.
•  Create a Surface by Blending the Boundaries.
•  Create a Surface using Variable Section Sweep.
•  Create surfaces using Style environment.
•  Understand surface editing tools.

Learning Objectives
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SURFACE MODELING
Surface models are a type of three-dimensional (3D) models with no thickness. These models
are widely used in industries like automobile, aerospace, plastic, medical, and so on.

Surface models should not be confused with thick models, that is, models having mass properties.
Surface models do not have thickness whereas thick or solid models have a user-defined thickness.
In Pro/ENGINEER, the surface modeling techniques and feature creation tools are the same as
that used in solid modeling. A solid model of any shape that is created can also be created using
the surface modeling techniques. The only difference between the solid model and the surface
model will be that the solid model will have mass properties but the surface model will not.
Sometimes, complex shapes are difficult to create using solid modeling. Such models can be
easily created using surface modeling and then the surface model can be converted into the
solid model. It becomes easy for a person to learn surface modeling if he is familiar with solid
modeling feature creation tools.

CREATING SURFACES IN Pro/ENGINEER WILDFIRE 2.0
In Pro/ENGINEER Wildfire 2.0, a sketch can be toggled between a solid model and a surface
model. The two tool buttons that are used to toggle between the solid feature and a surface
feature are available on dashboards.

Creating an Extruded Surface
To create an extruded surface, choose the Extrude Tool button from the Base Features
toolbar. The Extrude dashboard is displayed as shown in Figure 13-1.

In this dashboard, the Extrude as solid button is selected by default. Select the
Extrude as surface button to extrude the sketch and create a surface model. All the
attributes that are related to a solid model and that were discussed in Chapter 3 are same

for a surface model also. Some examples of these attributes are sketch plane, both-side or
one-side extrusion, depth of extrusion, and so on.

A surface model can be extruded with capped ends or with open ends. Figure 13-2 shows the
open end surface model and Figure 13-3 shows the capped end surface model. Remember
that to create the capped end surface model, the sketch should be a closed loop. Otherwise,
a surface can be created with the open sketch.

To create a surface with capped ends, select the Capped Ends check box in the Options slide
up panel.

Figure 13-1  The Extrude dashboard
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Figure 13-3  Surface with capped endsFigure 13-2  Surface with open ends

Creating a Revolved Surface
To create a revolved surface, choose the Revolve Tool button from the Base Features toolbar.
The Revolve dashboard is displayed as shown in Figure 13-4. This feature creation tool works in
the same way as in the case of solid modeling.

The Revolve as solid button is selected by default; choose the Revolve as surface
button to create a revolve surface. You can create a revolved capped end surface or an
open end surface. The Capped End check box in the Options slide-up panel is

available only when the sketch is closed and the angle of revolution is less than
360-degrees. Figure 13-5 shows the open end revolve surface and Figure 13-6 shows the capped
end revolve surface.

Figure 13-4  The Revolve dashboard

Figure 13-6  Revolved surface with capped endsFigure 13-5  Revolved surface with open ends
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Creating a Sweep Surface
To create a sweep surface feature, choose Insert > Sweep > Surface from the menu bar. The
SWEEP TRAJ menu is displayed. The method to create a surface sweep feature is the same as
that to create a solid sweep feature. To create a solid sweep feature, refer to Chapter 7. The
additional option of capping the ends that were available in the Extrude and Revolve options is
also available in the Sweep option.

Figures 13-7 and 13-8 show the sweep surfaces with the open and closed ends respectively.

Creating a Blended Surface
To create a surface blend, choose Insert > Blend > Surface from the menu bar. The BLEND
OPTS menu is displayed. The method to create a blended surface is the same as that to create a
solid blend. To create a solid blend feature, refer to Chapter 7. Blended surfaces can be with
open ends or capped ends. Figure 13-9 shows the blended surface with open ends and Figure 13-10
shows the blended surface with capped ends.

Figure 13-8  Sweep surface with capped ends created
using a closed sketch

Figure 13-7  Sweep surface with open ends
created using a closed sketch

Figure 13-10  Blended surface with capped endsFigure 13-9  Blended surface with open ends
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Tip: If you want to create a surface blend with capped end, you need to create a closed
sketch. Pro/ENGINEER does not accept an open sketch for a capped end blend surface.

To create a surface blend with capped ends and keeping the sketch open can also be
done. For this purpose, select the Open Ends option and then draw an open sketch.
Give the blend depth and create the blended surface. Now, redefine the surface feature
and modify the open ends attribute to capped ends. Choose OK from the SURFACE
dialog box. The blended surface with the capped ends is created. This is also true with
other features like extrude, revolve, sweep, and so on.

Creating a Swept Blend Surface
To create a swept blend surface, choose Insert > Swept Blend > Surface from the menu bar.
The BLEND OPTS menu is displayed. The method to create a swept blend surface is the same
that to create a solid swept blend feature. To create a solid swept blend feature, refer to  Chapter 8.
Figure 13-11 shows the swept blend with open ends and Figure 13-12 shows the swept blend with
capped ends.

Creating a Helical Sweep Surface
To create a surface helical sweep, choose Insert > Helical Sweep > Surface from the menu bar.
The Surface dialog box and the ATTRIBUTES menu is displayed. The method to create a
helical sweep surface feature is the same as that to create a solid helical sweep feature. For more
information on creating solid helical sweep features, refer to Chapter 8. Figure 13-13 shows the
helical sweep surface with open ends and Figure 13-14 shows the helical sweep surface with
capped ends.

Creating a Surface by Blending the Boundaries
To create a surface by blending the boundaries, datum curves, or points, choose the
Boundary Blend Tool button from the Base Features toolbar. The Boundary Blend
dashboard is displayed as shown in Figure 13-15 and you are prompted to select

Figure 13-12  Swept blend surface with capped endsFigure 13-11  Swept blend surface with open
ends
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Figure 13-14  Helical sweep feature with capped
ends created using the closed sketch

Figure 13-13  Helical sweep surface with open
ends created using an open sketch

two or more curve chains to define a blended surface. The use of this dashboard are discussed
next.

Curves tab
When you choose the Curves tab, the slide-up panel is displayed. Choose a curve from the
graphics window; the curve is highlighted in red as shown in Figure 13-16. At the two ends of
the curve, T=0 is displayed, an arrow is attached to the curve. When you modify the value of T,
which is by default 0, to some higher value then the curve is extended from that end. Press
CTRL+left mouse button to select the second curve; the second curve also gets highlighted.
Both the selected curves are numbered as per the sequence of selection. The surface is created as
shown in Figure 13-17.

Figure 13-15  The Boundary Blend dashboard

Figure 13-17  Boundary blend surfaceFigure 13-16  Curves selected to blend
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Figure 13-18  Curves slide-up panel

The collector present below the Curves tab shows 2 Chains. This collector represents the Curves
tab and the number of curves selected in the first direction are displayed in this collector.

Now, invoke the Curves slide-up panel and select 2 Chain from the First direction collector;
the slide-up panel is displayed as shown in Figure 13-18. In the slide-up panel, the Move up
and Move down buttons are available, which can change the order of selection of the curves.
The Closed blend check box is used to close the surfaces.

Figure 13-19 shows the surface created after selecting the three curves and Figure 13-20 shows
the surface that is closed by selecting the Closed blend check box.

The Second direction collector in the Curves slide up panel is used to select curves in the
second direction. The second direction curves are usually drawn in a direction other than that
of the first direction. The Figure 13-21 shows the first and second direction curves and
Figure 13-22 shows the surface created after selecting the curves shown in Figure 13-21.

Tip: To delete the curves from the collector, right-click the collector and choose the
Remove all option from the shortcut menu that is displayed.

Figure 13-20  Surface created after closing itFigure 13-19  Surface created after selecting the
curves
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Creating a Surface Using Variable Section Sweep
To create a surface by variable section sweep, choose Insert > Variable Section Sweep from the
menu bar. The Variable Section Sweep dashboard is displayed. To learn more about Variable
Section Sweep, refer to Chapter 8. The procedure to create a variable section sweep feature or
surface is the same as was discussed in Chapter 8.

Figure 13-23 shows the trajectories and section that are used to create the variable section
sweep surface. You have an option to keep the ends open or capped. This option is available
in the Options slide-up panel.

Figure 13-23  Variable section sweep surface with open ends

Figure 13-22  Surface created by selecting the curves
in two directions

Figure 13-21  Datum curves
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Figure 13-24  Style environment

CREATING SURFACES USING STYLE ENVIRONMENT OF
Pro/ENGINEER WILDFIRE 2.0
Style is an environment available in Pro/ENGINEER that is used to draw free style curves and
create surfaces by joining them. The surfaces created using the Style environment are called
Super features. This is because these features can contain any number of curves or surfaces.
The Style surfaces can be joined with the Pro/ENGINEER surfaces. They can have the
parent-child relationship among themselves and as well as with Pro/ENGINEER features.

To enter the Style environment, choose the Style Tool available in the Base Features
toolbar or choose Insert > Style from the menu bar. Figure 13-24 shows the appearance
of the Style environment.

Style Tools Toolbar
Figure 13-25 shows the Style Tools toolbar available in the Style environment. The tools
available in this toolbar are discussed next.

Select Button
This button is used to select the surfaces, curves, planes, and so on in the Style
environment. If you are in middle of a feature creation tool you can choose the Select
button to exit that tool.
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Figure 13-25  Style Tools toolbar

Set the active datum plane Button
This button is used to select the datum plane on which the drawing or the editing
operation needs to be performed. The datum plane that you select is highlighted by a
mesh.

Create Internal Datum Plane Button
This button is chosen by selecting the black arrow on the right of the Set the active
datum plane button. When you select the arrow, the flyout is displayed. Choose the
Create Internal Datum Plane button to create an internal datum plane in the Style

environment. When you choose this button the DATUM PLANE dialog box is displayed. This
dialog box is used to create a datum plane in a similar procedure that was discussed in Chapter 4.
The datum planes are named as DTM1, DTM2, and so on.

It should be noted that the datum planes created using this button are displayed in the graphics
window only when you are in the Style environment. Once you exit the Style environment, the
datum plane becomes invisible. Any feature created in the Style environment is displayed in the
Model Tree as a Style feature.

Create Curves Button
This button is used to draw curves. When you choose this button, the Curve dashboard
is displayed as shown in Figure 13-26.

The options in this dashboard are discussed next.

Figure 13-26  The Curve dashboard
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Free Radio Button
When the Curve dashboard is displayed, the Free radio button is selected by default. The
prompt in the Message Area reads “Click to define points for the curve (SHIFT to snap)”.
To create curve, click on the screen. A yellow point is displayed at the location where you
clicked. Now, again click to define the second point of the curve. The two points are
joined. When you click to define the location of the third point, you will notice that the
curve that you are drawing is defined by a spline. After defining the points, press the
middle mouse button to create the curve. While specifying a point if you press the SHIFT
key then the point is snapped to the entity already present on the screen.

Remember that the curve drawn using the Free option is created on the active datum plane.
To draw a 3D curve you need to snap the point on the existing entity. You can also draw a 3D
curve by choosing the Toggle showing all views and one view full-size button from the
Style toolbar.  When you choose this button, the display is turned into four windows. In
Pro/ENGINEER, this type of display is called a 4-view display mode. The four views show
the top, default, right-side, and front views. You can select a point in one window and then
select the second point in the other window. By specifying points in different windows, the
3D curve can be drawn. To switch back to the single window display mode, choose the
Toggle showing all views and one view full-size button.

Planar Radio Button
This radio button when selected allows you to create the curve on the datum plane that is
highlighted by the mesh. This datum plane is called the active plane. The active plane can
be selected before invoking the Curve dashboard by choosing the Set the active datum
plane button.

COS Radio Button
This radio button is used to draw curves on surfaces. The points that you define on a surface
are constrained to that surface. When you click to define the location of the first point of the
curve, the point is placed. Now, this surface is selected and the points placed hereafter
should lie on the same surface. If you click outside this surface then the point is not placed
on the surface. After the curve is drawn, press the middle mouse button. The red curve is
converted to a white curve indicating that the curve is completed. The curve drawn on the
surface is the child of the surface.

Control Points Check Box
While drawing the curve, if this check box is selected, then while editing the curve the
control points are displayed.

Tip: To undo the last operation, choose the Undo button from the Style toolbar. The
shortcut for undo is CTRL+Z.

Tip: Using the Planar option, you can project a point of an existing entity on the
active datum plane. This can be done by selecting the point on the entity using the
SHIFT key. The selected point is projected on the active datum plane.
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Edit curves Button
This button is used to edit the curves that are created as style features. When you choose
this button the Edit curve dashboard is displayed and you are prompted to select a
curve. When you select a curve to edit, the Edit curve dashboard appears as shown in

Figure 13-27.

The options in the Edit curve dashboard are discussed next.

Curve collector
When you select a curve to edit, the id of the curve is displayed in this collector.

Free radio button
If the curve that is selected for editing was drawn using the Free option, then this radio
button is selected by default.

Planar radio button
If the curve that is selected for editing was drawn using the Planar option, then this
radio button is selected by default.

COS radio button
If the curve that is selected for editing was drawn using the COS option, then this radio
button is selected by default.

Proportional Update check box
If the curve that is selected for editing was drawn using the Proportional Update option,
then the curve is edited proportionately with the points.

Control Points check box
If the curve that is selected for editing was drawn using the Control Points option, then
the control points are displayed on the curve. Using these control points you can modify
the shape of the curve.

Shortcut menu options
When the control point, next to the endpoint of the curve is selected, the tangent vector of
the curve is highlighted in yellow color. Right-click the yellow vector to display the shortcut
menu, as shown in Figure 13-28.

Figure 13-27  The Edit curve dashboard

Tip: Using the Free option, you can draw a curve on a surface. To draw a curve on
a surface, press SHIFT to select a point on the surface. The surface is highlighted as
you select a point on it and then the point is placed on the surface. This method of
selecting points on a surface can be used to draw curves that join points on two
separate surfaces.



Surface Modeling        13-13

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n

Figure 13-28  Shortcut menu

Figure 13-30  Curve joining the base surface
tangentially

Figure 13-29  Curve joining the two surfaces

By default, a curve has a natural contact with the adjacent surface. This is evident from the
check mark on the left of the Natural option in the shortcut menu. Figure 13-29 shows the
curve that is connected to the adjacent surface using the Natural option. The curve is drawn
using the Free option. The point on the cylindrical surface is selected by using SHIFT+left
mouse button and similarly another point is selected on the surface at the base. Figure 13-30
shows the curve whose contact type is changed to the Surface Tangent option by choosing
it from the shortcut menu.

Creating COS’s by projecting curves onto surfaces Button
Using this button, a curve created in the Style environment can be projected onto the
selected surface.

To create COS’s, choose the Create COS’s by projecting curves onto surfaces button from the
Style Tools toolbar. You are prompted to select the surface on which you need to drop the curve.
Select the surface and press the middle mouse button. You are prompted to select the curve that
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you need to drop. After selecting the curve, press the middle mouse button. Now, you are
prompted to select the plane normal to which the curve will drop. Select the plane normal to
which the curve will be projected and exit the dashboard.

Create surfaces from boundary curves Button
This button is used to create a surface among a closed boundary of curves. When you
choose this button the Boundary Surfaces dashboard is displayed and you are prompted
to select three or four boundary curves to define a surface. Select the four curves as

shown in Figure 13-31. After selecting the four curves, press the middle mouse button. The
surface is created as shown in Figure 13-32.

Connect surfaces Button
When you choose this button, the Connect surfaces dashboard is displayed and you are
prompted to select the two surfaces. The Style surface can be connected to the
Pro/ENGINEER surface. When you select the two surfaces shown in Figure 13-33 and

press the middle mouse button, the connections are automatically applied to the two surfaces.
These connections may be of two types: curvature connection represented by a dashed line
and the tangent connection represented by an arrow. If the tangent connection is applied
then the arrow is displayed and if the curvature connection is applied then a dashed line is
displayed on the surfaces. Figure 13-34 shows the two surfaces where the tangent connection
is applied and is not applied.

Figure 13-32  Surface created using the curvesFigure 13-31  Four curves
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Figure 13-37  Surface connected at the top by
tangent connection

Figure 13-36  Surface connected at the top by
curvature connection

Figure 13-34  Arrow and the dashed lineFigure 13-33  The two surfaces

Figure 13-35  The Connect surfaces dashboard

After surfaces are selected, the  Connect surfaces dashboard is displayed as shown in Figure 13-35.
To apply the connection, click on any one end of the dashed line. The dashed line is converted
to an arrow, indicating that the two surfaces are connected. To remove the connection, use
SHIFT+left click on the arrow.

Figure 13-36 shows the style surface when the type connection is curvature and Figure 13-37
shows the surface when it is connected tangentially.
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Note
The Icon Length dimension box on the Connect surfaces dashboard is used to increase the
length of the arrow and the dashed line.

To delete a curve, select the curve and when it turns red in color, press the DELETE key.

Trim selected quilts Button
This button is used to trim a surface. When you choose this button, the Trim dashboard
is displayed and you are prompted to select the surface(s) to trim. Select the surface so
that it turns pink in color and then press the middle mouse button. Now, you are

prompted to select the curve that will be used to trim the surface. Select the curve and press the
middle mouse button. The selected surface is highlighted in two portions. Select the portion to
delete. Choose the green check mark to exit the trim tool.

Figure 13-38 shows the surface and the curve that are selected for trimming. This figure also
shows the surface divided into two portions. The portion defined by the curve is selected to
delete. Figure 13-39 shows the surface after trimming.

Note
After completing the Style feature creation, choose the Exit the current Style feature button to
exit the Style environment.

SURFACE EDITING TOOLS IN Pro/ENGINEER WILDFIRE
The surface editing tools help in decreasing the modeling time. They also help in creating
complex surface models. The surface editing tools that you will be learning in the next section
are as follows:

1. Mirror 5.   Intersect 9.   Vertex Round
2. Merge 6.   Offset
3. Trim 7.   Thicken
4. Fill 8.   Solidify

Figure 13-39  Surface after trimmingFigure 13-38  Surface is divided into two portions
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Mirroring the Surfaces
The Mirror Tool is used to mirror the surface about a plane. This tool is available in the
Edit Features toolbar only when a surface is selected. When you choose this button, the
Mirror dashboard is displayed as shown in Figure 13-40.

Using the References tab you can choose the mirroring plane. The Copy as Dependent check
box is selected by default in the Options tab. The makes sure that the Parent-child relationship
is maintained between the mirrored and the original surface. Figure 13-41 shows the mirror
plane about which the surface is mirrored as shown in Figure 13-42.

Merging the Surfaces
The Merge Tool is used to merge the two surfaces and make them a single surface. A
surface is also known as a Quilt. To convert a surface to a solid, it is necessary that the
surfaces are merged. While merging the surfaces, this tool also trims the surfaces. This

tool is available in the Edit Features toolbar only when the two surfaces to be merged are
selected. When you choose the Merge Tool button, the Merge dashboard is displayed as shown
in Figure 13-43.

The following steps explain the procedure to merge the surfaces shown in Figure 13-44.

1. Select the Quilts option from the Filter drop-down list. Select the two surfaces and when the
surfaces turn pink in color, choose the Merge Tool; the Merge dashboard is displayed. In

Figure 13-40  The Mirror dashboard

Figure 13-42  Surfaces after mirroring and
keeping the original surface

Figure 13-41  Mirror plane and the surface to
be mirrored

Figure 13-43  The Merge dashboard
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Figure 13-46  Merged surface

this figure, the part of the surfaces that will be retained after the two surfaces are merged is
highlighted by yellow dots on it. The yellow arrows points to show the side of the surface to
keep. The direction of yellow arrow can be toggled by using the Change side of first quilt to
keep and the Change side of second quilt to keep buttons available on the Merge dashboard.

2. Choose the Change side of first quilt to keep button and then choose the Change side of
second quilt to keep button. Notice that the outer side of the surfaces are highlighted with
yellow dots as shown in Figure 13-45.

3. Choose the Preview button and then exit the dashboard. The resulting merged surface is
shown in Figure 13-46. This merged surface is a single surface and now can be converted to
a solid feature.

The Reference tab of the Merge dashboard shows the selected quilts. In the Options tab, you
can select between Intersect and Join options. The Join option can be used when the edge of
one quilt lies on the other quilt.

Figure 13-45  Arrows showing the part of the surface
to retain

Figure 13-44  Two surfaces to merge
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Trimming the Surfaces
As the name suggests, the Trim Tool is used to trim the selected surfaces using a
trimming object. You need to select the surface that you need to trim and then choose
the Trim Tool button from the Edit Features toolbar. The Trim dashboard is displayed,

as shown in Figure 13-47. You are prompted to select the trimming object. This trimming object
can be a curve, plane, edge, or a surface.

The part of the surface that is to be retained is highlighted with yellow dots. A yellow arrow
points in the direction of the surface to be retained after trimming. You can choose the Flip
between one side, other side, or both sides of trimmed surface to keep button to toggle
the direction of yellow arrow. By default, the trimming object is deleted after the surfaces are
trimmed. If you need to keep the trimming object, select the Keep trimming surface check box
from the Options slide-up panel.

Figure 13-48 shows the surface selected as the trimming object, the trimming surface, and the
yellow arrow. From this figure it is evident that the arrow is pointing toward the right; therefore
the right portion of the surface will be retained after trimming. Figure 13-49 shows the surface
obtained after trimming.

Creating the Fill Surfaces
The Fill option is used to create a planar surface by sketching its boundaries. When you choose
this option from the Edit menu in the menu bar, the Fill dashboard is displayed as shown in
Figure 13-50.

Figure 13-47  the Trim dashboard

Figure 13-49  Surface obtained after trimmingFigure 13-48  Trimming surfaces

Figure 13-50  The Fill dashboard
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Figure 13-53  The Intersect dashboard

Figure 13-52  Fill surfaceFigure 13-51  The sketch plane for creating a fill
surface

From the References slide-up panel choose the Define button to select the sketching plane and
drawing the sketch. Figure 13-51 shows the sketch plane and Figure 13-52 shows the surface that
is created using the Fill option.

Creating the Intersect Curves
The Intersect option is used to create a curve at the intersection of two surfaces. The intersect
curve can then be used for various purposes. The Intersect option is available in the Edit menu
only when you have selected a surface. When you choose this option from the Edit menu, the
Intersect dashboard is displayed as shown in Figure 13-53.

When you select the second surface, the intersecting curve is created as shown in Figure 13-54.
Make sure to select the second surface while holding the CTRL key down. The curve created can

Figure 13-54  Surfaces selected to create the intersecting curve
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be copied, moved, and so on. One of the uses of the intersect curve is shown in Figures 13-55
and 13-56.

In Figure 13-55, the intersecting curve is copied at a distance of 150. To create the surface shown
in Figure 13-56, the Boundary Blend Tool is used. To create the boundary blend, the
intersecting curve is selected and then the curve edge of the surface is selected. Both the curves
are blended and the tangency is increased by dragging the handles.

Creating the Offset Surfaces
A surface can be copied to an offset distance. To offset a surface, select the surface to offset and
choose Edit > Offset from the menu bar. The Offset dashboard is displayed, as shown in
Figure 13-57. The Offset option is available only when you have selected a surface to offset.

In Pro/ENGINEER, there are three methods to offset a surface. These methods are as follows:

1. Create the offset of the whole surface, using the Standard option.
2. Sketch a section and offset the area inside the section with the draft, using the With Draft

option.
3. Sketch a section and offset the area inside or outside the section, using the Expand option.

In the Offset dashboard, first you need to specify the type of offset surface you need to create.
The types of offset that can be created in Pro/ENGINEER Wildfire 2.0 are as follows:

1. Standard Offset Feature
2. With Draft Feature
3. Expand Feature

Figure 13-56  Boundary blend created using the
intersecting curve

Figure 13-55  Copied curve

Figure 13-57  The Offset dashboard
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Figure 13-58  Original and the offset surfaces

Standard Offset Feature
The Standard Offset Feature button is present at the lower-left corner of the Offset dashboard
and is selected by default. You can enter the offset value in the dimension box.

Using this option you can offset the surface as a whole. From the drop-down list present in the
Options slide-up panel, you can offset a surface normal to the surface, allow Pro/ENGINEER to
automatically fit the surface, or control the direction of the offset in the x, y and z-axes. If you
select the Control Fit option, you need to select a coordinate system and specify the direction to
offset. From the Options slide-up panel you can select the Create side surface check box to join
the offseted surface with the side surfaces. Figure 13-58 shows the original surface and the offset
surface.

With Draft Feature
The With Draft Feature button can be selected form the list of buttons that appear by selecting
the black arrow present on the right of Standard Offset Feature button. Using this option you
can sketch the section and then give a draft angle to side surfaces. Choose the Define button
from the from the References slide-up panel to define a sketch plane and create the sketch.
Figure 13-59 shows the draft offset surface with the Straight radio button selected from the
Options slide-up panel. The section that was drawn on the sketch plane was circular.
Similarly, Figure 13-60 shows the draft offset surface with the Tangent radio button selected from
the Options slide-up panel.

Figure 13-60  Draft offset surface with
tangent profile

Figure 13-59  Draft offset surface with straight
profile
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Figure 13-63  The Thicken dashboard

Expand Offset Feature
The Expand Offset Feature button can be selected form the list of buttons that appear by
selecting the black arrow present on the right of Standard Offset Feature button. Using this
option you can sketch the section and then choose to offset the inside of the sketch or the
outside of the sketch. For this purpose you need to choose the Flip the material sides of sketch
button from the dashboard. Figure 13-61 shows the offset surface when the inside of the sketch
is selected to offset. The section that was drawn on the sketch plane was rectangular. Choose the
Define button from the Options slide-panel to define the sketch plane and create the sketch.
Figure 13-62 shows the draft offset surface when the outside of the sketch is selected to offset.

Giving Thickness to a Surface
To add thickness to a quilt or to a surface, select the quilt and choose the Thicken option from
the Edit menu. The Thicken dashboard is displayed, as shown in Figure 13-63.

Drag the handle to set the thickness of the quilt or enter the thickness value in the dimension
box. You can even remove material from the quilt by choosing the Removes material from
inside thickened quilt button from the dashboard.

Using the drop-down list present in the Options slide-up panel, you can give thickness to the
quilt normal to the surface, allow Pro/ENGINEER to automatically scale the surface along axes,
or scale and fit the original surface with respect to the coordinate system. If you select the
Control Fit option, you need to select a coordinate system and specify the direction to scale.

Figures 13-64 and 13-65 show the surfaces after adding thickness by controlling the thickness
using the Normal to surface option and the Automatic fit option respectively.

Figure 13-62  Outside of the sketch selected to offsetFigure 13-61  Inside of the sketch selected to
offset
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Converting a Surface to a Solid
You can convert a closed surface into a solid by choosing Edit > Solidify from the menu bar.
This option is available only when a closed surface is selected. This option fills the hollow
surface with material.

Creating Round at the Vertex of a Surface
The vertices of a surface or quilt can be rounded using the
Vertex Round option. Choose Insert > Advanced >
Vertex Round from the menu bar. The SURFACE TRIM:
Vertex Round dialog box is displayed as shown in
Figure 13-66. You are prompted to select the datum quilt to
intersect. Select the surface; now you are prompted to select
the corner vertex(s) to be rounded. Select the first vertex and
then press the CTRL key to select the other vertex as shown
in Figure 13-67. After selecting the vertices, press the middle
mouse button. The Message Input Window is displayed. Type
the radius of round and press ENTER. Choose the OK
button from the SURFACE TRIM: Vertex Round dialog box.
The vertices are rounded as shown in Figure 13-68.

Figure 13-65  Thickening the surface using the Automatic fit option

Figure 13-66  The SURFACE
TRIM: Vertex Round  dialog box

Figure 13-64  Thickening the surface using the Normal to surface option
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Figure 13-68  Vertices after creating roundFigure 13-67  Vertices to round

TUTORIALS

In this tutorial you will create the surface model shown in Figure 13-69. The orthographic views
of the surface model are shown in Figure 13-70.      (Expected time: 45 min)

The following steps are required to complete this tutorial:

a. Examine the model and determine the number of features in it, refer to Figure 13-70.
b. Create the base feature, which is a blend surface, refer to Figures 13-71 through 13-73.
c. Create the second feature, which is a blend feature, refer to Figures 13-74 and 13-75.
d. The third feature is a mirror feature that will be created by mirroring the second feature

about a plane passing from the center, refer to Figure 13-76.

Tutorial 1

Figure 13-69  Isometric view of the surface model
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Figure 13-70  Top view, front view, and the right-side view of the surface model

e. Create the fourth feature which is also a blend feature, refer to Figures 13-77 and 13-78.
f. Next, individually the surfaces will be selected to merge, refer to Figures 13-79 and 13-80.
g. Remaining features are the fill features that will create surfaces on the blend features, refer to

Figures 13-81 through 13-83.
h. Create rounds on the edges, refer to Figure 13-84.

After understanding the procedure for creating the model, you are now ready to create it.
When the Pro/ENGINEER session is started, the first task is to set the working directory.
Since this is the first tutorial of this chapter, you need to create a folder named c13 if it does
not exist and set it as the working directory.

Starting a New Object File
1. Start a new part file and name it as c13tut1.

The three default datum planes are displayed in the graphics window. The Model Tree is
also displayed in the graphics window. Close the Model Tree by clicking on the sash
present on the right edge of the Model Tree.

Creating the Base Feature
You will use the menu bar present on the top of the screen to invoke the Blend option. The
Blend option will be used to create the base feature.
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1. Choose Insert > Blend > Surface from the menu bar. The BLEND OPTS menu is displayed.

2. Choose Parallel > Regular Sec > Sketch Sec > Done from the BLEND OPTS  menu. The
SURFACE dialog box and the ATTRIBUTES menu is displayed.

3. Choose Straight > Open Ends > Done from the ATTRIBUTES menu. You are prompted
to select the sketch plane.

4. Select the RIGHT datum plane. The DIRECTION menu is displayed.

5. Choose Okay from the DIRECTION menu. The SKET VIEW menu is displayed.

6. Select the Top option and then choose the TOP datum plane. The References dialog
box is displayed and you enter the Sketcher environment.

7. Close the References dialog box and draw the arc and dimension it as shown in
Figure 13-71.

8. After drawing the first arc, press and hold down the right mouse button and choose the
Toggle Section option from the shortcut menu.

9. Draw the second arc and dimension it as shown in Figure 13-72.

10. After drawing the sketch, choose the Continue with the current section button to exit the
Sketcher environment. The DEPTH menu is displayed.

11. Choose Blind > Done from the DEPTH menu. The Message Input Window is displayed.

12. Enter a value of 150 and press ENTER.

13. Choose OK from the SURFACE dialog box. The base feature is created as shown in
Figure 13-73.

Figure 13-72  Sketch of the second arcFigure 13-71  Sketch of the first arc
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Creating the Second Feature
To create the second blend feature you need to create a datum plane that is at a distance of
150 from the FRONT datum plane that is passing through the center of the base feature.

1. Choose Insert > Blend > Surface from the menu bar.

2. Choose the Parallel > Regular Sec > Sketch Sec > Done from the BLEND OPTS  menu.

3. Choose Straight > Open Ends > Done from the ATTRIBUTES menu. You are prompted
to select the sketch plane.

4. Choose the Make Datum option to display the DATUM PLANE menu. Select the Offset
option and then select the FRONT datum plane.

5. Press the middle mouse button to confirm the selection. Now select the Enter Value option
from the OFFSET menu to display the Message Input Window and enter 150 in it.

6. Select the Done option from the DATUM PLANE menu and then select Okay from
DIRECTION menu.

7. Set the orientation of the sketch plane by selecting the TOP datum plane to be at the top
while sketching.

8. After you enter the Sketcher environment, close the References dialog box.

9. Sketch the first arc of radius 25, and then after toggling the sketch draw the second arc as
shown in Figure 13-74.

10. Exit the Sketcher environment; the DEPTH menu is displayed.

11. Choose Thru Until > Done from the DEPTH menu.

Figure 13-73  Trimetric view of the base feature
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Figure 13-75  Second featureFigure 13-74  Sketch of the second feature

12. Select the FRONT datum plane. Choose OK from the SURFACE dialog box. The blend
surface is extruded up to the selected datum plane as shown in Figure 13-75.

Creating the Mirror Copy of the Second Feature
The third blend feature is the same as the second blend feature. Therefore, a mirror copy of
the second feature will be used to create the third feature.

1. Select the second feature and then choose the Mirror Tool button. The Mirror
dashboard is displayed and you are prompted to select a plane to mirror about.

2. Select the FRONT datum plane and exit the Mirror dashboard by choosing the Build
Feature button. The mirror copy of the second feature is created as shown in Figure 13-76.

Creating the Fourth Blend Feature
The fourth blend feature will be created on the top of the base feature. To create the blend

Figure 13-76  Surface model after creating the third feature
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Figure 13-78  Model after creating the fourth
blend surface

Figure 13-77  Sketch of the fourth blend feature

feature, you will need to create a datum plane that is at a distance of 150 from the bottom of
the base feature.

1. Choose Insert > Blend > Surface from the menu bar.

2. Choose Parallel > Regular Sec > Sketch Sec > Done from the BLEND OPTS  menu.

3. Choose Straight > Capped Ends > Done from the ATTRIBUTES menu. You are prompted
to select the sketch plane.

4. Choose the Make Datum option to display the DATUM PLANE menu. Select the Offset
option and create a datum plane at a distance of 150 from the TOP datum plane.

5. Set the orientation of the sketch plane by selecting the RIGHT datum plane to be at the top
while sketching.

6. After you enter the Sketcher environment, close the References dialog box.

7. Sketch the first circle of diameter 50, dimension it. Toggle the sketch and then draw the
second circle of diameter 70 as shown in Figure 13-77.

8. Exit the Sketcher environment; the DEPTH menu is displayed.

9. Choose Thru Until > Done from the DEPTH menu.

10. Select the TOP datum plane. Choose OK from the SURFACE dialog box. The blend
surface is extruded up to the selected datum plane as shown in Figure 13-78.

Merging the Surfaces to Create a Quilt
To create round on the edges it is necessary to create a common edge where the two surfaces
are joining. For this purpose, the surfaces are merged.
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Note
It is easier to select the two surfaces for merging from the Model Tree. You should remember that
to select more than one surface you need to press the CTRL key. When you select the surfaces from
the Model Tree the boundary of the surface is highlighted in red color indicating that the surface
is selected. When you are selecting a surface directly from the graphics window, you need to select
the surface thrice. The third time when you select the surface, it turns pink in color.

You can also select the Quilt option from the Filter drop-down list to select the surfaces. The
Filter drop-down list is available in the status bar at the bottom right corner of the main
window.

1. Select the blend surface that is at the left and then select the blend surface at the middle.
When the two surfaces are highlighted, choose the Merge Tool. The Merge dashboard is
displayed and the two arrows shows the portion that will be retained after merging.

Note
The Merge Tool button is available only when the two surfaces are selected for merging.

2. Choose the Change side of first quilt to keep button from the dashboard. The direction of
yellow arrow changes.

3. Choose the Change side of second quilt to keep button from the dashboard. The direction
of yellow arrow changes. The portion of the surface that is now highlighted will be retained
after merging.

4. Exit the dashboard by selecting the Build Feature button. The model after merging the two
surfaces is shown in Figure 13-79.

Using the same procedure, merge the blend surface at the right with the blend surface at the
middle. After that, merge the top blend surface with the middle blend surface. Figure 13-80
shows the surface model after merging all the surfaces and forming a quilt.

Figure 13-79  Surface model after merging the two surfaces



13-32                Pro/ENGINEER Wildfire for Designers: F09/04

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n

Creating the Fill Surfaces
Four surfaces will be created to cap the ends of the blend surfaces. First, the left blend
surface will be capped using the Fill option.

1. Choose the Fill option from the Edit menu. The Fill dashboard is displayed.

2. From the References slide-up panel choose the Define button. The Sketch dialog box is
displayed and you are prompted to select the sketch plane.

3. Choose the Datum Plane Tool button from the Datum toolbar. To choose the button you
need to move the Sketch dialog box because the dialog box overlaps the tool button.

4. Select the two vertices of the left blend surface. To select the second vertex hold down the
CTRL key. Then holding down the CTRL key select the FRONT datum plane.

5. Select FRONT from the DATUM PLANE dialog box. The drop-down list appears in the
row where you clicked. From the drop-down list, select the Parallel option. Choose the OK
button from the DATUM PLANE dialog box.

The datum plane is created and a yellow arrow points in the direction of viewing the sketch.

6. Choose the Sketch button to close the Sketch dialog box. Close the References dialog box
and enter the Sketcher environment.

7. Choose the Create an entity from an edge button and select the smaller semicircular edge
of the blend surface. Complete the sketch as shown in Figure 13-81.

Figure 13-80  Surface model after merging the two surfaces
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8. Exit the Sketcher environment and then exit the Fill dashboard by choosing the Build
Feature button. The Fill surface is created as shown in Figure 13-82.

Similarly, create the fill surfaces to cap the ends of the middle surface blend feature. Mirror
the fill surface to create the fill surface at the right blend surface. Figure 13-83 shows the
surface model after capping all the ends of the blend surfaces.

Merging the Fill Surfaces
The fill surfaces that you have created should be merged with the other surfaces in order to
create round on their edges.

1. Hold down the CTRL key to select the fill surface that is at the left and then the blend
surface at the middle. When the two surfaces turn pink in color, choose the Merge Tool to
display the Merge dashboard.

2. Exit the dashboard by selecting the Build Feature button.

Figure 13-82  Surface after creating the fill
surface

Figure 13-81  Sketch for the fill surface

Figure 13-83  Surface model after creating the fill surfaces
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Using the same procedure, merge the remaining fill surfaces individually with the blend
surface at the middle. To check whether all the surfaces are merged, select the surface model
thrice. If the whole surface model is highlighted in pink color then all the surfaces are
merged and form a quilt.

Creating Rounds
When all the surfaces are merged then the edges are obtained at the intersection of two
surfaces. These edges can be easily rounded. In the given surface model, note that there are
rounds that are having two different radius values. Therefore, you need to create two sets to
define two values of rounds.

1. Choose the Round Tool from the Engineering Features toolbar.

2. Select the edges that have a radius value of 12. Remember that to select more than one edge,
you need to hold down the CTRL key.

3. After creating the rounds of radii 12, select the Sets tab to display the slide-up panel.

4. Click on New set, you have added a set that is named Set2.

5. Select the two edges that are having radii of 22. After creating the rounds of radii 22, exit
the Round dashboard.

The surface model after creating the rounds is as shown in Figure 13-84.

5. Choose the Save the active object button from the File toolbar and save the model.

Figure 13-84  Surface model after creating rounds
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In this tutorial you will create the surface model shown in Figure 13-92. The front and the
right-side views of the surface model are shown in Figure 13-93.    (Expected time: 45 min)

The following steps are required to complete this tutorial:

a. First, examine the model and determine the number of features in it, refer to Figure 13-86.
b. Create the base feature, which is an extruded surface with open ends, refer to Figures 13-87

and 13-88.
c. Create the second feature, which is a blend feature created at an offset distance of 65 from

the RIGHT datum plane, refer to Figures 13-89 and 13-90.

Tutorial 2

Figure 13-86  Front view and the right-side view of the surface model

Figure 13-85  Isometric view of the surface model
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d. The third feature is a mirror copy of the second feature, refer to Figure 13-91.
e. The fourth feature is the cylindrical surface, refer to Figures 13-92 and 13-93.
f. Create the two fill surfaces that will cap the ends of the base surface, refer to Figures 13-94

through 13-96.
g. Merge all surfaces by selecting them individually, refer to Figures 13-97 through 13-99.
h. Create the round features, refer to Figures 13-100 through 13-102.

After understanding the procedure for creating the surface model, you are now ready to
create it. The working directory was selected in the first tutorial.

Creating the Base Feature
The base feature is a surface that is between the two blend surfaces. The base feature is
created on the RIGHT datum plane.

1. Choose the Extrude Tool button from the Base Features toolbar.

2. Select the Extrude as surface button from the Extrude dashboard. Select the
RIGHT datum plane as the sketch plane.

3. Select the TOP datum plane from the graphics window and then select the Top option from
the Orientation drop-down list.

4. Choose the Sketch button to enter the Sketcher environment.

5. Once you enter the Sketcher environment, create the sketch of the base feature and apply
dimensions as shown in Figure 13-87.

6. After the sketch is complete, choose the Continue with the current section button to exit
the Sketcher environment.

The Extrude dashboard reappears below the graphics window. The Extrude from sketch
plane by specified depth value button is selected by default.

7. Enter a depth of 240 in the dimension box present in the Extrude dashboard. Choose the
Build feature button from the Extrude dashboard.

The base feature is completed and the default trimetric view is shown in Figure 13-88.

Creating the Blend Feature
The second feature is the blend surface and it will be created on the datum plane that is at
an offset distance of 65 from the FRONT datum plane.

1. Choose Insert > Blend > Surface from the menu bar.

2. Choose Parallel > Regular Sec > Sketch Sec > Done from the BLEND OPTS  menu.
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3. Choose Straight > Open Ends > Done from the ATTRIBUTES menu. You are prompted
to select the sketch plane.

4. Choose the Make Datum option to display the DATUM PLANE menu. Select the Offset
option and create a datum plane at a distance of 65 from the FRONT datum plane.

5. Set the orientation of the sketch plane by selecting the TOP datum plane to be at the top
while sketching.

6. After you enter the Sketcher environment, close the References dialog box.

7. Sketch the first arc of diameter 35, dimension it, and then draw the second arc of diameter
55 as shown in Figure 13-89.

8. Exit the Sketcher environment; the DEPTH menu is displayed.

9. Choose Thru Until > Done from the DEPTH menu.

10. Select the FRONT datum plane. Choose OK from the SURFACE dialog box. The blend
surface is extruded up to the selected datum plane as shown in Figure 13-90.

Figure 13-90  Blend surfaceFigure 13-89  Sketch of the blend surface

Figure 13-88  Base surface with open endsFigure 13-87  Sketch of the base surface



13-38                Pro/ENGINEER Wildfire for Designers: F09/04

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n

Mirroring the Blend Surface
The blend surface that you created earlier should be mirrored about the FRONT datum
plane.

1. Select the blend surface and then choose the Mirror Tool button from the Edit Features
toolbar. The Mirror dashboard is displayed.

2. Select the FRONT datum plane and exit the dashboard. The blend surface is mirrored
about the selected datum plane as shown in Figure 13-91.

Creating the Cylindrical Surface
The cylindrical surface will be created on the TOP datum plane.

1. Choose the Extrude Tool button from the Base Features toolbar.

2. From the Extrude dashboard, select the Extrude as surface button.

3. Select the TOP datum plane as the sketch plane.

4. After entering the Sketcher environment, draw the circle and dimension it as shown in
Figure 13-92.

5. Exit the Sketcher environment and extrude the sketch to some appropriate depth, refer to
Figure 13-93.

The model after creating the surface extrusion is shown in Figure 13-93.

Creating the Fill Surface
The fill surface will be created to cap the ends of the base feature.

1. Choose Edit > Fill from the menu bar. The Fill dashboard is displayed.

Figure 13-91  Model after creating the mirror copy of the blend surface
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2. Choose the Define button from the References slide-up panel. The Sketch dialog box is
displayed and you are prompted to select the sketch plane.

3. Select the RIGHT datum plane as the sketch plane. Choose the Flip button.

4. Select the Top option from the Orientation drop-down list and select the TOP datum
plane. Choose the Sketch button to enter the Sketcher environment.

5. Choose the Create an entity from an edge button and select the edges of the base
feature. Complete the sketch as shown in Figure 13-94.

6. Exit the Sketcher environment and then exit the Fill dashboard by choosing the Build
Feature button. The Fill surface is created as shown in Figure 13-95.

7. Mirror the fill surface about the datum plane that you need to create on-the-fly. This datum
plane will be at an offset distance of 120 from the RIGHT datum plane.

Figure 13-93  Cylindrical surfaceFigure 13-92  Sketch of the cylindrical surface

Figure 13-95  Model after creating the fill surfaceFigure 13-94  Sketch of the fill surface
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After creating the mirror copy of the fill surface, the other end of the base feature is also
capped as shown in Figure 13-96.

Merging the Blend Surface with the Cylindrical Surface
The blend surface that was the second feature and the cylindrical surface will be merged to
get the required circular slot.

1. Select the cylindrical surface and then select the blend surface.

2. Choose the Merge Tool from the Edit Features toolbar. The Merge dashboard is displayed
and the surface that will be retained after merging is highlighted.

3. Choose the Change side of first quilt to keep button to change the direction of the yellow
arrow.

4. Exit the Merge dashboard by choosing the Build Feature button. The model after merging
the two surfaces is as shown in Figure 13-97.

Merging the Blend Surface and the Extruded Surface
The blend surface and the extruded surface will be merged to build a single surface.

1. Select the base feature and then select the second feature from the Model Tree.

2. Choose the Merge Tool from the Edit Features toolbar. The Merge dashboard is displayed
and the surface that will be retained after merging is highlighted.

3. Choose the Change side of first quilt to keep button to change the direction of the yellow
arrow and then choose the Change side of second quilt to keep button.

4. Exit the Merge dashboard by choosing the Build Feature button. The model after merging
the two surfaces is as shown in Figure 13-98.

Figure 13-97  Model after creating the mergeFigure 13-96  Model after creating the mirror
copy of the fill surface
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Figure 13-99  Model after merging the mirror
copy of the blend surface with the base surface

Figure 13-98  Model after merging the blend
surface with the base surface

5. Similarly, merge the mirrored feature and the base feature. The surface model after merging
the mirrored surfaces is as shown in Figure 13-99.

Merging the Fill Surfaces with the Base Surface
The fill surfaces that you have created should be merged with the base surface in order to
create a single quilt or a single surface. When the surfaces are merged, you will use the edge
formed by the merge feature to create rounds.

1. Select the fill surface and then select the base surface.

Note
It is easier to select surfaces from the Model Tree.

To merge two surfaces, it is necessary that they intersect.

2. Choose the Merge Tool from the Edit Features toolbar and then choose the Build Feature
button to merge both the surfaces.

3. Similarly, merge the mirror copy of the first fill surface with the base surface.

Creating Rounds
The rounds that you need to create are on the cylindrical slot, edges where the two blend
surfaces are merging, and on the edges of the base surface.

1. Choose the Round Tool from the Engineering Features toolbar. Select the edge of the
cylindrical slot, see Figure 13-100. The preview of the round is highlighted on the selected
edge.

2. Enter a value of 4 in the dimension box for the radius of the round.
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3. Click on New set in the Sets slide-up panel to add a second set named Set2.

4. Select the four edges that are having radii of 18. The two edges are the edges that are formed
by merging the two blend surfaces with the base surface and the two edges are the top
corners of the base surface, see Figure 13-100.

5. Choose the Build Feature button from the Round dashboard to create the rounds. The
surface model after creating the rounds is shown in Figure 13-101.

Creating a Full Round
A full round will be created by selecting the two surfaces. These surfaces are the front and
back faces of the base surface.

1. Choose the Round Tool from the Engineering Features toolbar.

2. Select the two faces, front and back, of the base surface.

3. Invoke the slide-up panel by selecting the Sets tab. After selecting the two surfaces, these
surfaces are displayed in the References collector. The Full Round button is selected by
default. Now, you need to select the driving surface.

4. Select the top face of the base surface. The preview of the round is highlighted on the
selected surfaces. Exit the Round dashboard by choosing the Build Feature button. The
round is created as shown in Figure 13-102.

5. Choose the Save the active object button from the File toolbar and save the model. Answer
the following questions and then compare your answers to the answers given at the end
of this chapter.

Figure 13-101  Round created on the merged edge of
the cylindrical slot, edge on the intersection of blend
surfaces and the base surface, and on the edges
forming the corners of the base surface

Figure 13-100  Edges selected to create rounds
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Figure 13-102  Completed surface model

1. You can create a surface with capped ends by drawing an open sketch. (T/F)

2. Surface models have no thickness. (T/F)

3. Style features have the parent-child relationship among themselves and as well as with Pro/
ENGINEER features. (T/F)

4. In the Style environment, using the Free option when you press the SHIFT key and select
a point on a surface then the point is selected on that surface. (T/F)

5. To create a Helical sweep surface, the procedure to follow is the same as in the case of
creating a solid Helical sweep feature. (T/F)

6. Any feature created in the Style environment is displayed in the Model Tree as a __________
feature.

7. To enter the Style environment, choose the __________ available in the Base Features
toolbar.

8. The __________ tool is used to merge two surfaces and form an edge.

9. In the Style environment, __________ button is used to draw curves.

10. A Quilt is a __________ feature.

Self-Evaluation Test



13-44                Pro/ENGINEER Wildfire for Designers: F09/04

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

C
ha

p
te

r 
fo

r 
fr

e
e

 d
o

w
nl

o
a

d.
 L

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
o

go
n 

to
 w

w
w

o
go

n 
to

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n
.c

a
dc

im
.c

o
m

 f
o

r 
m

o
re

 in
fo

rm
a

ti
o

n

Review Questions
Answer the following questions:

1. Which of the following feature creation tools contain the options like parallel, rotational,
and general?

(a) Sweep (b) Blend
(c) Extrude (d) None

2. Which of the following editing tools are used to create a flat surface by drawing a sketch?

(a) Trim (b) Copy
(c) Fill (d) None of the above

3. What is the minimum number of sections required for a blend feature?

(a) one (b) two
(c) three (d) None of the above

4. Which of the following editing tools forms an edge between two intersecting surfaces?

(a) Merge (b) Intersect
(c) Trim (d) None

5. In which one of the following types of blend, sections are translated and rotated about the x,
y, and z-axes?

(a) Parallel (b) Rotational
(c) General (d) None

6. The Intersect option is used to create an intersect curve. (T/F)

7. In the Style environment, the Edit curves button is used to project curves on surfaces. (T/F)

8. Surface models are 3D models with no thickness. (T/F)

9. In the Style environment, the Create surfaces from boundary curves button is used to
select at least three or four curves and create a surface. (T/F)

10. To undo the last operation, choose the Undo button from the Style toolbar. (T/F)
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Figure 13-104  Top, front, right-side, and the detailed views of the surface model

Figure 13-103  Isometric view of the surface model

Exercise 1
In this exercise you will create the surface model shown in Figure 13-103. The orthographic
views of the surface model are shown in Figure 13-104.    (Expected time: 40 min)

Note
Create the base feature using the Blend option and the ends as revolve features.

Exercises
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Figure 13-106  Top, front, right-side, and the detailed views of the surface model

Figure 13-105  Surface model

Exercise 2
In this exercise you will create the surface model shown in Figure 13-105. The orthographic
views and the detailed view of the surface model are shown in Figure 13-106.

   (Expected time: 55 min)

Answers to the Self-Evaluation Test
1 - F, 2 - T, 3 - T, 4 - T, 5 - T, 6 - Style, 7 - Style Tool, 8 - Merge Tool, 9 - Create curves, 10 - surface.


