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Overview of Practices for Lesson 1

Practices Overview
In these practices, you will test your understanding of the Database Architecture.
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Practice 1-1: Exploring the Database Architecture

Fill in the blanks with the correct answers.
1. The two main components of Oracle RDBMS are

and
2. Aninstance consists of and
processes.
3. A session is a connection between the process and either the
process or the process.

4. Name some components of the System Global Area (SGA).

5. List some background processes:

6. The process writes the dirty buffers to the data files.
The process writes the redo logs to the log files.
8. Name some files associated with an Oracle database.

™~

9. Some of the logical storage structures of an Oracle database are:

Copyright © 2010, Oracle and/or its affiliates. All rights reserved.

Practice 1-1: Exploring the Database Architecture
Chapter 1 - Page 3



10.
11.

12.

13.

14,

The
The

process copies the redo log files to an archive destination.
contains data and control information for a server or a

background process.

The logical tablespace structure is associated with the physical

files on disk.
State whether the following statements are true or false:

a.
b.

The SGA includes the Database buffer cache and the Redo log buffer.

Each server process and background process has its own Program Global Area
(PGA).

User processes run the application or Oracle tool code.

Oracle Database processes include server processes and background processes.

From a terminal session, connected as the oracle user, execute the processes.sh
script located in your SHOME/solutions/Database Architecture directory. What
does this script show you?

a.

It shows you all the database instance processes currently running on your machine.
This includes both background processes and foreground processes.

$ cd $HOME/solutions/Database Architecture
$ ./processes.sh

oracle 2891 3129 0 Junl4 ? 00:16:15
/u0l/app/oracle/product/11.2.0/dbhome 1/jdk/bin/java -server -Xmx192M
-XX:MaxPermSize=200M -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -
DORACLE_HOME=/u01l/app/oracle/product/11.2.0/dbhome 1 -
Doracle.home=/u0l/app/oracle/product/11.2.0/dbhome 1/o0c4j -
Doracle.oc4]j.localhome=/u0l/app/oracle/product/11.2.0/dbhome 1/edrsr4l
pl.us.oracle.com orcl/sysman -
DEMSTATE=/u01/app/oracle/product/11.2.0/dbhome 1/edrsr4lpl.us.oracle.c
om_orcl -Doracle.j2ee.dont.use.memory.archive=true -
Djava.protocol.handler.pkgs=HTTPClient -
Doracle.security.jazn.config=/u01l/app/oracle/product/11.2.0/dbhome 1/0
c4j/j2ee/0C4J DBConsole edrsr4lpl.us.oracle.com orcl/config/jazn.xml -
Djava.security.policy=/u0l/app/oracle/product/11.2.0/dbhome 1/oc4j/j2e
e/0C4J DBConsole edrsr4lpl.us.oracle.com orcl/config/java2.policy -
Djavax.net.ssl.KeyStore=/u0l/app/oracle/product/11.2.0/dbhome_ 1/sysman
/config/OCMTrustedCerts.txt-
Djava.security.properties=/u0l/app/oracle/product/11.2.0/dbhome 1/oc4j
/j2ee/home/config/jazn.security.props -
DEMDROOT=/u01/app/oracle/product/11.2.0/dbhome 1/edrsr4lpl.us.oracle.c
om_orcl -Dsysman.md5password=true -
Drepapi.oracle.home=/u0l/app/oracle/product/11.2.0/dbhome 1 -
Ddisable.checkForUpdate=true -
Doracle.sysman.ccr.ocmSDK.websve.keystore=/u0l/app/oracle/product/11.2
.0/dbhome_1/jlib/emocmclnt.ks -
Dice.pilots.html4.ignoreNonGenericFonts=true -Djava.awt.headless=true
-jar /u0l/app/oracle/product/11.2.0/dbhome 1/oc4j/j2ee/home/oc4j.jar -
config
/u0l/app/oracle/product/11.2.0/dbhome 1/oc4j/j2ee/0C4J DBConsole edrsr
41pl.us.oracle.com orcl/config/server.xml

oracle 3129 1 0 Jun08 ? 00:01:03

/u0l/app/oracle/product/11.2.0/dbhome 1/perl/bin/perl
/u0l/app/oracle/product/11.2.0/dbhome 1/bin/emwd.pl dbconsole
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/u0l/app/oracle/product/11.2.0/dbhome 1/edrsr4lpl.us.oracle.com orcl/s
ysman/log/emdb .nohup

oracle 3253 1 0 Junl4 ? 00:00:43 ora pmon_orcl

oracle 3255 1 0 Junl4 ? 00:00:00 ora vktm orcl

oracle 3259 1 0 Junl4 ? 00:00:00 ora gen0O_orcl

oracle 3261 1 0 Junl4 ? 00:00:00 ora_diag orcl

oracle 3263 1 0 Junl4 ? 00:00:00 ora_dbrm orcl

oracle 3265 1 0 Junl4 ? 00:00:32 ora pspO0_orcl

oracle 3267 1 0 Junl4 ? 00:19:33 ora_dia0 orcl

oracle 3269 1 0 Junl4 ? 00:00:00 ora_mman_orcl

oracle 3271 1 0 Junl4 ? 00:02:12 ora dbwO_orcl

oracle 3273 1 0 Junl4 ? 00:03:00 ora_lgwr orcl

oracle 3275 1 0 Junl4 ? 00:00:03 ora_ ckpt orcl

oracle 3277 1 0 Junl4 ? 00:01:44 ora smon_orcl

oracle 3279 1 0 Junl4 ? 00:00:00 ora_reco orcl

oracle 3281 1 0 Junl4 ? 00:01:50 ora mmon_orcl

oracle 3283 1 0 Junl4 ? 00:00:48 ora_mmnl_orcl

oracle 3285 1 0 Junl4 ? 00:00:00 ora do00 orcl

oracle 3287 1 0 Junl4 ? 00:00:00 ora s000_orcl

oracle 3340 1 0 Junl4 ? 00:00:00 ora_gmnc_orcl

oracle 3344 1 0 Junl4 ? 00:01:10 oracleorcl (LOCAL=NO)
oracle 3361 1 0 Junl4 ? 00:02:07 ora_cjg0 orcl

oracle 3379 1 0 Junl4 ? 00:00:08 ora g000_orcl

oracle 3381 1 0 Junl4 ? 00:00:01 ora g001 orcl

oracle 3532 1 0 Junl4 ? 00:00:00 oracleorcl (LOCAL=NO)
oracle 3534 1 0 Junl4 ? 00:05:40 oracleorcl (LOCAL=NO)
oracle 3536 1 0 Junl4 ? 00:04:42 oracleorcl (LOCAL=NO)
oracle 3538 1 0 Junl4 ? 00:13:05 oracleorcl (LOCAL=NO)
oracle 3599 1 0 Junl4 ? 00:12:10 oracleorcl (LOCAL=NO)
oracle 3614 1 0 Junl4 ? 00:00:01 oracleorcl (LOCAL=NO)
oracle 3617 1 0 Junl4 ? 00:05:40 oracleorcl (LOCAL=NO)
oracle 3855 1 0 Junl4 ? 00:00:00 ora_smco_orcl

oracle 7139 1 0 Julo4 » 00:00:02 oracleorcl (LOCAL=NO)
oracle 9861 1 0 Junls ? 00:01:03 oracleorcl (LOCAL=NO)
oracle 11366 1 0 15:14 » 00:00:00 ora w000 orcl

15. From a terminal session, connected as the oracle user, execute the files. sh script
located in your SHOME/solutions/Database Architecture directory. What does this
script show you?

a. This script shows you the location and hames of all database files, initialization file,
password file, and trace files.

$ cd $HOME/solutions/Database Architecture
$ ./files.sh

SQL>
SQL> col name format a45
SQL>
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SQL> select name from v$Scontrolfile;

/u0l/app/oracle/oradata/orcl/control0l.ctl
/u0l/app/oracle/oradata/orcl/control02.ctl
/u0l/app/oracle/oradata/orcl/control03.ctl

SQL>

SQL>

SQL> col member format a4b

SQL>

SQL> select group#,member from v$logfile;

GROUP# MEMBER
3 /ul0l/app/oracle/oradata/orcl/redo03.log
2 /u0l/app/oracle/oradata/orcl/redo02.log
1 /u0l/app/oracle/oradata/orcl/redo0l.log

SQL>

SQL>

SQL> col tablespace name format a20

SQL> col file name format a45

SQL>

SQL> select tablespace name, file name from dba data files;

TABLESPACE NAME FILE NAME

USERS /u0l/app/oracle/oradata/orcl/users0l.dbf
UNDOTBS1 /u0l/app/oracle/oradata/orcl/undotbs0l.dbf
SYSAUX /u0l/app/oracle/oradata/orcl/sysaux01l.dbf
SYSTEM /u0l/app/oracle/oradata/orcl/system0l.dbf
EXAMPLE /u0l/app/oracle/oradata/orcl/example0l.dbf
TRACETBS /u0l/app/oracle/oradata/orcl/tracetbs.dbf
TRACETBS3 /u0l/app/oracle/oradata/orcl/tracetbs3.dbf
SQL>

SQL> select tablespace name, file name from dba temp files;

TABLESPACE NAME FILE NAME

TEMP /u0l/app/oracle/oradata/orcl/temp0l1.dbf
SQL>

SQL> exit;
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-rw-rw---- 1 oracle oinstall 1544 Aug 22 2007
/u0l/app/oracle/product/11.1.0/db 1/dbs/hc_orcl.dat

-rw-Yr----- 1 oracle oinstall 1536 Mar 26 22:03
/u0l/app/oracle/product/11.1.0/db 1/dbs/orapworcl
-rw-Yr----- 1 oracle oinstall 2560 Mar 27 03:13

/u0l/app/oracle/product/11.1.0/db 1/dbs/spfileorcl.ora
alert cdump hm incident incpkg ir 1ck metadata stage sweep

trace

-rw-r--r-- 1 oracle oinstall 557386 Mar 27 13:00
/u0l/app/oracle/diag/rdbms/orcl/orcl/trace/alert orcl.log
$

#!/bin/bash

cd /home/oracle/solutions/Database Architecture

sqglplus / as sysdba @efiles.sql
ls -1 SORACLE HOME/dbs/*orcl*
ls /u0l/app/oracle/diag/rdbms/orcl/orcl

ls -1 /u0l/app/oracle/diag/rdbms/orcl/orcl/trace/alert*

col name format a45s

select name from vScontrolfile;

col member format a4b5

select group#,member from v$logfile;

col tablespace name format a20

col file name format a45

select tablespace name, file name from dba data files;

select tablespace name, file name from dba temp files;
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exit;

16. From a terminal session, connected as the oracle user, execute the sga. sh script
located in your SHOME/solutions/Database Architecture directory. What does this
script show you? (This script prints the various pools held in your SGA.)

$ cd $HOME/solutions/Database Architecture
$ ./sga.sh

SQL*Plus: Release 11.2.0.1.0 Production on Mon Jul 5 15:24:52 2010
Copyright (c) 1982, 2009, Oracle. All rights reserved.

Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing

options

SQL>

SQL> select * from v$sgainfo;

NAME BYTES RES
Fixed SGA Size 1339796 No
Redo Buffers 5144576 No
Buffer Cache Size 343932928 Yes
Shared Pool Size 192937984 Yes
Large Pool Size 4194304 Yes
Java Pool Size 4194304 Yes
Streams Pool Size 0 Yes
Shared IO Pool Size 0 Yes
Granule Size 4194304 No
Maximum SGA Size 845348864 No
Startup overhead in Shared Pool 58720256 No
NAME BYTES RES
Free SGA Memory Available 293601280

12 rows selected.

SQL>
SQL> col component format a30
SQL>

SQL> select component,current size,min size,max size from
vsmemory dynamic_components;

COMPONENT CURRENT_ SIZE MIN SIZE MAX SIZE

shared pool 192937984 167772160 192937984
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large pool

java pool

streams pool

SGA Target

DEFAULT buffer cache
KEEP buffer cache
RECYCLE buffer cache
DEFAULT 2K buffer cache
DEFAULT 4K buffer cache
DEFAULT 8K buffer cache

COMPONENT

DEFAULT 16K buffer cache
DEFAULT 32K buffer cache
Shared IO Pool

PGA Target

ASM Buffer Cache

16 rows selected.
SQL>
SQL> exit;

4194304
4194304

0
553648128
343932928
0

o O o o

CURRENT_SIZE

293601280
0

4194304
4194304

0
532676608
331350016
0

0
0
0
0

MIN SIZE

293601280
0

4194304
4194304

0
553648128
352321536
0

0
0
0
0

MAX SIZE

314572800
0

Disconnected from Oracle Database 11g Enterprise Edition Release

11.2.0.1.0 - Production

With the Partitioning, OLAP, Data Mining and Real Application Testing

options
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Overview of Practices for Lesson 2

Practices Overview

In these practices, you will get acquainted with SQL Developer functions, explore some
common mistakes and how to correct them.
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Practice 2-1: Using SQL Developer

1. Start Oracle SQL Developer.
Click the Oracle SQL Developer icon on your desktop.

[

SQL Developer

2. Create a database connection to the sSH schema using the following information:

Connection Name sh connection
Username: Sh

Password: Sh

Hostname: localhost

Port: 1521

SID: orcl

Right-click the Connections icon on the Connections tabbed page, and then select New
Connection from the shortcut menu. The New / Select Database Connection window
appears. Use the preceding information to create the new database connection.

Note: To display the properties of the newly created connection, right-click the
connection name, and then select Properties from the shortcut menu. Enter the
username, password, host name, and service name with the appropriate information, as
provided in the table. The following is a sample of the newly created database
connection for the sSH schema using a local connection:
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F- New / Select Database Connection il

Connection.. | Connecti...| Copnection Mame |sh_cunnecti0n |

Username |sh |

Passwaord |“* |

[] Save Password

Oracle IACCESSHMySQL"SQLSewerl

Role |defau|t v|

Connection Type (3) Basic () TMS () Advanced

-

() Service name |

Hostname ‘Iucalhust |
Port 1521 |
(@ 51D ‘ ore |

|

Status :

‘ Help | | Save | | Clear ‘ | Test ‘ ‘ Connhect ‘ ‘ Cancel |

3. Test the new connection. If the Status is Success, save the connection, and then connect to
the database using this new connection.

a. Double-click sh_connection on the Connections tabbed page.

b. Click the Test button in the New / Select Database Connection window. If the status is
Success, click the Connect button.
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THESE eKIT MATERIALS ARE FOR YOUR USE IN THIS CLASSROOM ONLY. COPYING eKIT MATERIALS FROM THIS COMPUTER IS STRICTLY PROHIBITED

New / Select Database Connection

Connection Mame Connection Details Connection Mame |5h_connection |
sh@/ flocalhost:152.. |WYEEISET T |5h |

Password |oo |

[] 5ave Password

Oracle

Role default ¥ [] 05 Authentication
Connection Type [ ] Kerberos Authentication

[ "] Proxy Connection

Hostname |Iocalhost
Port 11521
(3] SID |orc|

() service name|

I Status : Success I
Save ] [ Clear ] Test ] [ Connect Cancel ]

4. Create a new database connection named hr connection.

a. Right-click sh_connection in the Object Navigation tree, and select the Properties
menu option.

b. Enter hr connection as the connection name and hr as the username and
password, select Save Password, and then click Save to create the new connection.

c. Testthe new hr_connection connection.

New / Select Database Connection

Connection Mame Connection Details Connection Name |hr_connection |
hr@/ flocalhast: 152, [WYEETSET T |hr |

sh_connection sh@/ flocalhost:152..

Password |" |
Save Password

Oracle

Role [] 05 Authentication
Connection Type [ ] Kerberos Authentication

[ "] Proxy Connection

Hostname |Iocalhost
Port 11521
(=) SID |orc|

() service name|

Status : Success

Save ] [ Clear ] I Test ] [ Connect ] [ Cancel
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THESE eKIT MATERIALS ARE FOR YOUR USE IN THIS CLASSROOM ONLY. COPYING eKIT MATERIALS FROM THIS COMPUTER IS STRICTLY PROHIBITED

5. Repeat step 3 to create and test a new database connection named oe connection.
Enter oe as the database connection username and password.

New [ Select Database Connection

Connection Mame Connection Details Connection Name |oe_connection |
hr_connection hr@//localhost152.. | Username |oe |
or@/ flocalhost: 152

sh_connection sh@&/ flocalhost: 152,

Password |" |
[] sawe Password

Oracle

Role [ ] 05 Authentication
Connection Type [ ] Kerberos Authentication

[] Proxy Connection

Hostname ||ocalhost |
Port [1521 |
(2) 51D |orc| |

|

() Service namel

Status : Success

Save ] [ Clear ] I Test ] [ Cannect ] [ Cancel

6. Repeat step 3 to create and test a new database connection named sys connection.
Enter sys in the Username field, oracle 4U inthe Password field, and SYSDBA as the
role. From the Role drop-down menu, select SYSDBA as the role.

New [ Select Database Connection

Connection Name Connection Details Connection Name |sy5_connection |
hr_connection hr@/ flocalhost:152.. | Username |5,5,.5 |
oe_connection ce@/ flocalhost:152..
. Password |......... |
sh_connection sh@&/ flocalhost: 152,
sys_connection sys@/ flocalhost: 152 [ sawe Password
Oracle

Role SYSDEA ¥ [ ] 05 Authentication
Connection Type [ ] Kerberos Authentication

[] Proxy Connection

Hostname |Iocalhost |
Port [1521 |
(2) 51D |orc| |

|

() Service namel

Status : Success

Save ] [ Clear ] I Test ] [ Cannect ] [ Cancel ]
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Browsing the HR, SH, and OE Schema Tables

7. Browse the structure of the EMPLOYEES table in the HR schema.
a. Expand the hr connection connection by clicking the plus sign.
b. Expand Tables by clicking the plus sign.

c. Display the structure of the EMPLOYEES table. Double-click the EMPLOYEES table. The
Columns tab displays the columns in the EMPL.OYEES table as follows:

Oracle 5QL Developer

File Edit Miew Navigate Run Versioning Tools Help
GoEa 906 XEE O-O- &~ E.
[ Connections * | (1 = [ x| =) EHEMPLOYEES * =
% EE' _Tlp Columns Dat.a | Constraints | Grants |St.atistics |Trigger5 | Flashback | Dependencies | Details |Pa.r'titions | |;
a Connections |r :“/T @ SRR
[ Auto-Generated Local Connections @ corumn_name|g paTa_TYRE |8 wuiasie paTa_perauLT [ cotumnip [§ commenT
g hr [EMPLOYEE_TD NUMBER(5,0) No nu1l) 1Primary key
& Ea hr_corinection [FIRST_NAME \VARCHARZ (20 BYTE) Yes (nu1t) 2First name
|- T s Gieren) LAST_NAHE VARCHARZ (25 BYTE) No (U1t 3Last name ¢
. =-[FH CouNTRIES =
© Gi3- [ DEPARTMENTS EMATL VARCHARZ2 (25 BYTE) No (nu11) 4Enail id of
. » EIEES [PHONE_NUMBER VARCHAR2 (20 BYTE) Yes (nu11) 5Phone numbe
¢ - JOB_HISTORY HIRE_DATE DATE No (nu1l) 6 Date when t
- Joss JOB_ID VARCHARZ (10 BYTEJ No (nu11) 7 Current jok
-8 LocaTions SALARY NUMBER(S, 2) Yes (nu1l) 8 Monthly sal
é__%'ﬁ“:zmom COMMISSION_PCT NUMBER(Z,2) Yes (nu1l1) 9 Commission
@@ EdiA RS e MANAGER_ID NUMBER(5,0) Yes (nu11) 10 Manager id
L«EIEE Indexes DEPARTMENT_ID NUMBER.{4,0) Yes (nu1l1) 11 Department
E_@ Packages
[ﬁ] Procedures
% Functions
G0 Quaye

8. Browse the EMPLOYEES table and display its data.

a. To display the employee data, click the Data tab. The EMPLOYEES table data is
displayed as follows:
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H Oracle SQL Developer : Table HR.EMPLOYEES@hr_connection SEE

File Edit View Navigate Run Versioning Tools Help
GaEag 90 XEE O0-0-1&- E.
B, Connections x | (51 = [ x| ] |EJEMPLOYEES % =
EF Eﬂ ‘_d" Columns Data JConstraghis |Crants |Statistics |Triggers |Flashback | Dependencies |Detai|s |Par‘titions '_‘_EI
B, Connections W) B NI son. [Filter] | Actions... -
@[ Auto-Generated Local Connections B ewpovee n | FRsT_NAME|H LAST NAME|E EMaL | PHONE_NUMBER [ HIREDAT
w- 1 198 Donald 0Connell DOCONNEL 650.507.9833  21-JUN-07
=& hr_connection 2 199 Douglas Grant DCRANT 650.507.0844  13-JAN-08
& Tables (Fitered) 3 200 Jennifer Whalen JWHALEN 515.123.4444  17-5SEP-03
- COUNTRIES
] DEPARTLENTS 4 201 Michael Hartstein  MHARTSTE 515.123.5555  17-FEB-04
- [ EMpLOYEES 5 202 Pat Fay PFAY £03.123.6666  17-AUG-05
- [ JoB_HISTORY 3 203 Susan Mavris SMAVRIS 515.123.7777  07-JUN-02
- JoBs 7 204 Hermann Baer HBAER  515.123.8888 07-1UN-02
e LocaTions 8 205 Shelley Higgins SHIGGINS 515.123.8080  07-JUN-02
U___'E;EC'ONS 9 206 Willian Gietz WGIETZ 515.123.8181  07-JUN-02
- [ Editioning Views 10 100 Steven King SKING  515.123.4567  17-JUN-03
- [38 Indexes 11 101 Neena Kochhar NKOCHHAR 515.123.4568  21-SEP-05
- [ Packages 12 102 Lex De Haan LDEHAAN 515.123.4569  13-JAN-01
@Fﬁ Procedures 13 103 Alexander Hunold AHUNOLD 590.423.4567 D3-1AN-08
- Functions 14 104 Bruce Ernst BERNST 590.423.4568  21-MAY-O7
-8 Queue

9. Use the SQL Worksheet to select the last names and salaries of all employees whose
annual salary is greater than $10,000. Use both the Execute Statement (F9) and the Run
Script (F5) icons to execute the SELECT statement. Review the results of both methods of
executing the SELECT statements on the appropriate tabs.

a. Display the SQL Worksheet by using any of the following two methods: Select Tools >
SQL Worksheet, or click the Open SQL Worksheet icon. The Select Connection
window appears. Select hr connection. Enter the following statement in the SQL

Worksheet:

SELECT =*

FROM employees
WHERE SALARY > 10000;

1) Execute by pressing Ctrl+Enter or by clicking the Execute icon | 2
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in X | I|sh_connection~1 % | I|hr_connection~1 X JEMPLOYEES X [lu'_cmmﬂhn-—-ﬂ_ﬂ W=

FEEaY 26 a8 g &l Ed hr_connection =

SELECT *
FROM emplowvees
WHERE SALARY > 10000;

b W

[:}Quew Result *
& 5, ) Bk soL | Al Rows Fetched: 15 in 0.011 seconds

EMPLOYEE_ID |[§ FIRsT_nAME ([ LasT_NAME ([ EmAIL B PHONE_NUMEER HIRE_L

1 201 Michael Hartstein MHARTSTE 515.123.5555 17-FEB-Q
2 205 5helley Higains SHIGGINS 515.123.8080 07-1UN-0
3 100 Steven King SKING 515.123.4567 17-JUN-O
4 101 Neena kochhar NKOCHHAR 515.123.4568 21-5EP-0

2) Execute by pressing the F5 key or by clicking the Execute Script icon =

in X | Il sh_connection~1 * | Il hr_connection~1 X | JEMPLOYEES X [hr_cmmﬂion-—-i‘_ﬂ E]E]E]

FEBY RE 48 ¢ &l | 016 seconds EJ hr_connection =

SELECT *
FROM emplovees
LWHERE SALARY = 10000,

b, W

[ Query Result x  [&] Script Output
)f 4’ E 5 E| Task campleted in 0.16 seconds

EMPLOYEE_ID FIRST_NAME LAST_NAME EMAIL
201 Michael Hartstein MHARTSTE
205 Shelley Higgins SHIGGING
100 STewen king SEING
101 Neena kochhar HNEOCHHAR.
102 Lex e Haan LDEHALN
108 WNancy Greenberg WGREEMEE
114 Den Faphaelw DEAPHEAL
145 Jahn Fussell JRUSSEL
146 kKaren Fartners KPARETHER.
147 Alberto Errazuriz AEREAZLE,
148 Gerald Cambrault QCAMBREALU
149 Eleni Zlotkey EZLOTEKEY
167 Clara Wishney CWTSHMEY
168 Liza Nzer LOZER
174 E1len Ahel EABEL

15 rows cplarten

10. In the same SQL Worksheet, create and execute a simple anonymous block that outputs
“Hello World.”

Copyright © 2010, Oracle and/or its affiliates. All rights reserved.

Practice 2-1: Using SQL Developer
Chapter 2 - Page 9



a. Enable SET SERVEROUTPUT ON to display the output of the DBMS OUTPUT package
statements. Select View > Dbms Output. Click the green plus sign as shown to enable
DBMS OUTPUT.

[ZDbms Output * | m

ﬁ ¢ 8 | Buffer Size[20000 | -

| Enable DEMS_OUTPUT for connection |

b. Inthe dialog box that appears, select hr connection and click OK.

Select Connection

Select the connection you wish to use from the list or
create a new connection.

Connection: [a hr_connection v] % /
(o] [ canee ]

c. Use the SQL Worksheet area to enter the code for your anonymous block.

A4

ERRe® &E&vBld ¢ 0.53549403 seconds

Enter SGL Statement:

BEGIH
DEMS _OUTPUT. PUT_LINE( 'Hello World!'):
EHD ;

d. Click the Execute icon (Ctrl + Enter) to run the anonymous block.

The Script Output tab displays the output of the anonymous block as
follows:
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THESE eKIT MATERIALS ARE FOR YOUR USE IN THIS CLASSROOM ONLY. COPYING eKIT MATERIALS FROM THIS COMPUTER IS STRICTLY PROHIBITED

Ié_]Star‘t Page X -hr_connecﬁon x =)
EaY 2R BgRed ’a hr_connection v]
Begin pad
DEMS_OUTPUT.PUT_LINEC "HelTo World'y; _
END;
v
. W

[ statement Output *

A¢HEHE

ananymous hlock completed o
W

(ZDbms Output * | =

% ¢ B & |suffer sizej20000 " pall |

r_connection

Set serveroutput aon

Hello World
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Practice 2-2: Avoiding Common Mistakes

In this practice, you examine some common mistakes in writing SQL statements. You have to
find a workaround to enhance performance.

Case 1. Correlated Subquery

1.

2.

Execute the correlation setup.sh script from the

$HOME/solutions/Common Mistakes directory. Make sure that you run the script
connected as the sysdba user. You can find the scripts for all the following cases in your
$HOME/solutions/Common_ Mistakes directory.

Analyze a correlated subquery, in SQL Developer.

a. Goto Tools > Preferences.

b. Click Database > Worksheet.

Cc. Select /home/oracle/solutions/Common Mistakes as the default path.

\

(&8 )| Database: Worksheet

Environment []Autocommit in SQL Worksheet
[ Code Editor

; | Dpen a Worksheet on connect
----- Compare and Merge i

&l Database [ ] Close all worksheets on disconnect
""" Fovanced Prompt for Save file on close
----- Autotrace /Explain P
..... Drag And Drop Max FRows to print in a script |5EIDD |
..... MLS
_____ Objectviewer SQL History Limit 100 |
""" PL/SOL Compiler Select default path to look for scripts
""" Repor‘t.s |,."thEIGFaCIE}SOIutinnS,"Cﬂmmﬂn_MiStakES," Erowse |
----- SOL Editor Code Tem
- SQL Formatter This is the directory used when running a script using the @
----- Third Party JDEC Driv LB

..... ined Extensi [] Save Bind variables to disk on exit
ﬁ [] Automatically Freeze Result Tabs
[+ Debugger
----- Extensions
----- External Editor
----- File Types
- Clobal lgnore List
[ Migration

P

%

| Help OK J | Cancel

d. Click OK.
e. Add the files tab to the navigator pane. Select View > Files.
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WiA'M MNavigate Run Versionin

@= Ereakpoints Ctrl+5hift-F
Debugger ¥
Log Ctrl+5hift-L

@ Run Manager
Team b

5]| Connections
Data Mode]et b
f% Dbms Output

B Files

&8 Find DB Object
e

f.  Click the files tab.

File Edit. View Navigate Run Versionin
Fo@ag 90 XEE O -{

[ Connections % |[F] x |||3_Il )
W ¢

Elli}_ﬁ Recent Files
&0 My Computer

g. Inthe file explorer, open the
$HOME/solutions/Common Mistakes/correlation setup.sql file.

() Connections x |[E = [ = ]
2 €

=7 Common_Mistakes
------ bad_connect.sh

------ better_connect.sk
------ @ better_join.sql

------ @ better_predicate.s
------ @ better_union.sgl

------ cleanup_rest.sh

------ carrelation_clear
------ @ correlation_clean!
------ correlation_setup

------ @ correlation.sql

------ @ flush.sql
...... @ join.sqgl

------ El multiple_setup.sq

h. Run the script by clicking the Run Script icon. (Alternatively, press F5.) When you
execute the script, you must select a connection. Choose sys connection from the
drop-down menu, and then enter the sys password oracle 4U.
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mrrelat ion_setup.sql * |

WE a8 E 48 g 5l 059500003 seconds

--Execute as the sws user
al ter user sh identified by sh account unlock;

grant dba to sh;

i

El Script Output X

" (’f E 5 E | Task completed in 0.595 seconds

alter user sh succeeded.
grant dha succeeded.

3. Open a SQL Worksheet as the SH user (s