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 فصل سوم

 MAYAدر  بوجود آوردن سطوح سه بعدی

  



 Mayaدر نرم افزار  Modelingآشنایی با مفهوم 

  مفهومModeling 

  مدل ها و انیمیشن های سه بعدی مکانات موجود در نرم افزار مایا سبب افزایش بهره وری در ساخت ا   

می گردد و به آسانی می توان توسط این نرم افزار انیمیشن های پیچیده و غیر ممکن را طراحی و پیاده 

 . سازی نمود

مدل های سه بعدی و جلوه های بصری ویژه را می توان با استفاده از نرم افزار به گونه ای کاملا واقع گرایانه    

 .شبیه سازی نمود

نرم افزار طراحی و  ی بزرگ و پیچیده را نیز می توان توسط نرم افزار مایا و داده های هوشمند موجود دردنیا 

 . مدیریت کرد

  انواعModeling : 

 مایا دارای سه روش مدلسازی می باشد که عبارتند از :

1-Polygonal Modeling  

2-NURBS Modeling 

3-Subdivision Modeling 

 

Polygonal Modeling  : 

( صورت می گیرد و آبجکت هایی که بر اساس faceاین مدلسازی از طریق ساخت و تغییر تعدادی سطح )

 این مدل لیجاد می شوند ساختار چند ضلعی دارند.



NURBS Modeling : 

ها ، منحنی ها و ویرایش آنها بکار می رود و آبجکت هایی که براساس مدل  surfaceبرای مدلسازی 

NURBS . ایجاد می شوند ساختار منحنی دارند 

Subdivision Modeling : 

قابلیت ویرایش مدل با بیشترین سطح جزئیات و کمترین دیتا را دارد که کاربرد کمتری نسبت به روش 

 های دیگر دارد.

 

 

 

 

 

 سطوح پالیگان از سه قسمت اصلی تشکیل شده است:

Vertex  یا رأس 

Face یا سطح 

Edge یا لبه 

 

 

 

 



  با انتخاب موضوع و کلیک راست ماوس این سه گزینه نمایش داده می شوند و با انتخاب آنها اصطلاحا به

 می رویم. Componentحالت 

  اساس مدلسازی پالیگان همین کامپوننت ها هستند( که با تغییر آنها مثلا جابجاییMove ) کردن، در

 . ایجاد می شودموضوع تغییر 

 

 

 

 

 

 

 

 

 

 

  شناخت اصول ایجاد اشیایPolygon : 

 را باید انتخاب کرد. Polygon Primitivesگزینه ی  Createروش اول: از منوی      

 

 

 

 

 

 



 دسترسی خواهیم داشت. Polygonو به آبجکتهای ساده ی در این زیر من

 دادبا کلیک برروی نقطه چین بالای زیر منو می توان آنرا بصورت شناور در محیط کاری قرار  نکته:

 می توان به این گزینه ها دسترسی داشت. Polygonو سربرگ  Shelfاز نوار  روش دوم :

 

 

 

 

 

 

 

 

 عبارتند از: Polygonاشیای 

 Sphere )کره( 

 Cube )مکعب( 

 Prism )منشور( 

 Pyramid )هرم( 

 Pipe Helix )مارپیچ لوله یا فنر( 

 Soccer Ball )توپ فوتبال( 

 Platonic Solid )چندوجهی منتظم( 

 

 

 

 



  در کادرPolygon Primitives  مقابل هر گزینه یک مربع کوچک قرار دارد که با کلیک روی آن می

را فعال کرد . با استفاده از گزینه های داخل این پانل تنظیمات مربوط به شیء  Tool Settingsتوان پانل 

 انجام می شود .

  در پایین این کادر اگر گزینه یInteractive Creation عال کنیم شکل هندسی بطورپیش فرض را غیر ف

 در مرکز صفحه ترسیم می شود و نمی توان سطوح را با کلیک و درگ ترسیم کرد.

  اگر گزینه یExit on Completion  در حالت فعال باشد بعد از ترسیم شی، اشاره گر ماوس از حالت

 ترسیم خارج می شود و برای ترسیم شی ء بعدی باید دوباره آنرا انتخاب کرد.

 

 

 

 

 

 

 

 

 

نمایش  Channel Box/layer Editorبا ترسیم یک شیء پارامترهای مختلف آن در پانل : 1نکته 

استفاده  Inputsیه و سازنده ی آبجکتها باید از قسمت داده می شوند و برای دسترسی به پارامترهای اول

 کرد.

عبارتی مرتبط با شی ترسیم شده نمایش داده می شود که با کلیک روی آن فهرستی  Inputsدر قسمت 

 از پارامترهای سازنده ی شی ظاهر می شود.

 Channel Boxدارای تنظیمات بیشتر و پیشرفته تری نسبت به  Attribute Editorپانل  :2نکته 

می باشد.این پانل با انتخاب یک آبجکت دارای چندین سربرگ خواهد بود و اگر آبجکت پیچیده ای 

 انتخاب کنیم تعداد سربرگ ها بیشتر می شود.

 می گویند. Nodeبه هر یک از این سربرگها یک 



 مولفه های سازنده ی اشیاء :

 Object mode )سطح اصلی آبجکت( 

 Edge )لبه ها( 

 Face )سطوح( 

 UV )بافت دهی به آبجکت( 

 

 

 

 

 

 

 

 

و مولفه های  Marking Menuبا پایین نگه داشتن کلید ماوس روی شیء  روش اول انتخاب مولفه ها :

 سازنده ی شی ء ظاهر می شود.

      می توان چندین سطح را انتخاب کرد و همینطور با shift، با استفاده از کلید Faceبا انتخاب  نکته : 

 کلیک روی یک سطح کل سطوح را نیز می توان انتخاب کرددابل 

را انتخاب  بدون جابجا شدن بین مولفه ها بطور همزمان همه ی مولفه ها  Multiبا انتخاب گزینه ی  نکته :

 و ویرایش کرد

  شده و به حالت اصلی آبجکت برمی گردیم از مولفه ها خارج object modeبا انتخاب  نکته :

  

 Select By Object Typeبطور پیش فرض آیکن  Status lineروش دوم انتخاب مولفه ها : در نوار 

می توان آیکن مولفه های مختلف  Select By Component Typeدر حالت انتخاب است و با انتخاب 

 نمایش داد. Status Lineرا در 



 

 

 

 

 

 

  ابزارهای ویرایش سطوح:دستورات و 

ده اند. ابزارهای ویرایش پالیگان در مایا دستورات و ابزارها با توجه به عملکردهایی که دارند دسته بندی ش

 قرار دارند. Mesh Toolsو Mesh ، Edit Meshدر منوهای 

  دستوراتBoolean: 
 آبجکتهای جدید ایجاد کرد.با این دستورات می توان با اضافه کردن و یا کم کردن آبجکتها از هم 

Mesh   -->  Combine  -->  Boolean 

 دو شیء که باهم قسمت مشترک هم داشته باشند روی صفحه ایجاد می کنیم . -1

 3هر دو شی ء را انتخاب می کنیم . shiftبا کلید  -2

 را انتخاب می کنیم.  Mesh -->Booleanاز منوی  -3

 

 

 

 

 

 

 



  دستورUnion : 

را فعال کنید تا اشیاء به حالت نیمه شفاف  Shading -->  X-Ray برای درک بهتر این گزینه از منوی  

 دیده شوند.

قسمتهای مشترک دو شیء حذف شده و آبجکتها باهم ترکیب می شوند و یک  Unionبا انتخاب گزینه ی 

  ایجاد می گردد.آبجکت واحد 

 

 

 

 

 

 

 

 

 

 

  دستورDifference : 

  شیء دومی از شیء اولی کم می شود . )دومین آبجکت  Differenceبا انتخاب دو آبجکت و گزینه ی   

  در نظر گرفته می شود( Operator بعنوان عملگر یا

 را غیر فعال کنید. shading  --> X-Rayبرای درک بهتر این گزینه از منوی 

             

 

 

 

 

 

 



  دستورIntersection : 

 آبجکت در صفحه باقی بماند. وموجب می شود که فقط قسمت مشترک دانتخاب این گزینه 

 

 

 

 

 

 

 

 

 

  دستوراتDeformers : 
 ها بکار می رود. برای تغییر شکل کلی در آبجکت

را انتخاب  Animationرا باز کنید . سپس گزینه ی  Menu Setآبجکت مورد نظر را انتخاب کرده و -1

را انتخاب و در مربع کناری آن کلیک  Latticeگزینه ی  <-- Create Deformersکنید . حال از منوی 

 کنید.

 createمی توان جزئیات مربوط به دستور را تغییر داده و روی دکمه ی  Lattice Optionsدر کادر 

کلیک کرد.بدین ترتیب شبکه ای در اطراف آبجکت ایجاد می شود و با انتخاب این شبکه تنظیماتی در 

Channel Box  وAttribute Editor .ظاهر می شود 

را انتخاب کنید در واقع مشابه  Lattice Pointروی آن راست کلیک کرده و  Latticeبرای تغییر  -2

Vertex .عمل می کند 



را باید انتخاب  Edit --> Delete By Type --> Historyپس از اعمال تغییرات دلخواه از منوی  -3

 حذف شود. Latticeکرد تا 

 

 

 Deformer  غیرخطی :های 
 عبارتند از: این دستورات که بسیار پرکاربرد در انیمیشن سازی می باشند

 Bend : 

 برای ایجاد خمیدگی در شکل استفاده می شود.

 انتخاب آبجکت-1

 نقطه چین بالای زیرمنو <-- Create Deformers --> Nonlinearکلیک روی  -2

 که با این کار یک خط عمودی یا دستگیره بر روی مدل قرار می گیرد. Bendکلیک روی گزینه ی  -3

 کلیک کنید. bend1بر روی  Channel Boxدر  Inputsدر قسمت  -4

بر روی شیء  Deformerاست که برای تعیین میزان تاثیر  Curvatureمهمترین تنظیم این قسمت  -5

 استفاده می شود .

 جابجا کرد یا دوران داد.همچنین می توان خط عمودی مربوط به آن را -6



7- Deformer .ها را می توان فقط بر روی قسمتی از آبجکت هم اعمال کرد 

 

 Flare : 

 می توان قسمت هایی از آبجکت را پهن تر و یا باریک تر کرد. Deformerبا این 

 انتخاب آبجکت -1

2- Create Deformers -->  Nonlinear  --> Flare   

می شود که این دستور در محدوده ی دو دستگیره ی دایره ای  یره در شکل نمایش دادهدو دستگ -3

 تاثیرگذار است.

 کلیک کنید. Flare1بر روی روی  Channel Boxدر  Inputsدر قسمت -4

 و تغییر آن می توان در آبجکت تغییرات ایجاد کرد. Curveبا انتخاب پارامتر  -5

 چندین پارامتر مهم این دستور عبارتند از: -6

Start flare X : حدوده ی ابتدایی در راستای محور مX 

End flare X :  محدوده ی انتهایی در راستای محورX 

Start flare Z :  محدوده ی ابتدایی در راستای محورZ 



End flare Z :  محدوده ی انتهایی در راستای محورZ 

Low Bound  وHigh Bound .برای تغییر محل دستگیره ها بکار می رود 

 
 

 Sine : 

 :توان آبجکت را بصورت موج های سینوسی تغییر شکل داد  فرمر می با این دی

 انتخاب آبجکت -1

  Nonlinearدر  Sineکلیک رو -2

 Inputsدر  Sine1کلیک در -3

 برای ایجاد امواج در آبجکت Amplitudeتغییر پارامتر -4

 برای تعداد و طول موج ها Wave Lengthتغییر پارامتر  -5

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 Squash : 

 عمل می کند و با آن میتوان حالت کشیدگی و فشردگی در آبجکت ایجاد کرد. Flareمشابه  

  Expandتغییر در میزان کشیدگی شکل با  و Factorرامتر اتغییر شکل با پ                

 

 Twist : 

 برای ایجاد پیچش در آبجکت مورد استفاده قرار می گیرد.   -    

  End Angleو  Start Angleایجاد پیچش در شکل با   -

  High Boundو  Low Bound باش تعیین محدوده ی پیچ   -   



 

 

 

 

 

 

 

 

 

 

 Wave : 

 ایجاد کرد.در آبجکت  ی راامواج ن دستور میتوانایبا  -

 برای تغییر طول  Wave Lengthوپارامتر  برای ایجاد امواج در آبجکت Amplitudeتغییر پارامتر  -  

 موج بکار می رود.

          

 

 

 

 

 

 

 

 Combine : 

 برای ترکیب چند ابجکت به یک آبجکت واحد از این دستور استفاده می شود.  

Mesh --> Combine --> Combine 



 

 

 

 

 

 

 

 

 

 

 

 Separate 

 برای جدا کردن پالیگان آبجکت های ترکیب شده استفاده می شود. 

Mesh  --> Combine --> Separate  

 

 Conform : 

 های یک آبجکت به سطح آبجکت دیگر استفاده می شود. vertexبرای چسباندن 

 برای اینکار حداقل به دو پالیگان آبجکت نیاز داریم .  -1

 هیم ورتکس هایش را جایگزین کنیمانتخاب آبجکتی که می خوا -2

3-Modify  --> Objects --> Make Live  

 انتخاب شکلی که می خواهیم چسبانده شود. -4

5- Mesh --> Remesh --> Conform  

 



 Construction History : 

برای ثبت تاریخچه ساخت و ساز اشیاء بکار می رود تا بتوان  Construction History On/Offکلید  

 تغییرات بوجود آمده روی یک آبجکت را درمراحل بعدی ردیابی کرد.

 

 

 

 

 

 

 

 

 :ها Componenetشناخت اصول کار با 

اگر روی  .های پیچیده ای ایجاد کرد می توان آبجکت Polygon Primitiveبا ویرایش اجزای یک   

آبجکت راست کلیک کنیم و کلید را نگه داریم مارکینگ منو باز می شود که از طریق آن می توان به 

Vertex ،Edge ،Face وUV .دسترسی پیدا کرد 

 های یک آبجکت فعال را انتخاب  faceدر مارکینگ منو به ما اجازه می می دهد تا  Faceحالت انتخاب   

  .کنیم

به رنگ قرمز در می آید که با انتخاب آن به رنگ سبز  face، آن faceبا بردن اشاره گر ماوس به روی یک  

 تغییر می کند.

 

  گزینه یMulti  ،هم باعث می شود تمام اجزا را همزمان و بدون نیاز به سوئیچ کردن بین کامپوننت ها

 انتخاب کرد.

 Create Polygon : 

 استفاده می شود. view portها در vertexبرای ایجاد پالیگان ها با قرار دادن 

Mesh Tools > Tools > Create Polygon  



 

 

 

 

 

 

 

 

 

 

 Transforming : 

 با این ابزار میتوان در آبجکت مورد نظر با استفاده از ورتکس ها تغییر شکل ایجاد کرد.   

Edit Mesh > Transform Component  
 

 

 

 

 

 Adding : 

های یک پالیگان را به اجزای کوچکتر تقسیم  faceها یا  edgeتوان  می Add Divisionsبا ابزار 

 کرد.

 faceیا  edgeانتخاب  -1

2-Edit Mesh > Components > Add Divisions  



 

 

 

 

 

 

 

  ابزارBevel : 

 برای انبساط ورتکس یا فیس مربوط به یک پالیگان استفاده می شود.   

Edit Mesh  > Components > Bevel 
 

 

 

 

 

 

  ابزارBridge : 

 بکار می رود. border edgeبین دو  faceبرای ساختن 

Edit Mesh > Components > Bridge 
 

 

 

 

 

 

 

 

 



  ابزارCollapse : 

 ها استفاده می شود.edgeبرای از هم باز کردن    

Edit Mesh > Components > Collapse 
 

 

 

 

 

 

 

 
 

  ابزارConnect : 

 ها بکار می رود.edgeها، از طریق faceهای انتخاب شده یا vertexبرای متصل کردن 

Edit Mesh > Components > Connect 

 

 

 

 

 

 

  ابزارDetach : 

 مورد استفاده قرار می گیرد. faceیا چند  vertexبه چند  faceیا  vertexبرای شکافتن یک   

Edit Mesh > Components > Detach 



 

 

 

 

 

 

  ابزارExtrude : 

، به بیرون یا داخل edgeو یا  vertex ،faceپالیگان مانند برای اکسترود کردن اجزای مختلف از یک   

 بکار می رود.

Edit Mesh > Components > Extrude 
 

 

 

 

 

 

 

 

 

  ابزارMerge : 

 استفاده می شود. vertexبرای ترکیب کردن دو   

Edit Mesh > Components > Merge 



 

 

 

 

 

 

 

 

 

 

 : Delete Edge/Vertexابزار   

 های انتخاب شده از یک پالیگان آبجکت استفاده می شود.vertexها یا  edgeبرای حذف کردن 

Edit Mesh > Edge > Delete Edge/Vertex 

 

 

 

 

 

   

 

 : Chamfer Verticesابزار 

 شده بکار می رود. chamferبرای جایگزینی یک ورتکس به منظور ایجاد یک گوشه ی 

Edit Mesh > Vertex > Chamfer Vertices /Vertex 



 

 

 

 

 

 

 

 

 : NURBSایجاد اشیای 

برای ساختن سطوح  با منحنی های پیچیده مناسب می باشد. سطوح  NURBSمدلسازی بر پایه ی 

NURBS .را میتوان به صورت تعاملی و به سادگی تغییر داد 

Create > Objects > NURBS Primitives 

 

 

 

 

 

 

 

 

 

 

،  Isoparm ،Hull ،Control Vertexدارای اجزای معینی می باشد مانند :  NURBSهرآبجکت 

Surface UV ،Surface Patch  وSurface Point  



 
 

 
 

ها را با ابزارهای مختلفی ایجاد کنید.بعضی از این ابزارها عبارتند  NURBS Curveشما در مایا میتوانید 

 از:

  ابزارCV Curve Tool :  

Create  > Objects > Curve Tool > CV Curve Tool 
 

 

 

 

 

 

 

 



 مورد استفاده قرار می گیرد. viewportبرای ایجاد منحنی ها در 

  ابزارEP Curve Tool : 

Create  --> Objects --> Curve Tool --> EP Curve Tool 

 

 

 

 

 

 

 

 

 

 

 برای ایجاد یک طرح کلی از یک منحنی با قرار دادن نقطه های ویرایش روی آن است.

 

  ابزارPencil Curve Tool : 

Create  --> Objects --> Curve Tool --> Pencil Curve Tool 

 یا قلم در نرم افزارهای دیگر عمل می کند.) ترسیم دست آزاد منحنی ( Brushمانند 

 

  ابزارArc Tool : 

Create  --> Objects --> Curve Tool --> Arc Tool 

 مورد استفاده قرار می گیرد. viewportنقطه هایی در نی با قرار دادن برای ایجاد منحنی های کما



 یا سطح ها: Surfaceابزار موجود برای ایجاد 

 مایا مجهز به تعدادی ابزار برای ایجاد سطوح سه بعدی پیچیده است.

  ابزارLoft : 

 برای روکش کردن یک سطح روی منحنی های معرف استفاده می شود.)حداقل به دو منحنی نیاز داریم(

 از منو ست Modelingانتخاب 

Surfaces --> Create --> Loft 

 

 

 

 

 

 

 

 

 

 

 

  ابزارPlanar : 

 استفاده می شود. planeبا قرار گرفتن تمام ورتکس ها روی همان  NURBS Surfaceبرای ایجاد یک   

Surfaces --> Create --> Planar 

  ابزارRevolve : 

 شود. برای ایجاد یک سطح دور منحنی معرف در طول محور مشخص شده استفاده می  

Surfaces > Create > Revolve 



  ابزارBirail : 

Surfaces > Create > Birail 

برای ایجاد سورفیس ها با استفاده از یک منحنی یا دو منحنی معرف در طول دو منحنی که بعنوان مسیر    

 مشخص می کنید، استفاده می شود.

 

  ابزارExtrude: 

 Surfaces > Create > Extrude 

کردن یک آبجکت مشخص با کشیدن منحنی معرف آن در طول منحنی مسیر ، استفاده  Extrudeبرای  

 می شود.

  ابزارBoundary : 

Surface  > Create > Boundary 

 برای ایجاد یک سطح با پر کردن خطوط مرزی استفاده می شود.

  ابزارSquare : 

 با استفاده از چهر خط متقاطع، استفاده می شود. NURBSبرای ایجاد یک سطح  

Surface > Create > Square 

  ابزارBevel : 

سه بعدی بر خطوط انتخاب شده ، استفاده  edgeبا استفاده از اعمال تاثیر  NURBSبرای ایجاد یک سطح 

 می شود.

Surface > Create > Bevel 
 

  ابزارBevel Plus : 

 شده استفاده می شود.  Extrudeبه سطح  bevelکردن منحنی های بسته و افزودن  extrudeبرای  



Surface > Create >Plus  Bevel 

 : NURBSویرایش سطوح 

Surfaces > Edit NURBS Surfaces 
 

 

 

 

 

 

 

 

  ابزارDuplicate NURBS Patch : 

 وجود استفاده می شود. NURBS Patchبرای ایجاد سطح جدید از 

  ابزارTrim  : 

 که توسط منحنی ها مشخص شده ، استفاده می شود. NURBSبرای پنهان کردن قسمتی از سطح 

 ابزارUntrim : 

 شده استفاده می شود. trimبرای برگرداندن قسمت 

  ابزارAttach : 

 استفاده می شود. NURBSبرای پیوند دو سطح 

  ابزارAlign : 

 بکار می رود. NURBSبرای تراز کردن دو سطح 

 



 
 

 ابزارDetach : 

 به چند قسمت استفاده می شود. NURBSبرای تقسیم سطوح 

  ابزارOpen/Close : 

 مورد استفاده قرار می گیرد. NURBSبرای باز کردن یا بستن سطوح 

  ابزارExtend : 

 بکار می رود. NURBSبرای گسترش سطوح 

  ابزارIsoparm Insert : 

 بکار می رود. NURBSدر سطح  Isoparmبرای قرار دادن 

  ابزارRebuild : 

 بکار می رود. BURBSبرای بازسازی سطوح 

  ابزارSculpt Geometry Tool : 

 به صورت دستی بکار می رود. Polygonیا  NURBSبرای برجسته سازی و حجاری یک آبجکت 

 : Reverse Dierctionابزار 

 از سطح انتخاب شده بکار برده می شود. Vو  Uبرای معکوس کردن یا عوض کردن جهت های 

  تبدیلNURBS   بهPolygon : 

Modify > Objects > Convert NURBS to Polygons  

 

  ابزار مبدلNURBS to Polygons  برای تبدیل مش هایNURBS  به آبجکت هایPolygon 

 استفاده می شود.



 

 

 

 

 

 

 

 

 

 : Subdivبه  NURBSتبدیل 

Modify --> Objects --> Convert --> NURBS to Subdiv  

بکار می  Subdiv به مش های  NURBSبرای تبدیل مش های  NURBS to Subdivابزار مبدل 

 .رود
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